Foros del Web » Creando para Internet » CSS »

problema con los bordes y el color de fondo con a:hover en ie7

Estas en el tema de problema con los bordes y el color de fondo con a:hover en ie7 en el foro de CSS en Foros del Web. Hola a todos, he estado buscando en el foro y he encontrado varias cosas pero nada especifico al problema que tengo. a ver tengo una ...
  #1 (permalink)  
Antiguo 14/11/2008, 06:54
 
Fecha de Ingreso: octubre-2007
Mensajes: 27
Antigüedad: 10 años, 2 meses
Puntos: 0
problema con los bordes y el color de fondo con a:hover en ie7

Hola a todos, he estado buscando en el foro y he encontrado varias cosas pero nada especifico al problema que tengo.

a ver tengo una barra de navegacion donde cuando pasas el raton sobre el enlace, el estado hover, se cambia el color de fondo del enlace. En fdirefox, chrome, ie6 sin problema, pero en ie7 tarda muchisimo en hacer el efecto y claro que no puedes hacer otra cosa mientras el efecto carga.

el codigo es sencillo:

#barra_navegacion li a:link, #barra_navegacion li a:visited{
font-size: 10px;
color: #636261;
font-weight: normal;
border: 1px solid #ffffff;
}

#barra_navegacion li a:hover {
display: block;
background-color: #cdd8e3;
}

y en el html

<div id="barra_navegacion">
<ul>
<a href="#" class="titulo_enlace">Qué Hacemos</a>
<br />
<li><a href="../diseno-web-malaga.htm">Diseño Web</a></li>
<li><a href="../imagen-corporativa.htm">Imagen corporativa</a></li>

obviamente no pongo todo el codigo, solo a modo de ejemplo.

Es la primera vez que veo algo así, os enseñaria la web y vereis lo que tarda el efecto hover, pero no puedo por ahora por motivos comerciales.

no se si a alguien le ha pasado algo asi, yo es la primera vez que lo veo y aora mismo estoy flipandolo con el puto ie7 de los huevos y lo pero de todo que ya sale el 8 juas otro navegador mas para optimizar jajjaaja

Si me podeis ayudar os lo agradezco muchisimo.

Un saludo
  #2 (permalink)  
Antiguo 14/11/2008, 07:24
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: problema con los bordes y el color de fondo con a:hover en ie7

Quitale el display:block al hover, pienso que no lo necesita, si tiene eso el Chrome no reconoce el hover, el fflo reconoce como si fuera widht: 100% y el ie6 también y encima lo abre y tambien en el ie7. y si le quitas el block ya no pasará eso.

Bye..
  #3 (permalink)  
Antiguo 14/11/2008, 09:30
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: problema con los bordes y el color de fondo con a:hover en ie7

Soy de la misma opinión que willyfc: no creo que el display ahí te haga falta (aunque depende de cómo esté hecho todo, claro).

No obstante tienes otro error en el html:

Cita:
<div id="barra_navegacion">
<ul>
<a href="#" class="titulo_enlace">Qué Hacemos</a>
<br />

<li><a href="diseno-web-malaga.htm">Diseño Web</a></li>
<li><a href="imagen-corporativa.htm">Imagen corporativa</a></li>
Cuando haces una lista no debes poner cosas fuera de los elementos de la lista, es decir, si comienzs un "ul", lo que debe estar por debajo de él deben ser sólo "li's", y luego dentro de estos lo que sea.
__________________
Visita mi nueva web idplus.org
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:19.