Foros del Web » Creando para Internet » CSS »

Problema con capas e Internet Explorer 6

Estas en el tema de Problema con capas e Internet Explorer 6 en el foro de CSS en Foros del Web. Hola todos, tengo un grave problema. He publicado una nueva version de la pagina de mi plantel para el cual laboro, maquete la pagina con ...
  #1 (permalink)  
Antiguo 20/05/2008, 20:33
 
Fecha de Ingreso: enero-2006
Mensajes: 3
Antigüedad: 11 años, 10 meses
Puntos: 0
Problema con capas e Internet Explorer 6

Hola todos, tengo un grave problema. He publicado una nueva version de la pagina de mi plantel para el cual laboro, maquete la pagina con capas y cual ha sido mi sorpresa que en todos los navegadores se ve a la perfeccion pero en Internet Explorer 6 me hace un cochinero. Aqui os mando mi pagina espero me puedan ayudar.

http://www.cunorte.udg.mx/
  #2 (permalink)  
Antiguo 21/05/2008, 02:44
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema con capas e Internet Explorer 6

Lo primero de todo debeo decirte que estás repitiendo los identificadores (ID) de unas cajas a otras, como boxControl y otras, y eso no se debe hacer. El identificador, como su propio nombre indica, debe servir para identificar y diferenciar una única caja como sujeto único. Para llamar a varios con las mismas propiedades se debe usar class.

En segundo lugar, tu problema con IE6 es que entre el tamaño de las cajas y sus márgenes, sencillamente no caben en el ancho de su contenedora. Y no saques la calculadora, que no hace falta. Recuerda que para IE6 2+2 no son 4, sino 4,1. Increíble pero es así. Lo único que puedes hacer es hacer pruebas reduciendo el tamaño de alguna caja pixel a pixel hasta que se coloque en su sitio.

Mikel.
  #3 (permalink)  
Antiguo 21/05/2008, 10:13
 
Fecha de Ingreso: enero-2006
Mensajes: 3
Antigüedad: 11 años, 10 meses
Puntos: 0
Respuesta: Problema con capas e Internet Explorer 6

Que tal Mikmoro Agradezco infinitamente tu ayuda... La verdad soy algo nuevo con esto de las hojas de estilo, tomare en muy en cuenta tus observaciones... Repeti el identificador (ahora se que no lo debo hacer) ya a todos los layers les queria poner los bordes redondos... Pero bueno, que bueno que me dices que estoy mal. Lo corregirè y te digo que pasa.

Saludos y Gracias
  #4 (permalink)  
Antiguo 21/05/2008, 13:27
 
Fecha de Ingreso: enero-2006
Mensajes: 3
Antigüedad: 11 años, 10 meses
Puntos: 0
Respuesta: Problema con capas e Internet Explorer 6

Que tal, al parecer ya corrigi el problema con los layers y ahora la pagina mas o menos se ve bien con IE6, solo en algunas paginas, las que incluyen algun imagen grande son las que no se ven bien, tal es el caso de:

http://cunorte.udg.mx/conoce/organigrama/index.html

es acaso que le pone algun margen a la imagen, cómo quitarselo... agrdecería su ayuda
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:04.