Foros del Web » Creando para Internet » CSS »

problema con fixed (iexplorer)

Estas en el tema de problema con fixed (iexplorer) en el foro de CSS en Foros del Web. Buenos días. tengo el siguiente CSS Código PHP: textarea  {          font : 1.1em Verdana ,  Arial ,  Helvetica ,  sans - serif ;          color ...
  #1 (permalink)  
Antiguo 19/08/2008, 10:06
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
problema con fixed (iexplorer)

Buenos días. tengo el siguiente CSS

Código PHP:
textarea {
        
font:1.1em VerdanaArialHelveticasans-serif;
        
color:#333;
        
margin:3px;
        
height:165px;
        
border:solid 0 #fff;
        
padding0 8px;
        
backgroundtransparent url("../../../templates/test/images/textarea.gif"no-repeat fixed;
        
width:200px;
        
voice-family"\"}\""
        
voice-family:inherit;
        
width:200px;
    } 
Si le pongo el fixed, no me muestra la imagen, ya leí que el fixed no funciona en iexplorer, ya lo traté de hacer de mil formas, pero la imagen se sigue moviendo dentro del textarea, en firefox no pasa eso, la imagen se mantiene estática y lo que se mueve es el texto, hay algo que pueda hacer para solucionar este problema, que la imagen no se mueva dentro del textarea en iexplorer.

Gracias de antemano, salu2
  #2 (permalink)  
Antiguo 19/08/2008, 10:16
 
Fecha de Ingreso: junio-2007
Ubicación: Buenos Aires, Argentina
Mensajes: 262
Antigüedad: 10 años, 6 meses
Puntos: 1
Respuesta: problema con fixed (iexplorer)

Lo que se me ocurre es que metas el TEXTAREA en un DIV, teniendo este último la imagen de fondo. No sé si es lo más ortodoxo, pero seguro funciona.

Éxitos!
Pablo
__________________
Moebius Digital | La pieza que faltaba
Diseño web | Web hosting
  #3 (permalink)  
Antiguo 19/08/2008, 10:34
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Respuesta: problema con fixed (iexplorer)

mira yo lo probé con esto:

Cita:
textarea {
font:1.1em Verdana, Arial, Helvetica, sans-serif;
color:#333;
margin:3px;
height:165px;
border:solid 0 #fff;
padding: 0;
background: transparent url("amarillo.jpg") no-repeat fixed;
width:200px;
}
En FF3 / IE6 / IE7 y en los tres me funciona bien.
  #4 (permalink)  
Antiguo 19/08/2008, 10:36
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: problema con fixed (iexplorer)

Te refieres a un div de CSS o auna etiqueta <div>.

A ver con css sería algo asi??

Código PHP:
div#textarea{
       
bla...
       
bla...

Bueno probaré, si me equivoqué a ver si me corrigen porfavor, grax.
  #5 (permalink)  
Antiguo 19/08/2008, 11:08
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: problema con fixed (iexplorer)

Probé lo de dragonX pero sigo en las mismas, no me aparece la imagen, seguiré viendo si saben de algo me avisan, grax
  #6 (permalink)  
Antiguo 19/08/2008, 13:34
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Respuesta: problema con fixed (iexplorer)

no te acepta la imagen???

no la ves?
  #7 (permalink)  
Antiguo 19/08/2008, 14:13
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: problema con fixed (iexplorer)

Está muy raro, probé localmente el script con wampserver, le puse una posicion a la imagen y le puse fixed en el attachment, y me respeta bien lo que le digo, me pone la imagen y no la desplaza.

Cuando en el sitio pongo los mismos atributos, no lo respeta, se me hace muy raro pongo por ejemplo:

background: transparent url("imagen.gif") no-repeat scroll;

entonces me muestra la imagen, pero si escribo:

background: transparent url("imagen.gif") no-repeat fixed;

no me la muestra, no tengo ni idea de lo que estoy haciendo mal, o porque no me muestra ni siquiera la imagen, si hay alguna idea sería genial, mientras seguiré intentando a ver que puedo lograr, gracias
  #8 (permalink)  
Antiguo 19/08/2008, 14:18
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Respuesta: problema con fixed (iexplorer)

y entoncés proba con esto:

Cita:
background: transparent url("imagen.gif") no-repeat;
background-position:top;
background-attachment: fixed;
A ver que pasa.....
  #9 (permalink)  
Antiguo 19/08/2008, 14:33
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: problema con fixed (iexplorer)

ok hice lo anterior, y se ve la imagen, cuando muevo el scrollbar de la página, si por ejemplo tengo el scrollbar hasta arriba no se ve nada, pero si desplazo el scrollbar hacia abajo empiezo a ver la imagen,

Eso quiere decir que la imagen está ahi, pero no la veo en la posición donde la ocupo, voy a mover los valores de la posicion y yo creo que debería funcionar con eso.

Te cuento en un momento.
  #10 (permalink)  
Antiguo 19/08/2008, 14:50
 
Fecha de Ingreso: mayo-2006
Mensajes: 58
Antigüedad: 11 años, 7 meses
Puntos: 0
Respuesta: problema con fixed (iexplorer)

Tengo una <tabla> donde pongo el <textarea> entonces si pongo:

Cita:
background: transparent url("imagen.gif") no-repeat;
background-position:top;//o cambio aqui por 'center' o 'bottom'
background-attachment: fixed;
Lo pone respecto a la tabla es decir en el top de la tabla (o bottom, o center).

Traté de darle valores en 'x' y 'y' a la posición pero nada, no me la muestra solamente si pongo lo anterior, o si le quito el fixed

La verdad ya me desesperé, hay alguna otra forma de poner la imagen? bueno te cuento que la intenté poner directamente en el atributo style del <textarea>, y tampoco pude, jajaja yo se que se puede pero le he dado muchas vueltas y parece que sigo en las mismas jejeje.

/**********************************Actualizacion*** ***************************/

Lo logré por fin, pongo el código quien sabe si alguien lo pueda utilizar, o le sirva de algo pero lo pongo de todas formas:

Cita:
textarea{
border: solid 0 #fff;
height: 170px;
width: 220px;
padding: 0 8 px;
background:transparent url("textarea.gif") no-repeat;
background-position: 270px 300px;//Esto es lo que fallaba.
background-attachment: fixed;
}
Tuve que poner la posición exacta de la imagen respecto de la tabla, muchas gracias por la ayuda, ya tenía rato sufriendo con esto, creo que hoy voy a dormir tranquilo, jajajajaja gracias de nuevo

Última edición por fagos08; 19/08/2008 a las 14:58
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:31.