Foros del Web » Creando para Internet » CSS »

Problema con Internet Explorer 7

Estas en el tema de Problema con Internet Explorer 7 en el foro de CSS en Foros del Web. Hola a todos amigos de foros del web Os sigo desde hace mucho tiempo y siempre que he tenido problemas y he buscado en google, ...
  #1 (permalink)  
Antiguo 05/04/2009, 15:34
 
Fecha de Ingreso: abril-2009
Mensajes: 8
Antigüedad: 8 años, 8 meses
Puntos: 0
Sonrisa Problema con Internet Explorer 7

Hola a todos amigos de foros del web

Os sigo desde hace mucho tiempo y siempre que he tenido problemas y he buscado en google, vuestro foro me ha sacado de dudas casi siempre. Tengo tres paginas y una de ellas me esta dando quebraderos de cabeza: muchocine punto net

Hace cosa de un par de dias, sufro en silencio uno de los bugs que tiene Explorer 7 con el modelo de cajas.

Os pego el codigo de mi css:

#az7 {width:100%;text-align:left;clear:both !important}
#az71 {float:left;width:75%;text-align:left;}
#az72 {float:left;width:18%;text-align:center;}


La primera caja es el contenedor, la segunda caja es la de contenido y la tercera caja es la columna de la derecha de google adsense. Podeis ver como funciona online el modelo de cajas aqui:

muchocine(punto)net/criticas/9516/Elizabeth:-La-Edad-de-Oro

(cambiar el (PUNTO) por punto normal porque no me dejan enviar enlaces, lo siento)

Si utilizais Explorer 7 y dais a F5 varias veces para que recargue la pagina a veces ocurre algo curioso, la pagina no carga por completo, se queda a la mitad, a la altura de donde termina la columna de adsense.

La verdad que llevo varios dias dandole vueltas y cambiando el codigo y no hay manera de solucionarlo. He cambiado el codigo, he intentado algun que otro hack y he leido otros foros pero no encuentro la forma de arreglarlo.

El modelo de cajas funciona perfectamente en firefox, opera, etc incluso en las versiones anteriores de explorer, pero en explorer 7 sigue pasando lo mismo, cuando das a F5 muchas veces en ocasiones se carga a la mitad.

Alguien tiene alguna experiencia similar o le pasa algo parecido? Como lo puedo solucionar?

Algun modelo de cajas para explorer 7 que no falle?

Necesito vuestra ayuda amigos!!
  #2 (permalink)  
Antiguo 05/04/2009, 23:43
Avatar de emiliodeg  
Fecha de Ingreso: septiembre-2005
Ubicación: Córdoba
Mensajes: 1.830
Antigüedad: 12 años, 3 meses
Puntos: 54
Respuesta: Problema con Internet Explorer 7

mira he probado lo que dices y no he logrado reproducir el fallo
lo unico q puedo decirte es
1.- corrige los errores de sintaxis que tiene tu pagina pq esta entrando en quirksmode y el html esta mal la sintaxis
2.- probablemente el servidor bloquee un useragent cuando hace demaciadas solicitudes y por ello el error q ves
3.- puede q el error se produce por el punto 1 y al tener ie varias isntancias de lo mismo colapsa o algo, ya sabes como es la familia de los chicos ie o microsoft :P

__________________
Degiovanni Emilio
developtus.com
  #3 (permalink)  
Antiguo 06/04/2009, 07:20
 
Fecha de Ingreso: abril-2009
Mensajes: 8
Antigüedad: 8 años, 8 meses
Puntos: 0
Respuesta: Problema con Internet Explorer 7

hola emilio



Muchas gracias por tu respuesta. Es cierto que una de las tareas que tengo que hacer en la web es formar correctamente la sintaxis del codigo de la pagina, pero en este caso creo que el problema real es que la altura de la columna de la derecha "az72" (ver arriba) está forzando con su altura el contenido de la columna de la izquierda "az71" donde está el texto y los trailers de la pelicula.

Puedo reproducir el error y tambien muchos de los colaboradores de mi página que me comentan por correo que sus criticas se suelen cortar por la zona de los trailers.

Mira te vuelvo a mandar un ejemplo a ver si hay mas suerte:

muchocine(punto)net/criticas/9530/Al-sur-de-san-luis

(sustituir (punto) por un punto normal, no me dejan enviar enlaces...)

Dale a F5 varias veces si no lo consigues ver, fijate en el trailer de la pelicula.

Alguien me puede ayudar?

Gracias!
  #4 (permalink)  
Antiguo 06/04/2009, 10:15
Avatar de emiliodeg  
Fecha de Ingreso: septiembre-2005
Ubicación: Córdoba
Mensajes: 1.830
Antigüedad: 12 años, 3 meses
Puntos: 54
Respuesta: Problema con Internet Explorer 7

bueno he probado nuevamente y le he dado como 100 veces al f5 en 10 segundos y nada

yo intentaria primeor solucionar todos los problemas de sintaxis

__________________
Degiovanni Emilio
developtus.com
  #5 (permalink)  
Antiguo 06/04/2009, 14:17
 
Fecha de Ingreso: abril-2009
Mensajes: 8
Antigüedad: 8 años, 8 meses
Puntos: 0
Respuesta: Problema con Internet Explorer 7

Si tienes razon con los problemas de sintaxis pero curiosamente ninguno de los otros navegadores me da problemas con la visualizacion por lo que estoy tratando de resolver ahora lo mas urgente que es el tema de la correcta visualizacion de las columnas.

De todas formas te agradezco mucho tu aportación Emilio. Alguien que me pueda ayudar con el tema de las columnas?

Mil gracias!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:36.