Foros del Web » Diseño web » CSS »

Problema con link

Estas en el tema de Problema con link en el foro de CSS en Foros del Web. Hola a tod@s. Tengo el siguiente problema y no soy capaz de averiguar por qué es. La cosa es que tengo tres enlaces puestos en ...
  #1 (permalink)  
Antiguo 11/02/2010, 11:43
 
Fecha de Ingreso: febrero-2010
Mensajes: 289
Antigüedad: 4 años, 5 meses
Puntos: 57
Problema con link

Hola a tod@s.

Tengo el siguiente problema y no soy capaz de averiguar por qué es.
La cosa es que tengo tres enlaces puestos en columna, uno debajo de otro. Además les he puesto una imagen para que se pinche en la imagen en vez de un texto.
La cosa es que ahora el enlace está activo en toda la fila de la pantalla. Pinche donde pinche en la linea horizontal imaginaria que ocupa el enlace en la pantalla se activa el link y me lleva a la página marcada en el link.
La verdad es que en principio no hay un problema grande con eso, pero es que no me gusta ese efecto. Yo quiero que haya que pinchar en la imagen.
¿Alguien sabe como se puede remediar eso?.

Gracias. Un saludo.
  #2 (permalink)  
Antiguo 11/02/2010, 12:18
 
Fecha de Ingreso: febrero-2010
Mensajes: 289
Antigüedad: 4 años, 5 meses
Puntos: 57
Respuesta: Problema con link

Bueno, ya lo he solucionado. Al final era una chorrada. Resulta que había puesto display:block para situar los enlaces en columna y se activaban en toda la fila.
Al final era tan fácil como utilizar position:absolute
Me parece que me quedan muchas cosas por aprender de css todavía.

Un saludo.

Etiquetas: link
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:40.
SEO by vBSEO 3.3.2