Foros del Web » Creando para Internet » CSS »

Problema con links (Etiqueta <a> dentro de <p>)

Estas en el tema de Problema con links (Etiqueta <a> dentro de <p>) en el foro de CSS en Foros del Web. Hola, tengo un problema y es que tengo unos links dentro de una etiqueta a es decir: <p><a href="contacto.html" title="Contacto">Contacto</a></p> Funciona perfectamente en todos los ...
  #1 (permalink)  
Antiguo 27/12/2006, 05:09
 
Fecha de Ingreso: octubre-2005
Mensajes: 52
Antigüedad: 12 años, 1 mes
Puntos: 0
Problema con links (Etiqueta <a> dentro de <p>)

Hola, tengo un problema y es que tengo unos links dentro de una etiqueta a es decir:

<p><a href="contacto.html" title="Contacto">Contacto</a></p>

Funciona perfectamente en todos los navegadores incluido el IE7, menos en IE6 y anteriores.

Sabeis por que puede ser???

Un saludo
  #2 (permalink)  
Antiguo 27/12/2006, 05:15
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 10 meses
Puntos: 771
Re: Problema con links (Etiqueta <a> dentro de <p>)

Hola salvaydor

¿Qué es lo que no funciona? Dá más detalles para que podamos orientarte.

Saludos,
  #3 (permalink)  
Antiguo 27/12/2006, 05:18
 
Fecha de Ingreso: octubre-2005
Mensajes: 52
Antigüedad: 12 años, 1 mes
Puntos: 0
Re: Problema con links (Etiqueta <a> dentro de <p>)

Pues que me salen como texto normal, no como links...

La página es metalicasbolingo.com, si lo veis con IE6 comprobareis que en los apartados por ejemplo (Troquelado, Punzonado, Corte...) abajo tiene un link con la palabra más y en firefox funciona de perlas pero en explorer no.

Un saludo.
  #4 (permalink)  
Antiguo 27/12/2006, 06:40
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: Problema con links (Etiqueta <a> dentro de <p>)

Creo que se debe a que esos liks están contenidos dentro de un div con un fondo que tiene un filtro de transparencia. Esto mismo ya se ha comentado en otros hilos de este foro, pero no sé cómo se ha resuelto, si es que se ha hecho.

Busca en hilos recientes (un mes máximo).

Mikel.
  #5 (permalink)  
Antiguo 27/12/2006, 07:02
 
Fecha de Ingreso: octubre-2005
Mensajes: 52
Antigüedad: 12 años, 1 mes
Puntos: 0
Re: Problema con links (Etiqueta <a> dentro de <p>)

Ok, ya he encontrado el hilo, sin resolver pero lo he encontrado, y sobre todo he comprendido el problema que no es poco.

A ver si conseguimos solucionarlo.....

Un saludo.
  #6 (permalink)  
Antiguo 27/12/2006, 17:22
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: Problema con links (Etiqueta <a> dentro de <p>)

Un preguntilla: ¿y por qué no lo haces así?


(es decir, insertando ya el fondo blanco y verde como el de tu página en el propio gráfico)

Así el link funciona correctamente. En otros casos en muy complicado, pero en este creo que es bastante sencillo. Prúebalo y a ver qué tal.

Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:36.