Foros del Web » Creando para Internet » CSS »

Problema con links en las imagenes y IE

Estas en el tema de Problema con links en las imagenes y IE en el foro de CSS en Foros del Web. Estoy intentando hacer que al pasar el ratón sobre una imagen con link el borde cambie de color, ahora lo tengo hecho así: a.estilo2:link { ...
  #1 (permalink)  
Antiguo 14/07/2005, 06:18
 
Fecha de Ingreso: julio-2005
Mensajes: 3
Antigüedad: 12 años, 5 meses
Puntos: 0
Problema con links en las imagenes y IE

Estoy intentando hacer que al pasar el ratón sobre una imagen con link el borde cambie de color, ahora lo tengo hecho así:

a.estilo2:link {
color: #CC0000;
background-color: #000000;
text-decoration: none;
}
a.estilo2:visited {
color: #CC0000;
background-color: #000000;
text-decoration: none;
}
a.estilo2:hover {
color: #FFC000;
background-color: #000000;
text-decoration: none;
}

Con el firefox me funciona perfecto tanto con las letras como con las imagenes pero con el IE me salen las letras bien pero los bordes de las imagenes me salen azules y no cambian de color...

A ver si alguien de por aqui sabe como hacer que se vea bien en los 2 exploradores.

Salu2.
  #2 (permalink)  
Antiguo 14/07/2005, 10:26
Avatar de ramm  
Fecha de Ingreso: junio-2004
Ubicación: Guadalajara
Mensajes: 207
Antigüedad: 13 años, 5 meses
Puntos: 0
porque te falta ponerle el atributo border

border: 2px solid #CC0000;

y en hover:
border: 2px solid #FFC000;

Ademas de ponerle asi:
img a.estilo2:hover {
.....
  #3 (permalink)  
Antiguo 14/07/2005, 13:40
 
Fecha de Ingreso: julio-2005
Mensajes: 3
Antigüedad: 12 años, 5 meses
Puntos: 0
Gracias por contestar pero todavia no lo he solucionado...

Si añado esto:


border: 2px solid #CC0000;

y en hover:
border: 2px solid #FFC000;

Me salen los bordes pero salen mal, de los 4 salen solo 2 o 3 me parece que es porque tengo las imagenes dentro de una tabla...

Luego he probado a ponerlo asi "img a.estilo2:hover {" y no he conseguido nada me sigue pasando lo mismo.

Saludos.
  #4 (permalink)  
Antiguo 14/07/2005, 14:05
Avatar de Durgeoble  
Fecha de Ingreso: marzo-2003
Mensajes: 462
Antigüedad: 14 años, 9 meses
Puntos: 2
a:hover img { estilos}

img a :hover como han indicado antes te aplicaria los estilos a un link "dentro" de una imagen lo cual no es muy logico.
__________________
Todas mis respuestas funcionaran correctamente en aquellos navegadores que respeten los estandares.
  #5 (permalink)  
Antiguo 14/07/2005, 14:27
Avatar de ramm  
Fecha de Ingreso: junio-2004
Ubicación: Guadalajara
Mensajes: 207
Antigüedad: 13 años, 5 meses
Puntos: 0
Cierto, lo puse al reves.

Ahora lo de los bordes no se, tendria que ver lo que estas haciendo
  #6 (permalink)  
Antiguo 14/07/2005, 16:06
 
Fecha de Ingreso: julio-2005
Mensajes: 3
Antigüedad: 12 años, 5 meses
Puntos: 0
Ahora si me ha funcionado muchas gracias!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:45.