Foros del Web » Creando para Internet » CSS »

Problema con lista (menu) no responde link

Estas en el tema de Problema con lista (menu) no responde link en el foro de CSS en Foros del Web. Hola a todos Tengo un menu que cuando carga el index y pasas el mouse te muestra en el caption del browser donde iria si ...
  #1 (permalink)  
Antiguo 24/04/2008, 21:57
 
Fecha de Ingreso: abril-2007
Mensajes: 48
Antigüedad: 10 años, 8 meses
Puntos: 0
Problema con lista (menu) no responde link

Hola a todos
Tengo un menu que cuando carga el index y pasas el mouse te muestra en el caption del browser donde iria si le das click.
Pues bien, cuando le doy click en el segundo link hace lo correcto, pero ahi es como que se tilda y no responden los demas, y el caption del browser sigue diciendo solo la pagina que le di click que en este caso es (servicios.php#) asi es como me muestra.
Paso a detallarles el css
----------------------------------------------------------
#button {
/* width: 12em;*/
width: 160px;
float:left;
padding: 10px 0 0 0;

border-right: 1px /*solid #000*/;
/* padding: 0 0 1em 0;*/
margin-bottom: 1em;
font-family: 'Trebuchet MS', 'Lucida Grande',
Verdana, Lucida, Geneva, Helvetica,
Arial, sans-serif;
/* background-color: #90bade; */
color: #333;
}
#button ul {
list-style: none;
margin: 0;
padding: 0;
border: none;
}

#button li {
border-bottom: 1px solid #90bade;
margin: 0;
}
#button li a {
display: block;
padding: 5px 5px 5px 0.5em;
border-left: 10px solid #1958b7;
border-right: 10px solid #508fc4;
background-color: #2175bc;
color: #fff;
text-decoration: none;
width: 100%;
}

html>body #button li a {
width: auto;
}

#button li a:hover {
border-left: 10px solid #1c64d1;
border-right: 10px solid #5ba3e0;
background-color: #2586d7;
color: #fff;
}
----------------------------------------------------------
en el php tengo esto:
<div id="button">
<ul>
<li><a href="index.php">Home</a></li>
<li><a href="servicios.php">Servicios</a></li>
<li><a href="faq.php">Preguntas Frecuentes</a></li>
<li><a href="acerca.php">Acerca de IMxM</a></li>
<li><a href="contactenos.php">Contactenos</a></li>
</ul>
</div>

Espero que alguien pueda ayudarme.
Gracias
Iván
  #2 (permalink)  
Antiguo 25/04/2008, 11:15
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: Problema con lista (menu) no responde link

¿Y qué hay en la página servicios.php?

Yo en el código no veo nada raro.

Mikel.
  #3 (permalink)  
Antiguo 26/04/2008, 06:15
 
Fecha de Ingreso: abril-2007
Mensajes: 48
Antigüedad: 10 años, 8 meses
Puntos: 0
Re: Problema con lista (menu) no responde link

Gracias por responder Mikmoro
Efectivamente, cuando pusiste que tiene servicios.php mire y tenia esto en su menu y por eso no andaba. Pegue el menu del index y anda bien ahora.

<div id="button">
<ul>
<li><a href="#">Home</a></li>
<li><a href="#">Servicios</a></li>
<li><a href="#">Preguntas Frecuentes</a></li>
<li><a href="#">Acerca de IMxM</a></li>
<li><a href="#">Contactenos</a></li>
</ul>
</div>

Denuevo, gracias por responder.
Saludos

Iván
P.M.A
  #4 (permalink)  
Antiguo 26/04/2008, 09:06
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Re: Problema con lista (menu) no responde link

Claro. Ya me parecía. Me alegro de que te funcione bien.

Un saludo.

Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:15.