Foros del Web » Creando para Internet » CSS »

Problema con listas

Estas en el tema de Problema con listas en el foro de CSS en Foros del Web. Hola! tengo este menu, pero deseo crear subniveles, tampoco me funciona clase activo. Alguna idea? Mil gracias!! ;) CSS Código HTML: #subNavigation { FLOAT: left; ...
  #1 (permalink)  
Antiguo 17/09/2009, 13:31
 
Fecha de Ingreso: junio-2008
Mensajes: 291
Antigüedad: 9 años, 5 meses
Puntos: 9
Problema con listas

Hola! tengo este menu, pero deseo crear subniveles, tampoco me funciona clase activo. Alguna idea? Mil gracias!! ;)


CSS

Código HTML:
 #subNavigation {
	FLOAT: left;
	PADDING-BOTTOM: 40px;
	MARGIN: -0.5em 20px 0px 0px;
	WIDTH: 170px;
	font-family: "Lucida Grande", "Trebuchet MS", Verdana, Arial, sans-serif;
}
#subNavigation LI {
	PADDING-RIGHT: 0px; PADDING-LEFT: 0px; FONT-SIZE: 1.08em; BACKGROUND: url(subnav_rule.gif) no-repeat left bottom; PADDING-BOTTOM: 0.5em; LINE-HEIGHT: 1.53em; PADDING-TOP: 0.5em
}
#subNavigation LI A:link {
	DISPLAY: block; PADDING-LEFT: 10px; COLOR: #666
}
#subNavigation LI LI {
	DISPLAY: block; PADDING-LEFT: 30px; COLOR: #d0431d; padding-top:10px;BACKGROUND: url(square_bullet.gif) no-repeat 30px 1.3em;
}
#subNavigation LI A:visited {
	DISPLAY: block; PADDING-LEFT: 10px; COLOR: #666
}
#subNavigation LI A:hover {
	BACKGROUND: url(square_bullet.gif) no-repeat 0px 0.6em; COLOR: #d0431d; TEXT-DECORATION: none
}
#subNavigation LI A:active {
	BACKGROUND: url(square_bullet.gif) no-repeat 0px 0.6em; COLOR: #d0431d; TEXT-DECORATION: none
}
HTML

Código HTML:
<UL id=subNavigation>
  <LI ><A href="#">Mission  Statement</A>

  <LI><A href="#">Our aims</A>

  <LI><A href="#">Ofsted  report</A> 
  <LI><A  href="#">Language  College</A> 
  <LI><A href="#">Gallery</A>
  <LI><A href="#">Staff</A> 
  <LI><A  href="#">Leadership  team</A> 
  <LI><A href="#">Governors</A> 
  <LI><A href="#">Departments</A> 
  </LI></UL>
<!-- end sub navigation --> 
  #2 (permalink)  
Antiguo 17/09/2009, 15:18
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problema con listas

Tienes todos los 'li' sin cerrar, y en el primero un espacio antes de '>'
Cita:
<li><a href="#">Mission Statement</a></li>
Creo que lo mejor es que pases por las faq's de css. Tienes una más que amplia colección de menús.
Seguro que encuentras alguno que se ajuste a tus necesidades y con un mínimo de ajustes para lograr la estética que desees.

Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:42.