Foros del Web » Creando para Internet » CSS »

Problema con maquetacion

Estas en el tema de Problema con maquetacion en el foro de CSS en Foros del Web. Hola, espero que me puedan ayudar, estoy comenzando con esto de CSS. Mi problema es el siguiente estoy creando una pagina de la siguiente estructura. ...
  #1 (permalink)  
Antiguo 03/01/2006, 09:50
 
Fecha de Ingreso: mayo-2004
Mensajes: 183
Antigüedad: 13 años, 7 meses
Puntos: 0
Problema con maquetacion

Hola, espero que me puedan ayudar, estoy comenzando con esto de CSS. Mi problema es el siguiente estoy creando una pagina de la siguiente estructura.

Encabezado
Navegacion Principal
Menu | Contenido
Pie de Pagina.

La pagina se muestra bien con el Internet explorer pero falla con el Opera. Con el opera baja el contenido a la parte de abajo a pesar de que haya puesto el float: right. Aqui coloco el codigo CSS.

#container
{
margin: 10px auto;
width: 90%;
background-color: white;
border: 1px solid black;
}

#header_principal
{
height: 45px;
border-bottom: 1px solid black;
background-color: gray;
}

#header_principal h1
{
font-size: 30px;
text-align: center;
color: #fff;
margin: 0;
padding: 0;
}

#mainnav
{
height: 25px;
background:#DAE0D2 url("bg.gif") repeat-x bottom;
color: #272900;
padding: 2px 0;
margin-bottom: 0px;
}

#mainnav ul
{
margin: 0 0 0 50px;
padding: 0;
list-style-type: none;
border-left: 1px solid #C4C769;
}

#mainnav li
{
display: inline;
padding: 0 70px;
border-right: 1px solid #C4C769;
}

#mainnav li a
{
text-decoration: none;
color: #272900;
}

#mainnav li a:hover
{
text-decoration: none;
color: #fff;
background-color: #C4C769;
border-bottom: 1px solid green;
}

#menu
{
width: 160px;
margin-right: -3px;
line-height: 165%;
border-right: 1px solid #765;
background-color: white;
float: left;
}

#menu ul
{
font: 85% arial, hevetica, sans-serif;
margin-left: 0;
padding-left: 0;
list-style-type: none;
}

#menu ul a:hover
{
color: #fff;
background-color: #B52C07;
}

#contents
{
margin-left: 0px;
margin-right: 0px;
padding: 0em;
background-color: aqua;
width:100%
}

Muchas gracias.
  #2 (permalink)  
Antiguo 05/01/2006, 04:16
Avatar de kahlito
Colaborador
 
Fecha de Ingreso: marzo-2003
Ubicación: En el Estrecho y el mar
Mensajes: 2.893
Antigüedad: 14 años, 9 meses
Puntos: 60
Hola masterboy6666, ¿podrias poner tambien la parte del body?, quizás sea más facil ver el problema
  #3 (permalink)  
Antiguo 05/01/2006, 16:11
 
Fecha de Ingreso: mayo-2004
Mensajes: 183
Antigüedad: 13 años, 7 meses
Puntos: 0
Muchas gracias por responder, ya lo resolvi. el problema era en que el body como tu me has dicho, escribi mal una etiqueta puse >/td> en lugar </td>
por eso fallaba... bueno, para la otra mejor me fijo mas al momento de postear. Y tambien observe que

#contents
{
margin-left: 160 px, por aquello que en el lado izquierdo se encuentra el menu y ademas es flotante..
bueno echando a perder se aprende.

Gracias.
}
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:14.