Foros del Web » Creando para Internet » CSS »

Problema con menu de listas en Mozilla Firefox

Estas en el tema de Problema con menu de listas en Mozilla Firefox en el foro de CSS en Foros del Web. Buenas, estoy haciendo un menú de listas con su respectivo enlace y todo bien en Iexplorer y Opera menos en Mozilla El código que utilizo ...
  #1 (permalink)  
Antiguo 04/03/2005, 08:20
Avatar de kahlito
Colaborador
 
Fecha de Ingreso: marzo-2003
Ubicación: En el Estrecho y el mar
Mensajes: 2.893
Antigüedad: 14 años, 9 meses
Puntos: 60
Problema con menu de listas en Mozilla Firefox

Buenas, estoy haciendo un menú de listas con su respectivo enlace y todo bien en Iexplorer y Opera menos en Mozilla

El código que utilizo es el siguiente:

Código HTML:
<style type="text/css">
ul {
	margin-top:95px;
	margin-left:35px;
	}
li {
	font-family: "Courier New", Courier, mono;
	font-size: 12px;
	color: #D2D4B8;
	list-style-image:url(fondo_bullet_verde.jpg);
	list-style-position:outside;
	margin:8px;
}
body {
	background-color:#EEEEE4;
	margin-left: 0px;
	margin-top: 0px;
	margin-right: 0px;
	margin-bottom: 0px;
	}
#contenedor{
margin: 0 auto;
background-color:#D2D4B8;
width:770px;
}
#cabecero{
width:770px;
height:120px;
background-color:#6F8779;
background-image:url(fondo_encabezado.gif);
}
#contenido{
	float:left;
	width:619px;
	height:380px;
	background-color:#D2D4B8;
	border-left-width: 1px;
	border-left-style: dashed;
	border-left-color: #EEEEE4;
}
#menu {
	width:150px;
	height:380px;
	background-color:#D2D4B8;
	background-image:url(fondo_menu.jpg);
	float:right;
	background-repeat: no-repeat;
	background-position: center center;
}
#menu li a{
	color: #D2D4B8;
	text-decoration:none;
	}
#menu li a:hover{
    color: #D2D4B8;
	text-decoration:underline;
	}
#pie {
width:770px;
height:100px;
background-color:#A09A84;
float:left;
background-image:url(fondo_pie.gif);
}
...
}
</style>
</head>
<body>
<div id="contenedor">
<div id="cabecero"></div>
<div id="contenido">
<h1>asdfa</h1>
<p>
  asdfasdf
</p>
</div>
<div id="menu">
<ul>
<li><a href="#">Inicio</a></li>
<li><a href="#">Portafolio Web</a></li>
<li><a href="#">Fotografias</a></li>
<li><a href="#">Retoques</a></li>
<li><a href="#">Ilustración</a></li>
<li><a href="#">Fondos escritorio</a></li>
<li><a href="#">Otros</a></li>
<li><a href="#">Curriculum</a></li>
</ul>
</div>
<div id="pie"></div>
</div>
</body> 
Y aquí una muestra del problema, asi se ve en Iexplorer y Opera:



y así en Mozilla se desplaza a la derecha



¿En que estoy fallando?

Saludosss
  #2 (permalink)  
Antiguo 04/03/2005, 09:24
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
intenta ponerle padding:0 a ul y li :)
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #3 (permalink)  
Antiguo 04/03/2005, 09:28
Avatar de kahlito
Colaborador
 
Fecha de Ingreso: marzo-2003
Ubicación: En el Estrecho y el mar
Mensajes: 2.893
Antigüedad: 14 años, 9 meses
Puntos: 60
Vaya parece que has hecho magia

Ya me funciona perfectamente, aunque la verdad no entiendo por qué en Mozilla me coge "supuestamente" esa distancia por su cuenta ...

Muchas gracias Kemie , saludosss
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:24.