Foros del Web » Creando para Internet » CSS »

Problema con mi hover

Estas en el tema de Problema con mi hover en el foro de CSS en Foros del Web. Pues parcialmente resolvi mi problema con los hovers, el problema es que en una pagina testeada si funca, pero en el famoso myspace parece no ...
  #1 (permalink)  
Antiguo 16/08/2010, 13:15
 
Fecha de Ingreso: agosto-2010
Mensajes: 6
Antigüedad: 7 años, 4 meses
Puntos: 0
Problema con mi hover

Pues parcialmente resolvi mi problema con los hovers, el problema es que en una pagina testeada si funca, pero en el famoso myspace parece no querer jalar:

Código:
a#Menu1 {display: block;
width: 481px;
height: 28px;
background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Menu1-2.png") no-repeat;
position:absolute; top:795px; left:154px; height:1%; width:30; background:transparent; border-left:0px solid black; border-right:0px solid black; padding-top:4px; padding-left:4px; padding-right:4px;
}
a#Menu1:hover {background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi Myspace XD/menu1-1.png") no-repeat;
}

a#Menu2 {display: block;
width: 57px;
height: 28px;
background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp2-2.png") no-repeat;
position:absolute; top:795px; left:635px; height:1%; width:30; background:transparent; border-left:0px solid black; border-right:0px solid black; padding-top:4px; padding-left:4px; padding-right:4px;
}
a#Menu2:hover {background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp2-1.png") no-repeat;
}

a#Menu3 {display: block;
width: 79px;
height: 28px;
background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp3-2.png") no-repeat;
position:absolute; top:795px; left:692px; height:1%; width:30; background:transparent; border-left:0px solid black; border-right:0px solid black; padding-top:4px; padding-left:4px; padding-right:4px;
}
a#Menu3:hover {background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp3-1.png") no-repeat;
}

a#Menu4 {display: block;
width: 78px;
height: 28px;
background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp4-2.png") no-repeat;
position:absolute; top:795px; left:770px; height:1%; width:30; background:transparent; border-left:0px solid black; border-right:0px solid black; padding-top:4px; padding-left:4px; padding-right:4px;
}
a#Menu4:hover {background: #666 url("http://i191.photobucket.com/albums/z61/Darck_mario/Mi%20Myspace%20XD/Msp4-1.png") no-repeat;
}
y este es el html

Código:
<div id="Men1">
<a href="http://www.myspace.com/darckscientistmad" id="Menu1"></a>
</div>

<div id="Men2">
<a href="" id="Menu2"></a>
</div>

<div id="Men3">
<a href="http://www.facebook.com/group.php?gid=21122929373&v=wall#!/profile.php?id=100000176631566" id="Menu3"></a>
</div>

<div id="Men4">
<a href="http://www.twitter.com/Marcos_RvZ" id="Menu4"></a>
</div>
no veo donde este el error, pero por mas que le testeo no funca, alguna sugerencia?
  #2 (permalink)  
Antiguo 16/08/2010, 14:10
 
Fecha de Ingreso: agosto-2010
Mensajes: 6
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Problema con mi hover

¿Ninguna idea? :(
  #3 (permalink)  
Antiguo 16/08/2010, 16:09
Avatar de alexk
Colaborador
 
Fecha de Ingreso: julio-2009
Ubicación: De vuelta al trono
Mensajes: 1.697
Antigüedad: 8 años, 5 meses
Puntos: 137
Respuesta: Problema con mi hover

esta un poquito mal tu codigo...
en el CSS tienes selectores como
a#Menu4{}
estas indicando que #Menu4 es una etiqueta <a> cuando es un <div> y el <a> esta dentro de este osea un selector valido en tu caso seria
#Menu4 a{}
luego en tu CSS tus selectores son #Menu1,#Menu2, etc... y en tu HTML tus clases son #Men1,#Men2, etc... ya sea myspace o donde sea jamas funcionara como lo tienes, ademas mucha posicion absoluta sin declarar una relativa... para que no floten por todos lados bordes mal usados, medidas repetidas e incompletas etc.. etc... mucho error en tan poco codigo... te recomiendo hacer denuevo tu menu y con mas calma y validando tu codigo
  #4 (permalink)  
Antiguo 17/08/2010, 11:40
 
Fecha de Ingreso: agosto-2010
Mensajes: 6
Antigüedad: 7 años, 4 meses
Puntos: 0
Respuesta: Problema con mi hover

Trate de solucionarlo con relative y de plano no salio :( no podrias orientarme un poco mas? la idea es un menu en el que cada elemento haga hover la segunda imagen con la primera :X
  #5 (permalink)  
Antiguo 17/08/2010, 12:08
Avatar de alexk
Colaborador
 
Fecha de Ingreso: julio-2009
Ubicación: De vuelta al trono
Mensajes: 1.697
Antigüedad: 8 años, 5 meses
Puntos: 137
Respuesta: Problema con mi hover

Cita:
Iniciado por alexk Ver Mensaje
mucho error en tan poco codigo... te recomiendo hacer denuevo tu menu y con mas calma y validando tu codigo
es lo mas que te puedo sugerir... bueno eso y que mires las FAQS CSS y que leas http://librosweb.es/ para entender mas sobre XHTML/CSS.

Etiquetas: hover
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:15.