Foros del Web » Creando para Internet » CSS »

Problema con Mozilla

Estas en el tema de Problema con Mozilla en el foro de CSS en Foros del Web. Estimados, Tengo un problema con mi pagina que, según he leído es bastante frecuente. Pero mi error es un poco distinto y no he encontrado ...
  #1 (permalink)  
Antiguo 18/03/2010, 06:44
 
Fecha de Ingreso: marzo-2010
Mensajes: 4
Antigüedad: 7 años, 8 meses
Puntos: 0
Problema con Mozilla

Estimados,

Tengo un problema con mi pagina que, según he leído es bastante frecuente. Pero mi error es un poco distinto y no he encontrado el problema hasta ahora.

La pagina se ve en explorer y chrome bien, pero en mozilla no se ve. Es como si no pescara al CSS o ninguna de las direcciones. Solo se ve el texto, pero nada más. No se ve la imagen de fondo, ni las distintas capas, ni formato de la pagina e imágenes.
Ademas no me pesca los enlaces a las otras paginas.

En explorer y chrome me pesca todo y se ve tal cual como quiero que se vea.

Supongo que es algo que no estoy poniendo pero no he logrado encontrar el error. A continuación agrego el código CSS haber si alguien encuentra el error.

Agradecería mucho si alguien pudiese decirme que esta mal.

CSS:

* {text-indent: 0px ; margin:0px ; padding:0px ; border: 0px}
p {font-family:Verdana; text-align: left;font-size: 12px;line-height: 20px}
h1 {font-family: Cambria ;font-size: 1.5em; color:black ; font-weight: bold ; text-decoration: none ; text-align: center;background-color: white}
h2 {font-family: Cambria ;padding-top: 10px;font-size: 1.1em; color:#0174DF ; font-weight: bold ; text-decoration: none ; text-align: center;background-color: white}
h3 {font-family: Cambria;font-size: 1.1em; color:#0174DF ; font-weight: bold ; text-decoration: none ; text-align: center;background-color: white}

body {
text-align: center ;
background-attachment : fixed ;
background-repeat:no-repeat;
background-position : center;
}

#global {width:800px ; margin: 20px auto}

#cabecera {height:127px;width:800px}
#logotipo {width:100px ; float:left ; margin-left: 20px}
#publicidad {float:right ; margin-right: 120px}
#navegacion {width: 630px; height:20px ; margin: 5px 5px 0px 0px;float:right}

#contenido {width: 800px}
p#centrado {text-align: center}

#texto {width:650px;float:right;background-color: white;padding-bottom: 20px}
#texto a {background-color: white; padding: 0px 0px 0px 0px }
#texto p {font-family: Verdana; padding: 0px 30px 15px 30px ;background-color: white}
#texto h1 {color: blue;padding-bottom:20px; padding-top:15px}
#texto h2 {padding-bottom: 10px; padding-top: 10px}
#texto h3 {padding-bottom: 5px; padding-top: 5px}

#menu {background-color: white ; width: 150px ; float:left ; text-align:left }
#noticias {background-color: white ; width: 130px ; float:left ; text-align:left }
#mapa {background-color: white ; width: 120px ; float:left ; text-align:left }

#portada {background-color:white; margin-bottom: 30px}
#ubicacionschultz {margin: 30px 49px 35px 49px ;border: blue 1px solid;width:550px ;height:400px;background-color:white}

#pie {float: left;width: 800px;margin-bottom:5px}
#datosimg {float: right; border: black 1px solid; margin: 5px}

#logo1 {float:left ; margin-left: 10px;margin-right: 10px;background-color:white }
#logo2 {float:left;margin-left: 70px ; background-color:white }
#logo3 {float:right; margin-right: 70px;background-color:white }
#logo4 {background-color:white;margin-top:10px;margin-bottom:10px }
#separacion {float: right;width: 649px;margin-top: 10px;margin-bottom:10px}

ul#nav,ul#nav li{list-style-type:none;margin:0;padding:0}
ul#nav{
float:right;
font-size: 15px;
font-weight: bold;
}

ul#nav li{
float:left;
margin-left: 0px;
text-align: center;
}
ul#nav a{float:left;width: 90px;padding: 5px 0;background: #045FB4;text-decoration:none;color: #FFC}
ul#nav a:hover{background: #ffffff;color: #333333}
ul#nav li.activelink a,ul#nav li.activelink a:hover{background: #ffffff;color: #333333}


#menu ul,#menu li{list-style-type:none;margin:0;padding:0}
#menu ul{
float:left;
font-size: 15px;
font-weight: bold;
}
#menu li{
float:left;
margin-left: 0px;
text-align: center;
}
#menu a{float:left;width: 150px;padding: 5px 0;background:#045FB4;text-decoration:none;color: #FFC}
#menu a:hover{background: #ffffff;color: #333333}
#menu li.activelink a,#menu li.activelink a:hover{background: #ffffff;color: #333333}

#mapa ul,#mapa li{list-style-type:none;margin:0;padding:0}
#mapa ul{
float:left;
font-size: 15px;
font-weight: bold;
}
#mapa li{
float:left;
margin-left: 0px;
text-align: center;
}
#mapa a{float:left;width: 150px;padding: 5px 0;background: #848484;text-decoration:none;color: #FFC}
#mapa a:hover{background: #ffffff;color: #333333}
#mapa li.activelink a,#mapa li.activelink a:hover{background: #ffffff;color: #333333}
  #2 (permalink)  
Antiguo 18/03/2010, 07:43
 
Fecha de Ingreso: agosto-2008
Mensajes: 469
Antigüedad: 9 años, 3 meses
Puntos: 20
Respuesta: Problema con Mozilla

Buneas,

pon el html, o por lo menos como vinculas al css, es decir el <link....> ya que seguramente alli este el error.

Saludos¡¡
__________________
Revisa las FAQ's antes de disparar.
  #3 (permalink)  
Antiguo 18/03/2010, 08:17
 
Fecha de Ingreso: marzo-2010
Mensajes: 4
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: Problema con Mozilla

Impostor,

Gracias por tu interés y acá esta el index.html


INDEX.HTML:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>Schultz</title>
<link rel="stylesheet" href="C:\wamp\www\Schultz2.0\estilosgeneral.css" type="text/css" media="all"/>
</head>

<body background= "C:\wamp\www\Schultz2.0\objetos\maquetaempresa.jpg ">
<div id="global">
<div id="cabecera">
<div id="logotipo">
<img src="C:\wamp\www\Schultz2.0\Objetos\logoschultz.gi f" alt="" />
</div>
<div id="publicidad"><img src="C:\wamp\www\Schultz2.0\objetos\schultz.gif" alt="" /></div>
<div id="navegacion">
<ul id="nav"><li class="activelink"><a href="C:\wamp\www\Schultz2.0/index.html">Inicio</a></li>
<li><a href="C:\wamp\www\Schultz2.0\schultz\schultz.html" >Schultz</a></li>
<li><a href="C:\wamp\www\Schultz2.0\proveedores\proveedor es.html">Proveedores</a></li>
<li><a href="C:\wamp\www\Schultz2.0\productos\productos.h tml">Productos</a></li>
<li><a href="C:\wamp\www\Schultz2.0\cotizaciones\cotizaci ones.html">Cotizar</a></li>
<li><a href="C:\wamp\www\Schultz2.0\noticias\noticias.htm l">Noticias</a></li>
<li><a href="C:\wamp\www\Schultz2.0\ubicacion\ubicacion.h tml">Ubicación</a></li></ul>
</div>
</div>
<div id="contenido">
<div id="texto">
<h3></h3>
<h1>Schultz Soluciones Neumáticas</h1>
<div id="portada">
<img src="C:\wamp\www\Schultz2.0\objetos\fotoempresa.jp g" alt="" />
</div>
</div>
</div>
<div id="pie">
<div id="datosimg">
<img src="C:\wamp\www\Schultz2.0\objetos\datosschultz.j pg" alt="" />
</div>
</div>
</div>
</body>
</html>
  #4 (permalink)  
Antiguo 18/03/2010, 11:26
 
Fecha de Ingreso: marzo-2010
Mensajes: 4
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: Problema con Mozilla

Por favor Ayuda!
  #5 (permalink)  
Antiguo 18/03/2010, 12:13
 
Fecha de Ingreso: marzo-2009
Ubicación: Santo André - São Paulo - Brasil
Mensajes: 91
Antigüedad: 8 años, 8 meses
Puntos: 1
De acuerdo Respuesta: Problema con Mozilla

Haga lo seguinte quando usted llama la hoja de estilo con LINK vos esta ponendo camino "absoluto"(yo no se se tiene esta palabra en español). Intentas loa seguiente.

Código HTML:
Ver original
  1. <link rel="styleheet" type="text/css" href="estilosgeneral.css">

Otra cosa para no tener otros errores. Siempre haga lo seguinte en los links.

./ para la misma carpeta.
../ para volvier la carpeta.

por ejemplo.

Caso vos tiene la hoja de estilo en outra carpeta. vos puede hacer así.

./css/[nombrehojeestilo].css

dentro de la hoje de estilo las image vos tiene que poner así

Código CSS:
Ver original
  1. body{
  2. background-image:url(../images/[nombreimage].png);
  3. }

con esta sugestiones vos va corrigir todo su codigo e evitar otros errores.
  #6 (permalink)  
Antiguo 18/03/2010, 15:43
 
Fecha de Ingreso: marzo-2010
Mensajes: 4
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: Problema con Mozilla

Estimado flpms,

Muchas Gracias por tu respuesta era exactamente el problema por que no se estaba viendo bien.

Muchas Gracias!!

Etiquetas: mozilla
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:08.