Foros del Web » Creando para Internet » CSS »

Problema con pixeles extra de Internet Explorer

Estas en el tema de Problema con pixeles extra de Internet Explorer en el foro de CSS en Foros del Web. Hola a todos, Les escribo para ver si alguien me puede ayudar con mi problema. Se trata de lo siguiente, en la página web que ...
  #1 (permalink)  
Antiguo 27/12/2009, 15:05
ginnomillan
Invitado
 
Mensajes: n/a
Puntos:
Problema con pixeles extra de Internet Explorer

Hola a todos,

Les escribo para ver si alguien me puede ayudar con mi problema.

Se trata de lo siguiente, en la página web que estoy desarrollando,

http://probe.sytes.net/

Todo funciona bien con firefox. El problema comienza con Internet Explorer 8.

Si se fijan al abrirla, hay una parte inferior con color de fondo azul. Pues bueno, el dilema es que el texto no se mantiene alineado, dependiendo de si aparace o no la barra de scroll vertical, se trata de unos cuantos pixeles, pero me gustaría saber cómo se puede arreglar eso, puesto que como digo solo me ocurre en explorer, no con firefox.

A la espera de sus comentarios, se despide

Ginno
  #2 (permalink)  
Antiguo 27/12/2009, 16:24
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema con pixeles extra de Internet Explorer

no estoy muy claro con lo que mencionas. sin embargo, veo que tienes una hoja de estilo para iexplorer. pues bien, si elimino el selector #contenedor-inferior del archivo index-ie.css se visualiza igual que firefox.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #3 (permalink)  
Antiguo 27/12/2009, 17:26
ginnomillan
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema con pixeles extra de Internet Explorer

De acuerdo, pero el problema es que cuando lo elimino, la página no me deja hacer scroll vertical... ¿¿??, si uno observa la página con explorer 8 y le colocas más barras de herramientas, cosa que tenga que automáticamente aparacer la barra de scroll vertical... no aparece...

Mira dejé la página con la modificación que tu me dices.

Saludos

Ginno
  #4 (permalink)  
Antiguo 27/12/2009, 18:14
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema con pixeles extra de Internet Explorer

la verdad... o yo no te entiendo, o tu no te explicas. te pongo una captura de como se visualiza. primero, veras como elimine el estilo aplicado a iexplorer.


con scroll vertical


sin scroll vertical
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #5 (permalink)  
Antiguo 27/12/2009, 18:27
ginnomillan
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema con pixeles extra de Internet Explorer

A ver.. tienes razón, mejor con imágenes: Con este código en la hoja de estilos para IE:

/* Sector inferior */
/*#contenedor-inferior {position: absolute; width: 993px; height: 33px; left: 0px; top: 548px; font-family: Arial; font-size: 80%; color: #ffffff;}*/
#institucion {position: absolute; width: 184px; height: 33px; left: 12px; top: 3px; z-index: 1}
#direccion {position: absolute; width: 253px; height: 33px; left: 256px; top: 3px; z-index: 2}
#fono-fax {position: absolute; width: 190px; height: 33px; left: 567px; top: 3px; z-index: 3}
#contacto {position: absolute; width: 53px; height: 33px; left: 815px; top: 3px; z-index: 4}
#sitemap {position: absolute; width: 84px; height: 33px; right: 12px; top: 3px; z-index: 5}
/*-- ESPECIFICACION DE ACCIONES SOBRE LAS FUENTES --*/
/*-- MAPA DEL SITIO --*/
a.sitemap:link {text-decoration:none; color: #ffffff;}
a.sitemap:visited {text-decoration:none; color: #ffffff;}
a.sitemap:active {text-decoration:none; color: #ffffff;}
a.sitemap:hover {text-decoration:underline; color: #ffffff;}
/*-- CONTACTO --*/
a.contacto:link {text-decoration:none; color: #ffffff;}
a.contacto:visited {text-decoration:none; color: #ffffff;}
a.contacto:active {text-decoration:none; color: #ffffff;}
a.contacto:hover {text-decoration:underline; color: #ffffff;}

Esto ocurre: Todas estas capturas son con una resolución de pantalla de 1024x768 que es en la que por defecto estoy diseñando.



Fíjate ahora que al explorer le quité una de las barras de su menú y mira lo que ocurre:



Ese es mi gran drama. Que no me aparece la barra de scroll vertical automáticamente

Última edición por ginnomillan; 27/12/2009 a las 18:55
  #6 (permalink)  
Antiguo 27/12/2009, 18:51
ginnomillan
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema con pixeles extra de Internet Explorer

Bueno,

Por fin lo solucioné. Claro que la solución fue la siguiente:

/* Sector inferior */
#contenedor-inferior {position: relative; width: 1000px; height: 33px; left: 0px; top: 548px; font-family: Arial; font-size: 80%; color: #ffffff;}
#institucion {position: absolute; width: 184px; height: 33px; left: 10px; top: 3px; z-index: 1}
#direccion {position: absolute; width: 253px; height: 33px; left: 256px; top: 3px; z-index: 2}
#fono-fax {position: absolute; width: 190px; height: 33px; left: 567px; top: 3px; z-index: 3}
#contacto {position: absolute; width: 53px; height: 33px; left: 815px; top: 3px; z-index: 4}
#sitemap {position: absolute; width: 84px; height: 33px; right: 10px; top: 3px; z-index:}
/*-- ESPECIFICACION DE ACCIONES SOBRE LAS FUENTES --*/
/*-- MAPA DEL SITIO --*/
a.sitemap:link {text-decoration:none; color: #ffffff;}
a.sitemap:visited {text-decoration:none; color: #ffffff;}
a.sitemap:active {text-decoration:none; color: #ffffff;}
a.sitemap:hover {text-decoration:underline; color: #ffffff;}
/*-- CONTACTO --*/
a.contacto:link {text-decoration:none; color: #ffffff;}
a.contacto:visited {text-decoration:none; color: #ffffff;}
a.contacto:active {text-decoration:none; color: #ffffff;}
a.contacto:hover {text-decoration:underline; color: #ffffff;}

Gracias zerokilled
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:50.