Foros del Web » Creando para Internet » CSS »

Problema con position absolute en Opera

Estas en el tema de Problema con position absolute en Opera en el foro de CSS en Foros del Web. Hola gente... Tengo un problema y por los test es con el position absolute, solo en Opera en el resto se ve bien (FF, IE6 ...
  #1 (permalink)  
Antiguo 22/07/2008, 10:26
Avatar de faiverson  
Fecha de Ingreso: mayo-2005
Mensajes: 79
Antigüedad: 12 años, 7 meses
Puntos: 0
Busqueda Problema con position absolute en Opera

Hola gente...

Tengo un problema y por los test es con el position absolute, solo en Opera en el resto se ve bien (FF, IE6 and 7, safari).

Código PHP:
<div id="playvideo"><img src="images/playvideo_grudge.png" border="0" height="54" width="98" /></div
EL CSS es el siguiente, bien sencillo:

Código PHP:
div#playvideo{position:absolute; left:250px; top:160px; z-index:5; } 
Si uso en el CSS:
Código PHP:
background-image:url(../images/playvideo_grudge.png); background-repeat:no-repeat
soluciono el problema, o si le doy la vuelta y uso position relative en vez de absolute, igual me queda picando porque no anda?

Probe un HTML solo con ese div y le agregue texto con position absolute, y el texto se posiciona y se ve, pero la imagen no, asi que se ve que es cuando se usa una imagen con position absolute en Opera.

Ideas?

Alguien conoce algun hack para Opera?
__________________
Fabi... fighting versus the web
  #2 (permalink)  
Antiguo 22/07/2008, 10:31
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema con position absolute en Opera

¿Puedes poner el trozo de código con el que estás probando, incluido su doctype? ¿Y en qué versión de Opera te pasa?

Mikel.
  #3 (permalink)  
Antiguo 22/07/2008, 10:51
Avatar de faiverson  
Fecha de Ingreso: mayo-2005
Mensajes: 79
Antigüedad: 12 años, 7 meses
Puntos: 0
Respuesta: Problema con position absolute en Opera

Ya lo solucione...
La version de Opera es la Versión 9.51

Este particular error se debe a un script que uso para la transparenciade png's en IE6. (Ahora lo ejecuto solo para IE6, con lo que soluciono el problema...)

Agrego los codigos para el que quiera ir mas alla y probar:

A modo simple la pagina seria:
Código HTML:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>hi world!</title>
<link href="css/grudge.css" rel="stylesheet" type="text/css" />
<script defer type="text/javascript" src="js/png.js"></script><!-- aca ta el problema! -->
</head>
<body>
<div id="playvideo"><img src="http://www.forosdelweb.com/images/playvideo_grudge.png" border="0" height="54" width="98" /></div>
</body>
</html> 
El CSS:
Código PHP:
div#playvideo{position:absolute; left:250px; top:160px; } 
Y el .js que trae el problema tiene:

Código PHP:
function PNG_loader() { 
   for(var 
i=0i<document.images.lengthi++) { 
      var 
img document.images[i]; 
      var 
imgName img.src.toUpperCase(); 
      if (
imgName.substring(imgName.length-3imgName.length) == "PNG") { 
         var 
imgID = (img.id) ? "id='" img.id "' " ""
         var 
imgClass = (img.className) ? "class='" img.className "' " ""
         var 
imgTitle = (img.title) ? "title='" img.title "' " "title='" img.alt "' "
         var 
imgStyle "display:inline-block;" img.style.cssText
         if (
img.align == "left"imgStyle += "float:left;"
         if (
img.align == "right"imgStyle += "float:right;"
         if (
img.parentElement.hrefimgStyle += "cursor:hand;"
         var 
strNewHTML "<span " imgID imgClass imgTitle 
            
" style=\"" "width:" img.width "px; height:" img.height "px;" imgStyle ";" 
            
"filter:progid:DXImageTransform.Microsoft.AlphaImageLoader" 
            
"(src=\'" img.src "\', sizingMethod='scale');\"></span>"
         
img.outerHTML strNewHTML
         
i--; 
      } 
   } 

try{
window.attachEvent("onload"PNG_loader); 
}catch(
e){}
/*
<!--[if gte IE 5.0]> 

<script type="text/javascript" src="png.js"></script> 

<![endif]--> 
*/ 
Gracias por responder tan rapido! Saludos!
__________________
Fabi... fighting versus the web
  #4 (permalink)  
Antiguo 22/07/2008, 10:59
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema con position absolute en Opera

Ah, pues nada. Me alegro de que hayas solucionado.

Mikel.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:34.