Foros del Web » Creando para Internet » CSS »

problema con los selectores hijos

Estas en el tema de problema con los selectores hijos en el foro de CSS en Foros del Web. Buenas a todo el mundo. Tengo el siguiente problemilla con el código que pongo a continuación: ---------------------------------------------------- <html> <head> <meta http-equiv="Content-Language" content="es"> <meta name="GENERATOR" content="Microsoft ...
  #1 (permalink)  
Antiguo 23/03/2007, 02:07
 
Fecha de Ingreso: marzo-2007
Mensajes: 126
Antigüedad: 10 años, 9 meses
Puntos: 2
problema con los selectores hijos

Buenas a todo el mundo.

Tengo el siguiente problemilla con el código que pongo a continuación:

----------------------------------------------------

<html>

<head>
<meta http-equiv="Content-Language" content="es">
<meta name="GENERATOR" content="Microsoft FrontPage 5.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>Pagina nueva 2</title>


<style type="text/css">
p > b {color:#00FF00}
</style>

</head>


<body>

<p><b>buenos días</b><font size="7"><b> buenas tardes</b></font></p>
</body>

------------------------------------

Según entiendo, el texto "buenos días" debería aparecer en color verde y el texto "buenas tardes" no, pero en realidad, no me aparece en verde ningún texto. ¿Por qué?, ¿es que entiendo mal lo de los selectores hijos?.

Me pasa lo mismo si intento realizar lo de los "selectores hermanos adyacentes". Es decir:

----------------------------------------------------

<html>

<head>
<meta http-equiv="Content-Language" content="es">
<meta name="GENERATOR" content="Microsoft FrontPage 5.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>Pagina nueva 2</title>


<style type="text/css">
i + b {color:#00FF00}
</style>

</head>


<body>

<p><i>buenos días</i><b> buenas tardes</b></p>
</body>

------------------------------------

Según entiendo "buenas tardes" debería aparecer en verde ya que la etiqueta <b>es un hermano de <i> y además está a continuación de esta, pero nada de nada.

Muchas gracias a todos.

Última edición por pumi; 23/03/2007 a las 02:16
  #2 (permalink)  
Antiguo 23/03/2007, 02:56
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Re: problema con los selectores hijos

Hola pumi

Yo creo que tu código es correcto, pero hay un navegador, de cuyo nombre preferimos no acordarnos, que no lo acepta. Si lo pruebas en Firefox u Opera, verás que queda bien.

Saludos,
  #3 (permalink)  
Antiguo 23/03/2007, 04:30
 
Fecha de Ingreso: marzo-2007
Mensajes: 126
Antigüedad: 10 años, 9 meses
Puntos: 2
Re: problema con los selectores hijos

Perfecto, muchisimas gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:46.