Foros del Web » Creando para Internet » CSS »

Problema con Z-index

Estas en el tema de Problema con Z-index en el foro de CSS en Foros del Web. Hola amigos, estoy creando un menu con vertical desplegable con jquery y css, y tengo problemas para mostrar el menu que se despliega, a un ...
  #1 (permalink)  
Antiguo 14/05/2010, 09:54
Avatar de chichote
Colaborador
 
Fecha de Ingreso: diciembre-2004
Ubicación: Santiago - Chile
Mensajes: 1.868
Antigüedad: 13 años
Puntos: 145
Problema con Z-index

Hola amigos, estoy creando un menu con vertical desplegable con jquery y css, y tengo problemas para mostrar el menu que se despliega, a un costado tengo otro slide con jquery al cual le tengo dado zindex 9 y al menu le puse 99 pero siempre el menu q se despliega se ve debajo del slide de imagenes, aunque le ponga un chorro de 9999999999999999999 pasa lo mismo, no se q pueda ser y ya no se que hacer.

les dejo ambos codigos para ver si me hechan una manito.

Menu

Código HTML:
#nav, #nav li ul							{	list-style-type: none; margin: 0; padding: 0; 
												width: 255px; border:#00FF00 1px solid /*WIDTH OF MAIN MENU ITEMS*/}
#nav li										{	position: relative; text-align:right;}
#nav li a									{	color: white; display: block; width: auto; padding: 2px 0; text-decoration: none;}
#nav li ul									{	/*SUB MENU STYLE*/position: absolute; width: 190px; background:#666666;
												left: 0; top: 0; display: none; margin-left:255px; z-index:9999 }
#nav li ul li								{	float: left; text-align:left; }
#nav li ul a								{	width: 180px; /*WIDTH OF SUB MENU ITEMS - 10px padding-left for A elements */}
#nav .arrowdiv								{	position: absolute; right: 2px;}
#nav li a:visited, #nav li a:active			{	color:#FFFFFF;}
#nav li a:hover								{	color:#CCCCCC}
/* Holly Hack for IE \*/
* html #nav li								{	float: left; height: 1%; }
* html #nav li a							{	height: 1%; }
/* End */
Slide
Código HTML:
#slide										{	float:left; height:279; margin-top:1px;}
#slideshow									{	position:relative; height:279px;}
#slideshow IMG								{	position:absolute; top:0; left:0; z-index:8; opacity:0.0;}
#slideshow IMG.active						{	z-index:10; opacity:1.0;}
#slideshow IMG.last-active					{	z-index:9;}
saludos
__________________
http://chicho.ninja yiaaaa
  #2 (permalink)  
Antiguo 14/05/2010, 10:27
Avatar de chichote
Colaborador
 
Fecha de Ingreso: diciembre-2004
Ubicación: Santiago - Chile
Mensajes: 1.868
Antigüedad: 13 años
Puntos: 145
Respuesta: Problema con Z-index

Solucionado, provando y probando llegue a la solucion

le puse z-index: -1 a la capa q contiene al slide

#slideshow { position:relative; height:279px; z-index:-1}

y funciona bien tanto en IE6, IE7, IE8 y FF.

Moraleja 1: no siempre el esfuerzo debe concentrarse en tratar de hacer algo, hay veces en que tratando de no hacer algo es suficiente. En este caso no no me funciono tratando de mostrar algo, pero si funcionó "ocultando" la otra parte

Moraleja 2: dar muerte a IE jajaja

Saludos.
__________________
http://chicho.ninja yiaaaa

Etiquetas: z-index
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:44.