Foros del Web » Creando para Internet » CSS »

Problema CSS

Estas en el tema de Problema CSS en el foro de CSS en Foros del Web. Buenas a todos, estoy con un inconveniente que no he podido resolver, como puedo hacer para tener un DIV que tenga un fondo repetido, el ...
  #1 (permalink)  
Antiguo 20/07/2009, 15:40
 
Fecha de Ingreso: marzo-2008
Mensajes: 171
Antigüedad: 9 años, 9 meses
Puntos: 0
Problema CSS

Buenas a todos, estoy con un inconveniente que no he podido resolver, como puedo hacer para tener un DIV que tenga un fondo repetido, el cual este abajo de todo de la pagina y a su vez otro con un SWF centrado horizontalmente, en la parte superior de la pagina.

Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

<style type="text/css">
<!--
body {
	margin-left: 0px;
	margin-top: 0px;
	margin-right: 0px;
	margin-bottom: 0px;
	background-color: #000000;
}
#TODO {
	background-image: url(img/fondos/poker+pros+wallpaper.jpg);
	background-repeat: repeat-x;
	background-position: bottom;
	height: 100%;
	width: 100%;
	position: absolute;
}
#SITE {
	height: 750px;
	width: 800px;
	position: relative;
	top: 0px;
	background-color: #000000;
}
-->
</style>
</head>

<body>
<div class="#TODO" id="TODO">

  <div class="#SITE">
  
  <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="850" height="750">
  <param name="movie" value="site.swf" />
  <param name="quality" value="high" />
  <param name="wmode" value="transparent" />
  <embed src="site.swf" width="800" height="750" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" wmode="transparent"></embed>
</object>
  
  </div>
</div>
</body>
</html>
El problema que tengo con este que puse es que el SWF no me queda CENTRADO, y ademas si cambio la resolucion no me queda "ENCUADRADO EN PANTALLA AL MAXIMO"

No se si me explico, pero bueno, cualquier cosa me explico mejor.

Un beso grande y espero puedan ayudarme

Chauchis,

Agustina.
  #2 (permalink)  
Antiguo 20/07/2009, 16:50
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problema CSS

Hola Agustina:
Lo primero de todo, corrige tu código:
Cita:
<div class="#TODO" id="TODO">
<div class="#SITE"id="SITE">
aunque sería preferible que nombrases tus selectores en minúsculas.

Y para centrarlo te faltan un par de cosillas.
A falta de poder trabajar con tu archivo de flash, he modificado algo tu código (sin entrar en lo relativo a tu <objet>
Código html:
Ver original
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml" lang="es-es">
  3. <title>Kseso? jugando con css </title>
  4. <meta http-equiv="Content-Type" content="text/html;charset=iso-8859-1" />
  5. <style type="text/css">
  6. * {margin:0;padding:0; border:0; outline:none;  position: relative;}
  7. body {background-color: #000000;}
  8. #todo {
  9.     background: url(imagen.jpg) repeat-x scroll left bottom;
  10.     height: 100%;
  11.     width: 100%;
  12.     overflow: hidden;
  13. }
  14. #site {
  15.     height: 750px;
  16.     width: 800px;
  17.     top: 0px;
  18.     background-color: #000000;
  19.     margin: 0 auto;
  20. }
  21. </head>
  22. <div id="todo">
  23.   <div id="site">  
  24.     <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="850" height="750">
  25.   <param name="movie" value="site.swf" />
  26.   <param name="quality" value="high" />
  27.   <param name="wmode" value="transparent" />
  28.   <embed src="site.swf" width="800" height="750" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" wmode="transparent"></embed>
  29. </object>  
  30.   </div>
  31. </div>
  32. </body>
  33. </html>

Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #3 (permalink)  
Antiguo 21/07/2009, 02:17
 
Fecha de Ingreso: marzo-2008
Mensajes: 171
Antigüedad: 9 años, 9 meses
Puntos: 0
Respuesta: Problema CSS

Holis! Muchas gracias por tu ayuda! Mi duda es por que el fondo no queda abajo del todo, sino que queda abajo, relativo al SWF, yo quiero que quede estilo PIE DE PAGINA, no se si me explico. Y el fondo de mi SWF no es transparente, no deja que se vea el fondo. Por que puede ser esto?

En caso que no me haya explicado bien, hago una imagen.

Desde ya muchas gracias y un beso grande.

Agustina
  #4 (permalink)  
Antiguo 21/07/2009, 02:58
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problema CSS

Hola de nuevo, Agustina:
Lo de pie de página, no acabo de comprender muy bien qué quieres realizar.
Así que te pongo distintas soluciones, ya publicadas antes por aquí, así puedes elegir lo que más te guste:
Una
Pie abajo si el contenido es menor que la ventana pero que se desplaza si aumenta.

Sobre el tema de flash, siento no poder ayudarte al respecto.

Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:15.