Foros del Web » Creando para Internet » CSS »

Problema en links

Estas en el tema de Problema en links en el foro de CSS en Foros del Web. hola tengo una duda y un problema a la vez, y eh buscado por aqui pero no he encontrado nada al respecto , veran tengo ...
  #1 (permalink)  
Antiguo 22/06/2005, 13:52
 
Fecha de Ingreso: diciembre-2004
Mensajes: 346
Antigüedad: 13 años
Puntos: 1
Problema en links

hola tengo una duda y un problema a la vez, y eh buscado por aqui pero no he encontrado nada al respecto , veran tengo una hoja de estilos con los a:link, a:hover, etc..

A:link {
color:000000;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
A:hover {
color:ffffff;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
A:active {
color:ffffff;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
A:visited {
color:000000;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}

esto obviamente para los links en general, pero a la hora de integrar otro como se diria... "class"

.link {
color:e3c4c4;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
.link:hover {
color:ffffcc;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
.link:active {
color:ddbbaa;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
.link:visited {
color:e3c4c4;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}

por asi decirlo, puesto que le kiero dar otro estilo a los links de una cierta parte... es que mi pagina como veran en el codigo es modular, llamando news.php, artic.php, etc.. entonces cuando pongo en news.php entre el link

<a href="dondeir.php" class="link">texto</a>

no me lo respeta y jala el general a:hover, a:active, etc... se me ocurrio meterlo en otro css aparte, pero el problema viene que como mi pagina es modular y se incluye el header.php y ahi tengo el css general

he visto paginas que usan un # para poner subsecciones de un link, pero no se como funcionan ni que hacen, como se podran dar cuenta no se mucho de css

Espero me puedan ayudar

Saludos
  #2 (permalink)  
Antiguo 22/06/2005, 15:12
Avatar de kahlito
Colaborador
 
Fecha de Ingreso: marzo-2003
Ubicación: En el Estrecho y el mar
Mensajes: 2.893
Antigüedad: 14 años, 9 meses
Puntos: 60
Hola AngelShady, me he perdido un poco, pero creo que te falta la a delante de la clase link:

Código:
a.link {
color:e3c4c4;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
a.link:hover {
color:ffffcc;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
a.link:active {
color:ddbbaa;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
a.link:visited {
color:e3c4c4;
font-size:8pt;
font-family:verdana;
font-weight:bold;
text-decoration:none;
}
Saludosss
  #3 (permalink)  
Antiguo 22/06/2005, 15:58
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
tambien recuerda siempre poner tus clases en el orden
:link
:visited
:hover
:active
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #4 (permalink)  
Antiguo 22/06/2005, 23:17
 
Fecha de Ingreso: diciembre-2004
Mensajes: 346
Antigüedad: 13 años
Puntos: 1
hola gracias, si las tengo en ese orden creo que sera la falta de la a, voy a probarlo a ver si me sirve, aunque sin la a me funciona, pero probare a ver k pasa thanks

---------------------------

Si era eso, faltaba la a. gracias por su ayuda a los dos, saludos

Última edición por AngelShady; 23/06/2005 a las 17:48
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:16.