Foros del Web » Creando para Internet » CSS »

Problema pagina al loguearme

Estas en el tema de Problema pagina al loguearme en el foro de CSS en Foros del Web. Hola, tengo un problema con una pagina, que al loguearme, me muestra un menu en flash, pero este no es el problema, hay algo mal ...
  #1 (permalink)  
Antiguo 20/05/2009, 08:38
Avatar de johnnygomez  
Fecha de Ingreso: octubre-2007
Mensajes: 166
Antigüedad: 10 años, 2 meses
Puntos: 0
Problema pagina al loguearme

Hola, tengo un problema con una pagina, que al loguearme, me muestra un menu en flash, pero este no es el problema, hay algo mal en el css y no puedo dar con que es la pagina como podran ver se muestra bien si no estoy logueado




la pagina la dividi como parte lateral que es donde estan los menues y algun que otro banner, y a parte central (centro derecho) que esta la informacion de la pagina. al loguearme, me muestra un menu en flash pero me deforma la pagina, tanto en chrome como firefox me la muestra de la siguiente manera




y en IE 8 de la siguiente manera




adjunto mas o menos como me base para hacer la "caja" del menu que es generica, es la misma que utilizo para la parte de abajo, lo cual me dio a pensar que era el flash, pero saco el flash y me lo sigue haciendo.

codigo del menu
Código:
<div class="recuadroCentro">
  <div class="topleft"></div><div class="topcentro"></div><div class="topright"></div>
  <div class="contentcell">
  <p>
        <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="507" height="96" id="header" align="middle">
        <param name="allowScriptAccess" value="sameDomain" />
        <param name="movie" value="swf/user_menu.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#1a1a1a" /><embed src="swf/user_menu.swf" quality="high" bgcolor="#1a1a1a" width="507" height="96" name="header" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
        </object></p>
    <script type="text/javascript" src="ieupdate.js"></script>
    </div>
 <div class="botleft"></div><div class="botcentro"></div><div class="botright"></div>
</div>
bueno, espero puedan ayudarme, no quiero poner mas codigo porque sino creo que es demasiado, pero si nesecitan algo....


Muchas gracias
__________________
Quien no encuentra ninguna falla en sí mismo, necesita una segunda opinión.
  #2 (permalink)  
Antiguo 20/05/2009, 10:12
Avatar de johnnygomez  
Fecha de Ingreso: octubre-2007
Mensajes: 166
Antigüedad: 10 años, 2 meses
Puntos: 0
Respuesta: Problema pagina al loguearme

Bueno, ya lo pude solucionar, empece a cortar codigo hasta que pude deducir de donde surgia el problema, el problema no era nada de css ni nada... era que cuando se logueaba, tomaba datos del cliente y por un reciente cambio que hice, en la base de datos local no lo tenia en la tabla de socios, por lo tanto me tiraba un error.... no se porque eso derivo a que se vea asi la pagina pero bueno, ya esta. muchas gracias igual por estar siempre
__________________
Quien no encuentra ninguna falla en sí mismo, necesita una segunda opinión.
  #3 (permalink)  
Antiguo 20/05/2009, 10:18
Avatar de CopperDavid  
Fecha de Ingreso: mayo-2009
Ubicación: Madrid
Mensajes: 40
Antigüedad: 8 años, 7 meses
Puntos: 1
Respuesta: Problema pagina al loguearme

Enhorabuena!!!

A veces justo estas explicando el motivo del problema, pensandolo bien te surge la solución.

SALU2.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:01.