Foros del Web » Creando para Internet » CSS »

Problema para alinear (divs + tablas)

Estas en el tema de Problema para alinear (divs + tablas) en el foro de CSS en Foros del Web. Hola! Estoy haciendo una web con divs y tablas. Sé que no es muy correcto pero es la única manera que tenía para que se ...
  #1 (permalink)  
Antiguo 10/12/2010, 04:47
Avatar de frasko01  
Fecha de Ingreso: junio-2008
Mensajes: 200
Antigüedad: 9 años, 5 meses
Puntos: 3
Problema para alinear (divs + tablas)

Hola!

Estoy haciendo una web con divs y tablas. Sé que no es muy correcto pero es la única manera que tenía para que se viera más o menos igual en todos los navegadores.

El problema, por muy raro que suene, no es con IE sino con Firefox y Safari. Estos dos navegadores me descuadran el menú de abajo y al refrescar la página... SORPRESA! aparece en el lugar correcto.

Es muy extraño porque, a veces, la primera vez que entras todo está bien pero haces click en EMPRESA y luego vuelves a HOME y ahí es cuando se descuadra.

Pueden ver la web en: www.aceiteslacuna.com/nueva

Espero que puedan ayudarme. Muchas gracias y saludos!
  #2 (permalink)  
Antiguo 10/12/2010, 04:48
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola frasko01

Muevo tu tema al foro de CSS desde Web general.

Saludos,
  #3 (permalink)  
Antiguo 10/12/2010, 08:06
 
Fecha de Ingreso: julio-2007
Ubicación: Bolivia, Cochabamba
Mensajes: 104
Antigüedad: 10 años, 4 meses
Puntos: 5
Respuesta: Problema para alinear (divs + tablas)

Código HTML:
Ver original
  1. <td align="left" valign="top" colspan="3">
  2.             <table cellspacing="0" cellpadding="0" border="0" class="menu_pie">
  3.                 <tbody><tr>
  4.                     <td align="left" width="835" valign="top">
  5.                         <ul>
  6.                                                         <li><a title="Home" id="seleccionado_pie" href="home">HOME</a></li>
  7.                                                         <li><a title="Empresa" id="" href="empresa">EMPRESA</a></li>
  8.                                                         <li><a title="PRODUCTOS" id="" href="productos">PRODUCTOS</a></li>
  9.                                                         <li><a title="COSECHA" id="" href="cosecha">COSECHA</a></li>
  10.                                                         <li><a title="SALUD" id="" href="salud">SALUD</a></li>
  11.                                                         <li><a title="CONTACTO" id="" href="contacto">CONTACTO</a></li>
  12.                                                         <li style="border: 0px none;"><a title="TIENDA" id="" href="tienda">TIENDA</a></li>
  13.                         </ul>
  14.                     </td>
  15.                     <td align="left" valign="top" style="padding-left: 40px;">
  16.                         <a href="#"><img border="0" style="padding-right: 5px;" title="Facebook" alt="Facebook" src="imagenes/facebook2.gif"></a>
  17.                         <a href="#"><img border="0" style="padding-left: 5px;" title="Twitter" alt="Twitter" src="imagenes/twitter2.gif"></a>
  18.                     </td>
  19.                 </tr>
  20.             </tbody></table>
  21.         </td>

Ahi tienes un colspan="3" creo que es por eso!!

Suerte!
__________________
Jorge A. Inturias C.
Tutoriales | Recursos | Ejemplos | www.disenopaginasweb.com
  #4 (permalink)  
Antiguo 10/12/2010, 09:14
Avatar de frasko01  
Fecha de Ingreso: junio-2008
Mensajes: 200
Antigüedad: 9 años, 5 meses
Puntos: 3
Respuesta: Problema para alinear (divs + tablas)

Gracias inturias, es cierto que el colspan="3" sobraba, pero ya lo he quitado y sigue igual.

Me inquieta una cosilla: en Firefox la tabla se desplaza hacia la derecha y en Safari hacia la izquierda. ¿Esto puede significar algo?
  #5 (permalink)  
Antiguo 16/12/2010, 06:18
Avatar de frasko01  
Fecha de Ingreso: junio-2008
Mensajes: 200
Antigüedad: 9 años, 5 meses
Puntos: 3
Respuesta: Problema para alinear (divs + tablas)

¿Nadie sabe qué está fallando aquí?
Me está rompiendo la cabeza este problema.

Por favor, una ayudita.
  #6 (permalink)  
Antiguo 16/12/2010, 07:21
 
Fecha de Ingreso: marzo-2008
Mensajes: 1.020
Antigüedad: 9 años, 9 meses
Puntos: 21
Respuesta: Problema para alinear (divs + tablas)

Eliminaste el Caché?

Recarga tu página con: CTRL + F5.

Prueba y dinos.

Usa Firebug.

Saludos.
  #7 (permalink)  
Antiguo 16/12/2010, 09:13
Avatar de frasko01  
Fecha de Ingreso: junio-2008
Mensajes: 200
Antigüedad: 9 años, 5 meses
Puntos: 3
Respuesta: Problema para alinear (divs + tablas)

Ya uso firebug. La caché la borro casi cada vez que recargo.

Lo que me pasa es que la primera vez que entro está mal y cuando recargo se pone bien. ¿Qué puede ser?

Saludos.
  #8 (permalink)  
Antiguo 16/12/2010, 10:39
Avatar de frasko01  
Fecha de Ingreso: junio-2008
Mensajes: 200
Antigüedad: 9 años, 5 meses
Puntos: 3
Respuesta: Problema para alinear (divs + tablas)

Lo que más me fastidia es que en Internet Explorer salga bien... es deprimente.
Estoy empezando a desconfiar de todos los navegadores.

Etiquetas: alinear, tablas
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:33.