Foros del Web » Creando para Internet » CSS »

Problema posición!

Estas en el tema de Problema posición! en el foro de CSS en Foros del Web. Hola! Tengo un problema a ver si me podeis ayudar, que me estoy haciendo la picha un lío. http://tecnotor.com/ -> click en productos y maquinaria. ...
  #1 (permalink)  
Antiguo 06/05/2009, 13:49
 
Fecha de Ingreso: agosto-2008
Mensajes: 143
Antigüedad: 9 años, 3 meses
Puntos: 1
Problema posición!

Hola!

Tengo un problema a ver si me podeis ayudar, que me estoy haciendo la picha un lío.

http://tecnotor.com/ -> click en productos y maquinaria.

Si os fijais, en maquinaria (aunque supongo que en productos también aunque no se ve), la lista se me va de la caja de la web. Me pasa en FF/Chrome, y me va bien en IE (qué raro!)

Me estoy haciendo una picha un lío, que posición tengo que poner para lograr que mi caja se meta en el subcontainer que le toca? Digamos que el div maquinaria2, debería estar con el fondo negro...

No acabo de verlo, llevo varias pruebas y no me va, me podeis echar una mano?


Otra cosa aparte, las imágenes que van rotando en FF/Chrome van genial, pero en IE me aslen unos márgenes horribles... Podríais indicarme por dónde debo tirar para solucionar esto?

Muchísimas gracias!
  #2 (permalink)  
Antiguo 06/05/2009, 14:03
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Problema posición!

eso pasa cuando el contenedor del texto( que creo que es subContainer), o no tiene alto o lo tiene fijo, prueba de esta manera:

Código HTML:
.subContainer{min-height:300px;height:auto!important;height:300px;overflow:auto}
aclaro que no estoy seguro de si es ese el contenedor de texto.Si no lo fuera coloca eso al que si lo es.
__________________
WFC
codigo82
  #3 (permalink)  
Antiguo 06/05/2009, 14:25
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problema posición!

creo que debes añadir a #container la propiedad "overflow:auto"
También consigues lo mismo si se lo añades a #subContainer
Pero no he visto posibles efectos secundarios no deseados en otras páginas.

Sobre la segunda cuestión (bordes colereados en las imágenes):
eso lo controla la propiedad "outline: none", por lo que te estaría bien añadir un pequeño reset al inicio de tu css:

Cita:
* {
outline: none;;
}
Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #4 (permalink)  
Antiguo 10/05/2009, 10:46
 
Fecha de Ingreso: agosto-2008
Mensajes: 143
Antigüedad: 9 años, 3 meses
Puntos: 1
Respuesta: Problema posición!

Hola chicos!

Muchas gracias! La clave ha sido el overflow:auto, ya está solucionado, lo he puesto en subcontainer.

Sobre los bordes, he puesto el reset en la CSS como me has dicho pero IE sigue poniendo un marco horrible y feo (FF y Chrome no), que más podría ser?

Gracias chicos!
  #5 (permalink)  
Antiguo 10/05/2009, 18:36
Avatar de willyfc  
Fecha de Ingreso: octubre-2008
Ubicación: Santa Cruz - Bolivia
Mensajes: 662
Antigüedad: 9 años, 2 meses
Puntos: 40
Respuesta: Problema posición!

tal vez funciones haciendo un reset al tag img

Código:
img{border:0}
otra cosa, son solo sugerencias, pero no da muy buen aspecto que en tu menú principal coloques un texto sencillo y al poner el cursor encima tenga bold ya que da la impresión de que se deforma, por cuestión de accesibilidad te sugiero en los vínculos usar los demás atributos ya que veo que no hay navegación por teclado en tu menú:

Código:
#options ul li a{
	color: silver;
	cursor: url(./cursor.cur);
}

#options ul li a:hover{
	color: white;
	font-weight: bold;
}
sugiero añadir:

Código:
#options ul li a:focus,#options ul li a:active{
	color: white;
	font-weight: bold;
}
como te digo son solo sugerencias.
__________________
WFC
codigo82
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:52.