Foros del Web » Creando para Internet » CSS »

Problema simple con div (creo)

Estas en el tema de Problema simple con div (creo) en el foro de CSS en Foros del Web. Hola Foreros! Necesito de su ayuda :D Les cuento: Tengo que implementar una página que tiene 2 fondos, para lo cual colocaré en fondo más ...
  #1 (permalink)  
Antiguo 09/09/2010, 21:11
de-troit
Invitado
 
Mensajes: n/a
Puntos:
Problema simple con div (creo)

Hola Foreros! Necesito de su ayuda :D
Les cuento:

Tengo que implementar una página que tiene 2 fondos, para lo cual colocaré en fondo más grande como fondo principal del body y un div en la parte superior que quiero expandir hacia todo el ancho disponible y poner en ese div el otro fondo (100%) y hacer que el div quede pegado a la parte superior. El problema de esto es que aunque esté al 100% me quedan espacios entre el div y el navegador y también en la parte superior, dejo una imágen:



Supongamos que el fondo blanco es el fondo principal y el div de color negro contiene el fondo secundario que es más pequeño, pero aún así a los lados del div me quedan espacios en blancos (del fondo principal), eso debe ser tapado por el fondo secundario del div.

Espero que me puedan ayudar a solucionar ese problema, ya intenté con todo (no me manejo mucho en CSS)

Les dejo el código que hice como ejemplo:

Código:
<html>
<head>
<style>
div {
	background-image: url(background.png);
	background-repeat: repeat-x;
	background-position: left top;
	color:white;
}
</style>
</head>

<body>
<div>
cotenido aqui<br />
cotenido aquí<br />
cotenido aquí<br />
cotenido aquí<br />
cotenido aquí<br />
cotenido aquí<br />
</div>
</body>
</html>
Saludos!

Última edición por de-troit; 09/09/2010 a las 21:16
  #2 (permalink)  
Antiguo 09/09/2010, 22:50
 
Fecha de Ingreso: septiembre-2010
Mensajes: 2
Antigüedad: 7 años, 3 meses
Puntos: 0
Respuesta: Problema simple con div (creo)

Has probado poniendo al body, margin:0
  #3 (permalink)  
Antiguo 09/09/2010, 23:02
de-troit
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema simple con div (creo)

Cita:
Iniciado por psdtocss Ver Mensaje
Has probado poniendo al body, margin:0
Wow! Eso fué realmente simple

Muchas gracias PSDToCSS!
  #4 (permalink)  
Antiguo 10/09/2010, 06:39
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problema simple con div (creo)

Complementando la respuesta de psdtocss

Utilice un reset css, más o menos amplio, en función de su código. Se evitará muchos problemas como este.
  #5 (permalink)  
Antiguo 11/09/2010, 21:37
de-troit
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema simple con div (creo)

Te refieres a cambiar todos los valores del elemento BODY por los más convenientes?

EJ>
Código:
body {
     margin: 0;
     padding:0;
     text-align:left;
     etc...
     etc...
}
?

(Disculpa mi poco dominio en el tema)

Saludos!
  #6 (permalink)  
Antiguo 12/09/2010, 02:59
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: Problema simple con div (creo)

Hola:

Puedes encontrar información de lo que es un reset en css tanto en google, como en el capítulo 2 del manual css avanzado de www.librosweb.es

Saludos.

  #7 (permalink)  
Antiguo 12/09/2010, 04:21
de-troit
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema simple con div (creo)

Interesante, lo usaré, muchas gracias por hacermelo saber.
Saludos! :)

Etiquetas: simple
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:21.