Foros del Web » Creando para Internet » CSS »

Problema web online

Estas en el tema de Problema web online en el foro de CSS en Foros del Web. Hola que tal, hace un tiempo realicé un sitio con css el cuál funciona perfectamente, subí los archivos por ftp y la página se visualizaba ...
  #1 (permalink)  
Antiguo 25/11/2009, 18:41
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Pregunta Problema web online

Hola que tal, hace un tiempo realicé un sitio con css el cuál funciona perfectamente, subí los archivos por ftp y la página se visualizaba correctamente en todos los navegadores.

Ahora, después de un tiempo encuentro que le falta una imagen al pie de página y el estilo de tipografía del footer desapareció. Esto es muy raro ya que no he hecho ningún cambio en el ftp.

¿que puede estar pasando? mis archivos originales están bien no necesito hacer ningun cambio en dreamweaver. Los volví a subir y siguen faltando imágenes.

gracias
  #2 (permalink)  
Antiguo 25/11/2009, 19:15
 
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 278
Antigüedad: 15 años
Puntos: 0
Respuesta: Problema web online

Deberías poner un enlace a la página y quizás compartir el código del CSS para poder ayudarte, sin tener que adivinar
  #3 (permalink)  
Antiguo 25/11/2009, 21:39
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

Si, disculpen, aqui adjunto imagenes.

Descubri que el problema no es al subirlo online, sino que el problema ya existe cuando previsualizo la web con la opcion del dreamweaver.

Mi footer se ve bien diseñado con css en modo diseño. Cuando lo previsualizo aparece sin el estilo. Chequie que la hoja de estilos estuviera bien adjuntada; de hecho las demás reglas de esa hoja funcionan bien. Es todo un misterio y estoy aprendiendo, pero estas cosas donde no puedo determinar cual es la raíz del problema me bloquean.

El foro no me permite publicar enlaces lamentablemente, y este tema amerita al menos tener una referencia del problema. El/la que este interesado se los puedo enviar por mensaje privado y luego me encargo de actualizar el post con la ayuda que me brindaron para que el problema pueda ayudar a otros usuarios que les pase lo mismo.

muchas gracias
  #4 (permalink)  
Antiguo 25/11/2009, 22:19
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema web online

escribe la url sin protocolo y dominio principal. o sea, sin http://www.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #5 (permalink)  
Antiguo 26/11/2009, 00:17
 
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 278
Antigüedad: 15 años
Puntos: 0
Respuesta: Problema web online

OK, mandame un privado con tu CSS y el archivo HTML para verlo. Seguro que aquí podemos ayudarte
  #6 (permalink)  
Antiguo 26/11/2009, 06:45
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

constructora-norte.com.ar/home.html

En el firebug aparecen todos los estilos menos el del div general del footer (el que contiene el footer)

gracias a todos
  #7 (permalink)  
Antiguo 26/11/2009, 07:03
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema web online

el dominio http://www.constructora.com.ar no existe, o al menos el sitio no responde.

edit @ 8:12 DST -5 GMT,
bien, ahora funciona...
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.

Última edición por zerokilled; 26/11/2009 a las 07:12
  #8 (permalink)  
Antiguo 26/11/2009, 07:08
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

Bueno acabo de solucionarlo. Pero me sigue intrigando saber porque.

Tengo dos hojas de estilos, una en el documento html y otra adjunta (estilos.css). En la hoja de estilos adjunta tengo todas las propiedades del footer, solo esas no funcionaban bien, el resto de las reglas si.
Movi todo lo relacionado con el footer al style de la hoja y anduvo, ahora aparece tal cual el estilo que coloque. Es muy raro, y me interesaría saber cual fue el error para aprender a pesar de que ahora funcione. Alguna idea?
  #9 (permalink)  
Antiguo 26/11/2009, 07:28
 
Fecha de Ingreso: agosto-2008
Mensajes: 469
Antigüedad: 9 años, 3 meses
Puntos: 20
Respuesta: Problema web online

Seguramente el fallo esta en que no estabas vinculando bien a la hoja de estilos adjunta o bien que no estasbas definiendo bien el doctype.

Edito: Efectivamente no tienes definido el doctype en la cabecera del html, y por alguna razón que ignoro, si no lo defines no funcionan las hojas de estilo adjuntas.

Mira esta info: http://www.eslomas.com/index.php/arc...xhtml-doctype/

Saludos¡¡
  #10 (permalink)  
Antiguo 26/11/2009, 07:36
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema web online

@ marie_c,
la causa no pude investigarla porque no me dio tiempo analizarlo. con el fin de una critica constructiva, personalmente a mi el diseño me parece agradable pero tienes un desastre serio en el codigo. especificamente a lo que me refiero es a la forma que haces la alineacion del contenido con la imagen de fondo. cuando analizalo los elementos con firebug el contenido se desplaza de una forma tan radical y me parecio curioso el por qué sucede. parte de la razon es porque estas usando <br /> para alinear el contenido con el fondo. mi recomendacion, evitalo y utiliza css para alinear los elementos.

edit @ 8:50 DST -5 GMT,
una captura para hacer mas evidente lo que se aprecia cuando se depura en firebug. a primera vista no parece ser un problema cuando el usuario visualiza la web, o al menos con mis configuraciones no presenta problema.


@Impostor,
¿seguro que no tiene un DOCTYPE? yo le veo el siguiente
Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.

Última edición por zerokilled; 26/11/2009 a las 07:50
  #11 (permalink)  
Antiguo 26/11/2009, 07:43
 
Fecha de Ingreso: agosto-2008
Mensajes: 469
Antigüedad: 9 años, 3 meses
Puntos: 20
Respuesta: Problema web online

Cuando yo lo mire no estaba.
  #12 (permalink)  
Antiguo 26/11/2009, 09:22
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

Justo estaba subiendo los cambios al ftp por eso la pagina estaba caida.

Respecto al código seguramente sea un caos. Sucede que estoy aprendiendo y practico haciendo paginas. Muchos errores los puedo detectar pero otros como este me son imposibles, y acudo a ustedes.

Impostor, estuve leyendo la pagina que me recomendaste y veo que seguramente deba usar en vez de Transitional, Strict.
Ademas pase la web por la validacion (validator w3 org) y me ha salido el siguiente error:
This document uses an inconsistent DOCTYPE declaration. The Public Identifier -//W3C//DTD XHTML 1.0 Strict//EN declares the XHTML 1.0 Strict document type, but the associated System Identifier w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd does not match this document type.

The recommended System Identifier for XHTML 1.0 Strict is w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd

Deberia pasar el Doctype a Strict ? Si lo modifico no alterará el funcionamiento en otras secciones de elementos flash y javascript?
  #13 (permalink)  
Antiguo 26/11/2009, 09:39
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema web online

no es necesario que cambies de transicional a estricto, lo que sucede es que la declaracion del DOCTYPE para XHTML Transitional esta mal declarada. deberia ser asi,
Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
hasta cierto punto puede que ciertas funcionalidades queden invalidas pero eso depende si dichas funcionalidades se escribieron pensando en el DOCTYPE que se va a emplear.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #14 (permalink)  
Antiguo 26/11/2009, 09:48
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

La compare y es la misma que use. Salvo que luego le sigue esta linea:
<html xmlns="(http//www)w3.org/1999/xhtml">
seguramente deba borrarla no ? El resto, si mis ojos no me engañan es igual.
  #15 (permalink)  
Antiguo 26/11/2009, 09:57
Avatar de zerokilled
Javascripter
 
Fecha de Ingreso: abril-2009
Ubicación: Isla del Encanto, La Borinqueña [+>==]
Mensajes: 8.049
Antigüedad: 8 años, 7 meses
Puntos: 1484
Respuesta: Problema web online

no, no debes borrarlo. cualquier documento XHTML se compone de la siguiente base que es obligatoria.
Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns='http://www.w3.org/1999/xhtml'><head>
<title>Test Development</title>
</head>

<body>

</body></html>
el DOCTYPE es lo que puede variar.
__________________
la maldad es una virtud humana,
y la espiritualidad es la lucha del hombre contra su maldad.
  #16 (permalink)  
Antiguo 27/11/2009, 07:18
 
Fecha de Ingreso: agosto-2009
Mensajes: 12
Antigüedad: 8 años, 3 meses
Puntos: 0
Respuesta: Problema web online

genial!! gracias :)
voy a mejorar el codigo, un saludo!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:31.