Foros del Web » Creando para Internet » CSS »

Problemas con background

Estas en el tema de Problemas con background en el foro de CSS en Foros del Web. Gente del foro Abro este tema, para ver si me pueden dar una mano con esto que me está pasando. La verdad que estuve toda ...
  #1 (permalink)  
Antiguo 01/09/2009, 16:46
 
Fecha de Ingreso: agosto-2009
Mensajes: 59
Antigüedad: 8 años, 4 meses
Puntos: 2
Problemas con background

Gente del foro

Abro este tema, para ver si me pueden dar una mano con esto que me está pasando. La verdad que estuve toda la tarde rompiéndome la cabeza y no logro entender que estoy haciendo mal.

Estoy aprendiendo CSS mientras desarrollo un sitio. Lo pienso dividir en tres cajas:

#cabecera, #cuerpo y #pie.

La idea que que todas tengan un fondo en degradado, para lo cual generé tres imágenes del mismo ancho, pero distintos altos. Una imágen para cada caja.
Las tres imágenes, además, tienen bordes laterales de 1px en color gris claro.

Bueno sin explayarme mas el problema es que en #cabecera la imagen se ve perfecto, pero en #cuerpo no se ven los bordes.

Aclaro que la imagen de cabecera es fija y la del cuerpo se repite verticalmente.

Dejo parte del codigo CSS

Código:
#cabecera{
	background:url(imagenes/header2.gif)  no-repeat;
	width: 768px;
	height:143px;
	margin:0 auto;
	padding:8px 0 0 0;
	position:relative;
}

#cuerpo {
	background:url(imagenes/fnd_contenidos.gif) repeat-y;
	width: 768px;
	height:50px;
	margin:0 auto;
	/*padding: 20px 10px 20px 15px;*/
	position:relative;
}
Saludos a todos y de antemano muchas gracias!!
  #2 (permalink)  
Antiguo 01/09/2009, 17:18
 
Fecha de Ingreso: noviembre-2008
Ubicación: W2.0
Mensajes: 103
Antigüedad: 9 años
Puntos: 1
Respuesta: Problemas con background

Intenta con esto

Cita:
border: 1px solid #dedede
  #3 (permalink)  
Antiguo 01/09/2009, 18:20
 
Fecha de Ingreso: agosto-2009
Mensajes: 59
Antigüedad: 8 años, 4 meses
Puntos: 2
Respuesta: Problemas con background

Hola diego, gracias por responder.
mirá esto ya lo había probado y funciona.

Mi problema puntual está en esta línea:

background:url(imagenes/fnd_contenidos.gif) repeat-y;

La imágen es de 768px (ancho) X 1px (alto).
El tema es que la imágen se ve como fondo del contenedor, pero no me muestra el primer y ultimo pixel (que es de color distinto para cumplir funciones de borde)

espero me haya sabido explicar


Saludos y gracias
  #4 (permalink)  
Antiguo 01/09/2009, 19:39
Avatar de alexk
Colaborador
 
Fecha de Ingreso: julio-2009
Ubicación: De vuelta al trono
Mensajes: 1.697
Antigüedad: 8 años, 5 meses
Puntos: 137
Respuesta: Problemas con background

Cita:
pero no me muestra el primer y ultimo pixel (que es de color distinto para cumplir funciones de borde)
las funciones de borde las hace el borde... sin mas... quita los bordes a la imagen y agregalos al css... no veo cual es el problema... talvez si pones la URL del problema veamos por que no usas "border" chao y suerte!.
  #5 (permalink)  
Antiguo 01/09/2009, 19:49
Avatar de daPhyre
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: [email protected] (Redirects to 127.0.0.1)
Mensajes: 2.404
Antigüedad: 9 años, 9 meses
Puntos: 142
Respuesta: Problemas con background

Prueba poner un padding mínimo, aunque sea de 1px... Creo que eso lo resolverá (Curiosamente, descubrí hace poco este extraño evento. Espero te ayude).
__________________
<signs>daPhyre</signs>
Jugaa.me


Adios al dolor de cabeza de IE...
  #6 (permalink)  
Antiguo 02/09/2009, 15:09
 
Fecha de Ingreso: agosto-2009
Mensajes: 59
Antigüedad: 8 años, 4 meses
Puntos: 2
Respuesta: Problemas con background

gracias gente por las respuestas.
al final no era problemas de la hojade estilos sino de la imagen en cuestion.

saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:56.