Foros del Web » Creando para Internet » CSS »

Problemas con los enlaces.

Estas en el tema de Problemas con los enlaces. en el foro de CSS en Foros del Web. He hecho una cabecera con un pequeño div a la izquierda, que hace de enlace con imagen que cambia. Me he dado cuenta de que ...
  #1 (permalink)  
Antiguo 12/10/2004, 07:10
 
Fecha de Ingreso: febrero-2004
Ubicación: Madrid
Mensajes: 65
Antigüedad: 13 años, 10 meses
Puntos: 0
Problemas con los enlaces.

He hecho una cabecera con un pequeño div a la izquierda, que hace de enlace con imagen que cambia. Me he dado cuenta de que al pulsarlo desaparece y además ¡para siempre! Recargo y nada, vuelvo a subir la plantilla y nada… Pensé que era cuestión del orden en que definí los enlaces. El orden original que puse es:

link
visited
hover
active

Por si estaba equivocado cambié a

link
visited
active
hover

que es como está ahora.

La dirección es http://paspespuyas.com/comunidad/index.php/b y el código que está ahora mismo es:
Código:
#header { 
	height: 130px;
 	background: #fff url(images/fondoheader.png);
	padding: 30px 10px 5px 25px;
	border-bottom : 1px solid #aaa;
}
	#paspesbanner{
float: left;
border: 0px;

margin-bottom: 10px;
margin-left: 1px;

}
div#paspesbanner ul{
list-style-type: none;
}
div#paspesbanner ul li{
margin:0px;
}

 #paspesbanner ul li a:link{
 text-decoration: none;
 display: block;
 background-image: url(images/paspesbanner.jpg);
background-repeat: no-repeat;
 border: 0;
width:200px;
height:25px;
 
 }
  #paspesbanner ul li a:visited{
   text-decoration: none;
 background-image: url(/images/paspesbanner2.jpg);
background-repeat: no-repeat;
 border: 0px;
width:200px;
height:25px;
  }
  #paspesbanner ul li a:active{
   text-decoration: none;
 background-image: url(images/paspesbanner2.jpg);
background-repeat: no-repeat;
 border: 0px;
width:200px;
height:25px;
 }
 #paspesbanner ul li a:hover{
 text-decoration: none;
 background-image: url(images/paspesbanner2.jpg);
background-repeat: no-repeat;
 border: 0px;
width:200px;
height:25px;
}
Luego en el html

anticipado.
Código:
<div id="header">
<img src="http://www.delanova.net/b2/skins/custom/img/maste.jpg" align="right" margin-bottom:1px/>
<div id="paspesbanner">
<ul>
<li>
<a href="http://paspespuyas.com/"></a>
</i>
</ul>
</div>
</div>

A ver si ven algo en ese código y gracias por
  #2 (permalink)  
Antiguo 12/10/2004, 09:51
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 10 meses
Puntos: 771
Hola eltransito.

Así por encima, veo que en el estilo para active tienes una barra de más. Creo que por ahí puede venir el problema, de hecho si limpias el caché del navegador y recargas la página, la imágen vuelve a aparecer:

background-image: url(/images/paspesbanner2.jpg);

Saludos,
  #3 (permalink)  
Antiguo 12/10/2004, 16:04
 
Fecha de Ingreso: febrero-2004
Ubicación: Madrid
Mensajes: 65
Antigüedad: 13 años, 10 meses
Puntos: 0
Gracias por la respuesta pero he probado y parece que no está ahí el falloc solamente
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:00.