Foros del Web » Creando para Internet » CSS »

Problemas con Fondo en Internet Explorer

Estas en el tema de Problemas con Fondo en Internet Explorer en el foro de CSS en Foros del Web. Hola, Tengo una tabla en la cual, en una de sus celdas, he colocado vía css una imagen de fondo para que se muestre. El ...
  #1 (permalink)  
Antiguo 26/10/2007, 14:42
Avatar de daniel.manchego  
Fecha de Ingreso: mayo-2006
Mensajes: 111
Antigüedad: 11 años, 7 meses
Puntos: 0
Problemas con Fondo en Internet Explorer

Hola,

Tengo una tabla en la cual, en una de sus celdas, he colocado vía css una imagen de fondo para que se muestre. El código es:

.contenido
{
background: transparent url(../images/fondo.jpg) no-repeat center center;
background-attachment: fixed;
position:relative;
}

entonces, en Firefox funciona muy bien, pero en internet explorer no, y en la última versión,funciona después de un buen tiempo de haber aparecido la página. Hay alguna forma de corregir ???

Saludos.
__________________
Daniel Manchego
http://dmanchego.blogspot.com
  #2 (permalink)  
Antiguo 26/10/2007, 14:55
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Re: Problemas con Fondo en Internet Explorer

probá con esto:

.contenido
{
background-image: url(../images/fondo.jpg) no-repeat center;
background-attachment: fixed;
}

  #3 (permalink)  
Antiguo 26/10/2007, 14:56
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Re: Problemas con Fondo en Internet Explorer

Hola daniel.manchego

El código parece correcto. ¿Puedes poner un enlace para echarle un ojo?

Saludos,
  #4 (permalink)  
Antiguo 26/10/2007, 16:04
Avatar de daniel.manchego  
Fecha de Ingreso: mayo-2006
Mensajes: 111
Antigüedad: 11 años, 7 meses
Puntos: 0
Re: Problemas con Fondo en Internet Explorer

Hola amigos,

Bueno no funcionó con lo que me dijo DragonX pero ya lo solucioné adicionando un div contenedor dentro de la celda, y ahí ya no me da problemas.

Parece ser que cuando le pones un background de fondo a una celda en IE7 se pone como loco, pero en el buen Firefox sí aparecía como uno quiere.

Muchas gracias!
__________________
Daniel Manchego
http://dmanchego.blogspot.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:43.