Foros del Web » Creando para Internet » CSS »

Problemas con a:hover en Crome y Safari

Estas en el tema de Problemas con a:hover en Crome y Safari en el foro de CSS en Foros del Web. Saludos... Tengo problema con a:hover tanto en Crome como en Safari. No me funciona el a:hover en ambos mientras que en IE, FF y Opera ...
  #1 (permalink)  
Antiguo 31/01/2011, 21:01
 
Fecha de Ingreso: enero-2011
Ubicación: Cali
Mensajes: 73
Antigüedad: 6 años, 10 meses
Puntos: 2
Problemas con a:hover en Crome y Safari

Saludos...

Tengo problema con a:hover tanto en Crome como en Safari. No me funciona el a:hover en ambos mientras que en IE, FF y Opera sí me funciona.

Pasa que tengo un sencillo menu en una página. El color de los enlaces son #000000. El color del a:hover es #0000cc.

Ojalá alguno de ustedes me pueda ayudar.

El códgio es el siguiente:

Código HTML:
Ver original
  1. <div id="menu">
  2.                     <ul>
  3.                    
  4.                     <li><a style="border: none; cursor: pointer;">INICIO</a></li>
  5.                     <li><a style="cursor: pointer;" onmouseover="muestra('menumcv');" onmouseout="oculta('menumcv');">
  6.                     MARIANO CIVICO</a></li>
  7.                     <li><a onmouseover="muestra('menumusica');" onmouseout="oculta('menumusica');" style="cursor: pointer;">MULTIMEDIA</a></li>
  8.                     <li><a href="http://musicamarianocivico.blogspot.com/2010/12/palante-otra-vez.html" target="_blanck">MY BLOG</a></li>
  9.                     <li><a href="http://www.youtube.com/user/MarianoCivicoMusica" target="_blanck">YOU TUBE</a></li>
  10.                     <li><a onclick="document.getElementById('contenedor_formulario').style.display = 'block'" style="cursor: pointer;">CONTRATACIÓN</a></li>
  11.                    
  12.                     </ul>
  13.          </div>

Código CSS:
Ver original
  1. #menu
  2. {
  3. float: left;
  4. margin: 0;
  5. width: 680;
  6. height: auto;
  7. margin-top: 13;
  8. }
  9.  
  10. #menu ul li
  11. {
  12. display: inline;
  13. }
  14.  
  15. #menu ul li a
  16. {
  17. text-decoration: none;
  18. font-family: arial black;
  19. font-size: 13;
  20. color: #000000;
  21. border-left: 1px solid #000000;
  22. padding: 0 7;
  23. }
  24.  
  25. #menu ul li a:hover
  26. {
  27. color: #0000cc;
  28. }
  #2 (permalink)  
Antiguo 01/02/2011, 14:56
 
Fecha de Ingreso: enero-2011
Ubicación: Cali
Mensajes: 73
Antigüedad: 6 años, 10 meses
Puntos: 2
Información Respuesta: Problemas con a:hover en Crome y Safari

Saludos...


Ya resolví el problema del a:hover en Safari y Crome respecto al problema planteado.

Lo que pasa es que cuando en estos navegadores se tiene un enlace y no se añade el atributo href="url..." o href="#", aunque en la hoja de estilo tengas especificado un a:hover, el mismo no funcionará hasta que añadas los atributos.

Que tengan buen día.

Etiquetas: safari, chrome
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:15.