Foros del Web » Creando para Internet » CSS »

Problemas con :hover en IE6

Estas en el tema de Problemas con :hover en IE6 en el foro de CSS en Foros del Web. Que tal gente!!. Tengo lo siguiente. En una hoja de estilo tengo es codigo. Código: .tabla_fila_impar{ background-color: #FFF; text-align: center; } .tabla_fila_impar:hover{ background-color: #E0E4E7; text-align: ...
  #1 (permalink)  
Antiguo 02/10/2008, 11:20
Avatar de diegoy2k  
Fecha de Ingreso: julio-2006
Ubicación: Algun Lugar
Mensajes: 68
Antigüedad: 11 años, 5 meses
Puntos: 0
Problemas con :hover en IE6

Que tal gente!!.

Tengo lo siguiente.

En una hoja de estilo tengo es codigo.
Código:
.tabla_fila_impar{
		background-color:	#FFF;
		text-align:		center;
}
.tabla_fila_impar:hover{
		background-color:	#E0E4E7;
		text-align:		center;
}
.tabla_fila_par{
		background-color:	#E5EFF9;
		text-align:		center;
}
.tabla_fila_par:hover{	
		background-color:	#E0E4E7;
		text-align:		center;
}
Despues de tomar valores desde un repositorio, genero la pagina en la que pongo este codigo

Código HTML:
<tr class="tabla_fila_impar">
  <td class="tabla_body_col"></td>	
  <td class="tabla_body_col"></td>
  <td class="tabla_body_col"></td>
</tr>
<tr class="tabla_fila_par">
  <td class="tabla_body_col"></td>	
  <td class="tabla_body_col"></td>
  <td class="tabla_body_col"></td>
</tr>
<tr class="tabla_fila_impar">
  <td class="tabla_body_col"></td>	
  <td class="tabla_body_col"></td>
  <td class="tabla_body_col"></td>
</tr> 
La cuestion es que en FireFox, IE 7, Opera, Safari, se ve bien, pero en IE6 so ve bien, pero no anda el efecto del :hover!.
Cual puede ser el problema?

Saludos!!!!!!!.
  #2 (permalink)  
Antiguo 02/10/2008, 11:24
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Respuesta: Problemas con :hover en IE6

Hola diegoy2k

El problema es que en la versión 6 y anteriores hover sólo funciona con enlaces.

Saludos,
  #3 (permalink)  
Antiguo 02/10/2008, 12:12
Avatar de diegoy2k  
Fecha de Ingreso: julio-2006
Ubicación: Algun Lugar
Mensajes: 68
Antigüedad: 11 años, 5 meses
Puntos: 0
Respuesta: Problemas con :hover en IE6

Como va gente!!, de nuevo yo!

Antes que nada gracias, JavierB.

Ya he encontrado la solucion.
Al parece IE6 no soporta alguno estandares!!!, existe una libreria que hace que IE6
soporte dichos estandares.
La libreria y documentacion por aca:
http://dean.edwards.name/IE7/

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:50.