Foros del Web » Creando para Internet » CSS »

Problemas con los navegadores

Estas en el tema de Problemas con los navegadores en el foro de CSS en Foros del Web. Hola a todos, tengo un problemilla con el codigo que depende del navegador que use y me preguntaba si alguien me podria ayudar. En la ...
  #1 (permalink)  
Antiguo 10/01/2006, 09:47
 
Fecha de Ingreso: octubre-2005
Mensajes: 28
Antigüedad: 12 años, 1 mes
Puntos: 0
Problemas con los navegadores

Hola a todos, tengo un problemilla con el codigo que depende del navegador que use y me preguntaba si alguien me podria ayudar.

En la pagina pretendo poner un menu de enlaces separado por pipes, y encontre un codigo que crei que me serviria es el siguiente:

CSS:

#navcontainer{
margin-right:0px;
margin-top:-50px;

}

*html #navcontainer{
margin-top:-90px;
}

#navlist {

list-style:none;
margin:0;
padding:0;
float:right;
}

#navlist li {

display:inline;
margin:0;
padding:0;
font-family:verdana;
font-size:10px;
font-weight: bold;
}

#navlist li:before {content: "|";}
#navlist li:first-child:before {content: "";}


*html #navlist li {
border-left:1px solid black;
padding:0 0.4em 0 0.4em;
margin:0 0.4em 0 -0.4em;
font-family:verdana;
font-size:10px;
font-weight: bold;
}



HTML:
<div id="navcontainer">
<ul id="navlist">
<li><a href="#">ca</a></li>
<li><a href="#">en</a></li>
<li><a href="#">es</a></li>
<li><a href="#">eu</a></li>
<li><a href="#">gl</a></li>
</ul>
</div>


Con Mozilla va estupendo, pero con el internet explorer no funcionan los enlaces.

Alguien me podria decir como puedo conseguirlo?

Muchisimas gracias, un saludo
  #2 (permalink)  
Antiguo 10/01/2006, 10:07
Avatar de PatomaS
Colaborador
 
Fecha de Ingreso: marzo-2004
Ubicación: En alguna otra parte
Mensajes: 4.656
Antigüedad: 13 años, 9 meses
Puntos: 63
Hola

Puede que con las prisas haya hecho algo mal porque tomé tu código y no pude ver nada en mis navegadores.

Si quito los dos primeros elementos de los estilos si veo el menú en la parte superior derecha.

¿tú poblema es que los vínculos no funcionan?

Igualmente, cuando pude ver los enlaces, el código funcionó bien en ambos navegadores.

Revisa bien los códigos por lo quepueda pasar.

En cualquier caso, el comportamiento de explorer con after y before es más bien extraño, al principio era sencillamente inexistente, pero con el tiempo y ciertos parches han implementado parcialmente su aceptación, pero al parecer no demasiado bien.

Bueno, lamenos no serte de más ayuda.

Felicidad
__________________
¡ hey, hou, hou, hey !
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:01.