Foros del Web » Creando para Internet » CSS »

problemas con z-index y flash en firefox

Estas en el tema de problemas con z-index y flash en firefox en el foro de CSS en Foros del Web. Hola a todos! El problema es que tendo un div con flash y otro div con una imagen que parcialmente quiero que se me monte ...
  #1 (permalink)  
Antiguo 03/06/2008, 04:05
 
Fecha de Ingreso: septiembre-2007
Mensajes: 23
Antigüedad: 10 años, 3 meses
Puntos: 0
problemas con z-index y flash en firefox

Hola a todos!
El problema es que tendo un div con flash y otro div con una imagen que parcialmente quiero que se me monte sobre el flash....
En en css tengo los z-index bien puestos, y en ie se me ve correctamente pero en Firefox no me hace ni caso....he estado buscando mensajes que hablen del tema y en todos dicen que el firefox no reconoce los z-index....
No hay ningun hack para solucionar éste problema????
Socorro!!!!!!!
  #2 (permalink)  
Antiguo 03/06/2008, 04:56
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: problemas con z-index y flash en firefox

Pues mira, ni es cierto que firefox no reconozca los z-index ni necesitas ningún hack para eso. Es un parámetro de la película de flash que es algo así como vmode="transparent" o algo parecido, pero no me hagas caso y busca en el foro de flash o en el de html por flash+transparent o así.

No tengo ni idea de flash, pero ese mismo problema lo he leido por aquí muchas veces.

EDITO: mira, creo que lo ponen así:

<param name="wmode" value="transparent">

Mikel.
  #3 (permalink)  
Antiguo 03/06/2008, 05:14
 
Fecha de Ingreso: septiembre-2007
Mensajes: 23
Antigüedad: 10 años, 3 meses
Puntos: 0
Respuesta: problemas con z-index y flash en firefox

eso de modo transparente ya lo tengo puesto....es cierto que se ha trata el mismo tema muchas veces...pero solo me funciona en ie
Alguien sabe algo....
  #4 (permalink)  
Antiguo 03/06/2008, 05:20
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: problemas con z-index y flash en firefox

¿El div que quieres poner encima tiene algún tipo de posicionamiento, relativo o absoluto?

Si es así y no funciona, pon un enlace para poder verlo o el código que usas.

Mikel.
  #5 (permalink)  
Antiguo 03/06/2008, 05:26
 
Fecha de Ingreso: septiembre-2007
Mensajes: 23
Antigüedad: 10 años, 3 meses
Puntos: 0
Respuesta: problemas con z-index y flash en firefox

ya lo he solucionado....
tenía puesto
<param name="wmode" value="transparent">
lo que no me había dado cuenta es que tenía que poner
<param name="wmode" value="transparent">
<embed wmode="transparent" src=".....swf....................

bueno a todos gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:43.