Foros del Web » Creando para Internet » CSS »

Problemas programando para navegadores

Estas en el tema de Problemas programando para navegadores en el foro de CSS en Foros del Web. Buenas tardes !!! Necesito programar una página y que funcione bien tanto para Iexplore6, como para mozilla, como para iexplore(versión Mac). Esta página usa capas ...
  #1 (permalink)  
Antiguo 19/01/2005, 06:57
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Problemas programando para navegadores

Buenas tardes !!!

Necesito programar una página y que funcione bien tanto para Iexplore6, como para mozilla, como para iexplore(versión Mac).

Esta página usa capas y demás, si entran con el explorer:
http://www.guiaoca.com/ocarecomienda.php

Veran que se ve bien, pero si se entra con el mozilla o con el iExplore para Mac, se ve hecha un desastre.

¿Pueden decirme páginas (A ser posible en castellano) donde me indiquen como programar para los tres navegadores?

Muchas gracias.
__________________
Charlie.
  #2 (permalink)  
Antiguo 19/01/2005, 11:14
Avatar de Durgeoble  
Fecha de Ingreso: marzo-2003
Mensajes: 462
Antigüedad: 14 años, 8 meses
Puntos: 2
Con ie es como se ve mal

El resto te lo muestran como deben
http://www.webexperto.com/tutoriales/
http://www.sidar.org/recur/desdi/mcss/manual/indice.php
http://www.disenorama.com/articulos/...o_de_cajas.htm
http://www.tierradenomadas.com/tw003.phtml
http://www.desarrolloweb.com/articulos/429.php?manual=2
http://www.w3schools.com/css/default.asp
http://www.htmlpoint.com/
http://www.juque.cl/weblog/
Te habia preparado un comentario sobre algunos fallos graves en la pagina pero por sobrecarga en los foros se me ha borrado, pero deberias revisarla a fondo, los <form> y los <font> estan mal colocados, realmente mal colocados, no se pueden meter entre un <tr> y un <td>
Te falta el doctype de la pagina mira esto Lista de doctypes Lista oficial

Los scrips deberias ponerlos todos en la cabecera entre las etiquetas <head> </head>

Si te hace falta algo mas avisa
__________________
Todas mis respuestas funcionaran correctamente en aquellos navegadores que respeten los estandares.

Última edición por Durgeoble; 19/01/2005 a las 11:15
  #3 (permalink)  
Antiguo 19/01/2005, 11:30
Avatar de kemie  
Fecha de Ingreso: junio-2003
Ubicación: estocolmo<-->mexico
Mensajes: 1.627
Antigüedad: 14 años, 5 meses
Puntos: 1
el primer , como dice Durgeoble es corregir tus errores. Mira los errores de html:
http://validator.w3.org/check?verbos...recomienda.php

y de css:
http://jigsaw.w3.org/css-validator/v...recomienda.php
__________________
::::::::::::::::::::::::::::: WebHostNinja | diseñorama.com::::::::::::::::::::::::::::::
  #4 (permalink)  
Antiguo 20/01/2005, 04:29
 
Fecha de Ingreso: junio-2003
Ubicación: Asturias
Mensajes: 2.427
Antigüedad: 14 años, 6 meses
Puntos: 7
Muchas gracias a los dos por la ayuda ofrecida.

Es muy de tener en cuenta, nuevamente, muchas gracias por molestaros.

Saludos Cordiales.
__________________
Charlie.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:04.