Foros del Web » Creando para Internet » CSS »

Problemón de css en explorer

Estas en el tema de Problemón de css en explorer en el foro de CSS en Foros del Web. hola, esta es la 1º web que he intentado hacer entera con css y al darla por acabada he comprobado que el index en explorer ...
  #1 (permalink)  
Antiguo 08/07/2009, 05:02
 
Fecha de Ingreso: marzo-2004
Ubicación: La Rioja (España)
Mensajes: 111
Antigüedad: 13 años, 9 meses
Puntos: 1
Problemón de css en explorer

hola, esta es la 1º web que he intentado hacer entera con css y al darla por acabada he comprobado que el index en explorer se ve desastrosamente :

http://www.g-or-g.com/problemaie/

En firefox, safari y netscape la veo bien, pero en explorer se me mueve todo a la derecha y los botones de imagen me desaparecen mostrando los enlaces de texto. ¿Alquien sabe cómo lo puedo solucionar? Esque para solucionarlo sólo se me ocurre ponerlo todo como imagen pero me parece muy chapucero

Última edición por G-or-G; 08/07/2009 a las 06:00
  #2 (permalink)  
Antiguo 08/07/2009, 05:05
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: Problemón de css en explorer

Y por que no pones mejor la url de la web?
__________________
No diseñes usando tablas.
  #3 (permalink)  
Antiguo 08/07/2009, 06:08
 
Fecha de Ingreso: marzo-2004
Ubicación: La Rioja (España)
Mensajes: 111
Antigüedad: 13 años, 9 meses
Puntos: 1
Respuesta: Problemón de css en explorer

editado el 1º post con la url
  #4 (permalink)  
Antiguo 08/07/2009, 06:37
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: Problemón de css en explorer

Te recomiendo que uses menús con CSS, como dicen en cristalab, por que según veo abres ul, luego div y unas cosas un tanto raras.

Y no uses position absolute.
__________________
No diseñes usando tablas.
  #5 (permalink)  
Antiguo 08/07/2009, 07:14
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Problemón de css en explorer

Creo que te sobra el cierre de este div:
Cita:
<div id="supportingPortada"></div>
<div id="linkListportada">
prueba a eliminarlo a ver qué pasa (el cierre que te pongo en negrita)
Otra cosilla (para evitar consulta más tarde si vas a validar tu código):
Todo lo que haya dentro de una lista (ul) debe estar contenido dentro de su correspondiente <li>.
Esto no puedes ponerlo así:
Cita:
<ul>
<div id="titleaei"></div>
<li>...
Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #6 (permalink)  
Antiguo 08/07/2009, 15:59
 
Fecha de Ingreso: noviembre-2004
Ubicación: Córdoba-Argentina
Mensajes: 15
Antigüedad: 13 años, 1 mes
Puntos: 0
Respuesta: Problemón de css en explorer

En #linkListportada utiliza float:left y en #supportingPortada, float:right siempre son position:relative...deberia funcionar....

Última edición por horacioliva; 08/07/2009 a las 16:00 Razón: missing info
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:40.