Foros del Web » Creando para Internet » CSS »

Propiedades mal interpretadas por ie9

Estas en el tema de Propiedades mal interpretadas por ie9 en el foro de CSS en Foros del Web. que tal quiero comentarles mi situacion a ver si alguien conoce posible solucion Estoy diseñando una pagina de forma local con hoja de estilos, se ...
  #1 (permalink)  
Antiguo 17/08/2012, 08:49
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 6 meses
Puntos: 23
Propiedades mal interpretadas por ie9

que tal

quiero comentarles mi situacion a ver si alguien conoce posible solucion

Estoy diseñando una pagina de forma local con hoja de estilos, se ve de la siguiente forma (en ie9, chrome y firefox):

Subido en SubeImagenes.com
http://www.subeimagenes.com/img/bien-365787.html

Bueno, pues se paso al servidor donde se va a alojar y sucedió esto (solo en ie9, en chrome y firefox sigue viéndose como la primer imagen):

Subido en SubeImagenes.com
http://www.subeimagenes.com/img/mal-365789.html

parece ser que todo lo que tengo con posicion:absolute, top, left, display:inline-block, no lo esta reconociendo correctamente.

Regrese a ver mi proyecto locamente y se ve bien, después (en forma local) le di clic a la opción vista de compatibilidad (ie9) y efectivamente se ve como en la segunda imagen. Parece que ie8 sale bien aunque no lo he probado

en mi pagina tengo:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="es">

probe con strict pero no soluciono el caso

Alguien sabria que puede estar causando este problema en ie9 y parece que en ie7

en chrome y firefox (y ie8 creo) esta tomando de forma correcta los estilos
  #2 (permalink)  
Antiguo 17/08/2012, 17:51
 
Fecha de Ingreso: agosto-2012
Mensajes: 39
Antigüedad: 7 años, 3 meses
Puntos: 5
Respuesta: Propiedades mal interpretadas por ie9

Los encabezados de mis sitios comienzan siempre con:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

prueba haciendo el ajuste, yo no he tenido problemas con iexplorer, pero no está demás que hagas la prueba.

adicionalmente si no funciona, prueba habilitando la compatibilidad de navegación y nos comentas tus resultados

Saludos.
  #3 (permalink)  
Antiguo 18/08/2012, 09:32
 
Fecha de Ingreso: agosto-2012
Mensajes: 37
Antigüedad: 7 años, 3 meses
Puntos: 12
Respuesta: Propiedades mal interpretadas por ie9

Si has maquetado usando posiciones absolutas tengo que decirte que es muy poco recomendable, pon las cosas estáticas y añádele floats para maquetar

De todas formas lo que te pasa es raro = /
__________________
Pedro Gutiérrez, diseñador y desarrollador web freelance en Toledo,
busco soluciones a los proyectos web que me propongas.

Visita mi web-blog: http://xitrus.es
  #4 (permalink)  
Antiguo 20/08/2012, 09:04
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 6 meses
Puntos: 23
Respuesta: Propiedades mal interpretadas por ie9

Gracias por sus respuestas, si es muy raro, nunca me había pasado :S

Bueno wlinker probe con tus encabezados, pero al ponerlos me descuadrada todo en modo normal y en modo compatibilidad, me alinea toda la pagina a la izquierda y lo que tengo con float display inline block no me lo pone en la misma linea.

Que tal pedrogp9693 te comento que si tengo varias cosas con floats pero poner otras con absolute fue inevitable :( y cambiarlas a esta altura sería casi casi volver a hacer el sitio y ya no creo tener tiempo para eso.

Por otro lado encontre una posible solucion, leyendo y probando identifique que el problema a tratar es el de la vista de compatibilidad de ie, ya que en chorme y firefox funcina bien.

Parace que al pasar al servidor y abrir la pagina desde ahí es como si "por default" tuviera la vista de compatibilidad seleccionada y sin posibilidad de desabilitarla.

Encontre estas meta que me ayudan a solucionar el problema en ie9 pero en ie8 persiste :/

<meta http-equiv="X-UA-Compatible" content="IE=9"/>
<meta http-equiv="X-UA-Compatible" content="IE=8"/>
<meta http-equiv="X-UA-Compatible" content="IE=7"/>

Etiquetas: chrome, estilos, html, ie9, imagenes, propiedades
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:24.