Foros del Web » Creando para Internet » CSS »

Que no se active el a:visited en un link

Estas en el tema de Que no se active el a:visited en un link en el foro de CSS en Foros del Web. Saludos a todos. En una web tengo los links configurados con css en todos sus estados: link, hover, visited y active. Pues bien, un vez ...
  #1 (permalink)  
Antiguo 14/11/2003, 11:06
Avatar de damargon  
Fecha de Ingreso: junio-2003
Ubicación: Madrid
Mensajes: 386
Antigüedad: 14 años, 5 meses
Puntos: 3
Que no se active el a:visited en un link

Saludos a todos.

En una web tengo los links configurados con css en todos sus estados: link, hover, visited y active.

Pues bien, un vez he hecho click en cualquiera de los enlaces estos se quedan con las características del "visited" y si vuelves a hacer onmouseover sobre él pierde el "hover", ya no hace el cambio de color.

He probado a no configurar "visited" pero entonces me coge el color violeta que viene por defecto en el explorer.

¿Qué hay que hacer para que siempre funcione el "hover" se haya o no visitado ese link?

Espero haberme explicado bien.

Un saludo.
  #2 (permalink)  
Antiguo 14/11/2003, 11:35
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Hola, damargon.

El orden en que debes poner los estilos es:

a:link
a:visited
a:hover

Espero que con esto te funcione. Saludos,
  #3 (permalink)  
Antiguo 14/11/2003, 11:47
Avatar de damargon  
Fecha de Ingreso: junio-2003
Ubicación: Madrid
Mensajes: 386
Antigüedad: 14 años, 5 meses
Puntos: 3
Gracias Javier!

Funciona perfectamente.

Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:34.