Foros del Web » Creando para Internet » CSS »

Rollover con CSS no funciona en Firefox

Estas en el tema de Rollover con CSS no funciona en Firefox en el foro de CSS en Foros del Web. Hola, Mi problema se parece al tópico comentado más abajo, pero no es exactamente el mismo: Quiero usar una imagen transparente como link en un ...
  #1 (permalink)  
Antiguo 27/09/2005, 04:06
Avatar de hermetika  
Fecha de Ingreso: septiembre-2003
Ubicación: Barcelona
Mensajes: 43
Antigüedad: 14 años, 2 meses
Puntos: 0
Rollover con CSS no funciona en Firefox

Hola,

Mi problema se parece al tópico comentado más abajo, pero no es exactamente el mismo:

Quiero usar una imagen transparente como link en un menu de lista horizontal con rollover mediante CSS:

Este es el código:
Código:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Menu Rollover</title>
<style type="text/css">
div.container{
	width:250px;
	height:31px;
	border:1px solid #ccc;
	}
ul.lista{
	list-style-type: none;
	margin:0;
	padding:0;
	}
li.lista{
	display:inline; 
	}
a.uno:link, a.uno:visited{
	background-image:url(link1.gif);
	background-position:0 0;
	}
a.uno:hover, a.uno:active{
	background-image:url(link1.gif);
	background-position:0 -31px;
	}
a.dos:link, a.dos:visited{
	background-image:url(link2.gif);
	background-position:0 0;
	}
a.dos:hover, a.dos:active{
	background-image:url(link2.gif);
	background-position:0 -31px;
	}
</style>
</head>
<body>
<div class="container">
<ul class="lista">
<li class="lista"><a href="#" class="uno"><img src="transparente.gif" width="100" border="0"></a></li>
<li class="lista"><a href="#" class="dos"><img src="transparente.gif" width="100" border="0"></a></li>
</ul>
</div>
</body>
</html>
La cuestión es que funciona bien en IE, pero en Firefox, el background me aparece más abajo, como a media altura, y si lo subo mediante margin-top negativo, se recorta. Alguna sugerencia ???

Gracias a todos y todas !!!
__________________
Puedes llegar a cualquier parte, siempre que andes lo suficiente. (Lewis Carroll)
  #2 (permalink)  
Antiguo 27/09/2005, 04:09
Avatar de caricatos
Moderador
 
Fecha de Ingreso: abril-2002
Ubicación: Torremolinos (Málaga)
Mensajes: 19.547
Antigüedad: 15 años, 8 meses
Puntos: 1262
Hola:

Creo que tendrías que poner position: absolute en el contenedor...

Saludos
__________________
Por favor:
No hagan preguntas de temas de foros en mensajes privados... no las respondo
  #3 (permalink)  
Antiguo 27/09/2005, 04:20
Avatar de hermetika  
Fecha de Ingreso: septiembre-2003
Ubicación: Barcelona
Mensajes: 43
Antigüedad: 14 años, 2 meses
Puntos: 0
Tampoco funciona

Gracias, caricatos, pero he probado position:absolute en el contenedor, y nada. Lo he probado en la lista, en los items de lista, en los enlaces.. incluso en el body, pero no sirve...

POdeis ver el ejemplo en http://www.inoquo.com/css/prueba_menu.htm
__________________
Puedes llegar a cualquier parte, siempre que andes lo suficiente. (Lewis Carroll)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:10.