Foros del Web » Creando para Internet » CSS »

text-decoration: no me funciona (!)

Estas en el tema de text-decoration: no me funciona (!) en el foro de CSS en Foros del Web. Amigos : quiero que en una 'nube de tags', cuando me pongo encima (hover) se subraye y sino permanezca sin subrayado. El problema es que ...
  #1 (permalink)  
Antiguo 01/08/2009, 22:36
Avatar de Italico76  
Fecha de Ingreso: abril-2007
Mensajes: 3.303
Antigüedad: 10 años, 8 meses
Puntos: 290
Exclamación text-decoration: no me funciona (!)

Amigos: quiero que en una 'nube de tags', cuando me pongo encima (hover) se subraye y sino permanezca sin subrayado.

El problema es que me sale SIN subrayado SIEMPRE e ignora todo lo que pongo:

#clouds2{ /* la nube de abajo -> con queries */
margin-bottom: 25px;
margin-left:100px;
width:560px;
padding-top:1200px;
text-decoration: none;
}

#clouds2 a:hover{
color:red;
text-decoration: underline;
}

de hecho... ni siquiera cambia de color (a red) .. no hace NADA...



valoro cualquier ayuda
__________________
Salu2!
  #2 (permalink)  
Antiguo 01/08/2009, 22:50
Avatar de Italico76  
Fecha de Ingreso: abril-2007
Mensajes: 3.303
Antigüedad: 10 años, 8 meses
Puntos: 290
Respuesta: text-decoration: no me funciona (!)

Bueno........solucioné asi:

#clouds2 a:link {
text-decoration: none;
}
#clouds2 a:hover {
text-decoration: underline !important;
color:#000066;
}
__________________
Salu2!
  #3 (permalink)  
Antiguo 02/08/2009, 09:03
Avatar de alexk
Colaborador
 
Fecha de Ingreso: julio-2009
Ubicación: De vuelta al trono
Mensajes: 1.697
Antigüedad: 8 años, 5 meses
Puntos: 137
Respuesta: text-decoration: no me funciona (!)

no era necesario el "!important" y no te daba estilos ya que la ID no es de tu elemento "a" sino de un elemento contenedor nose un "Li" o un "div" nose donde lo tienes
Código css:
Ver original
  1. #clouds2 a{ /* la nube de abajo -> con queries */
  2. margin-bottom: 25px;
  3. margin-left:100px;
  4. width:560px;
  5. padding-top:1200px;
  6. text-decoration: none;
  7. }
  8.  
  9. #clouds2 a:hover{
  10. color:red;
  11. text-decoration: underline;
  12. }
solo le agregue un "a" y listo chao y suerte

"!important" no hay en ie6
  #4 (permalink)  
Antiguo 02/08/2009, 09:12
Avatar de Italico76  
Fecha de Ingreso: abril-2007
Mensajes: 3.303
Antigüedad: 10 años, 8 meses
Puntos: 290
Respuesta: text-decoration: no me funciona (!)

Gracias amigo :)

yo pensaba que si no ponia 'a' estaba incluyendo todos los atributos
__________________
Salu2!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:53.