Foros del Web » Creando para Internet » CSS »

A veces no carga la imagen para el hover del link , alguna solucion???

Estas en el tema de A veces no carga la imagen para el hover del link , alguna solucion??? en el foro de CSS en Foros del Web. Hola a todos, resulta que tengo un link el cual tiene una imagen de fondo, aparte tengo otra imagen con caracteristicas similares para que se ...
  #1 (permalink)  
Antiguo 08/10/2009, 22:30
Avatar de richicasas  
Fecha de Ingreso: abril-2007
Ubicación: Colombia
Mensajes: 692
Antigüedad: 10 años, 8 meses
Puntos: 13
Exclamación A veces no carga la imagen para el hover del link , alguna solucion???

Hola a todos, resulta que tengo un link el cual tiene una imagen de fondo, aparte tengo otra imagen con caracteristicas similares para que se muestre en el a:hover, pero hay veces quedicha imagen como que no carga , pongo el puntero del mouse en el link y se me queda en blanco y no sale la imagen, alguien me podria ayudar a solucionar esto???, muchas gracias.
__________________
Juguetes Sexuales
  #2 (permalink)  
Antiguo 08/10/2009, 23:00
Avatar de deirdre  
Fecha de Ingreso: mayo-2009
Mensajes: 690
Antigüedad: 8 años, 6 meses
Puntos: 44
Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Pero, ¿te funciona en máquina local?. ¿Sólo te produce error si está online?

Puedes poner tu código para intentar ayudarte?

Bye
  #3 (permalink)  
Antiguo 08/10/2009, 23:06
Avatar de richicasas  
Fecha de Ingreso: abril-2007
Ubicación: Colombia
Mensajes: 692
Antigüedad: 10 años, 8 meses
Puntos: 13
Pregunta Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Código PHP:
a,  a:link{
    
background:url(../images/imagen1.giftop no-repeat;
    
display:block;
    
height:197px;
    
text-align:center;
    
font-size:16px;
    
padding-top:10px;
    
color:#FFFFFF;
}

 
a:hover{
    
background:url(../images/imagen2.giftop no-repeat;
    
color:#0B8507;} 
__________________
Juguetes Sexuales
  #4 (permalink)  
Antiguo 08/10/2009, 23:08
Avatar de richicasas  
Fecha de Ingreso: abril-2007
Ubicación: Colombia
Mensajes: 692
Antigüedad: 10 años, 8 meses
Puntos: 13
Exclamación Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Funciona local bien, per en Internet hay veces no carga la imagen del hover, toca darle f5 para recargar la pagina.
PREGUNTA:

He visto en algunos proyectos que cuando manejan diferentes imagenes para el menu una para la opcion y otra para el hover , que las dos son una misma imagen y estan separadas, sera por eso?? porque yo las tengo separadas??
__________________
Juguetes Sexuales
  #5 (permalink)  
Antiguo 09/10/2009, 06:26
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Utilizan la técnica que se conoce como sprite. La ventaja es que el cambio es instantáneo, ya que es la misma imagen que ya la tiene cargada y sólo la tiene que "mover".

Sprites + css

Un saludo
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #6 (permalink)  
Antiguo 09/10/2009, 06:49
Avatar de deirdre  
Fecha de Ingreso: mayo-2009
Mensajes: 690
Antigüedad: 8 años, 6 meses
Puntos: 44
Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Hola richicasas

Tal como te dice kseso? esa técnica se denomina sprite, pero si ya tienes tus imágenes editadas y no quieres convertirlas a sprite puedes intentar forzar la descarga de todas las imágenes de tus hover, bien utilizando algún pequeño javascript de precarga de imágenes, o mejor aún, colocando las imágenes dentro de un div con display none al principio del código (justo después de <body>), tal que así:

Código HTML:
<body>
<div style="display: none">
<img alt="" src="ruta/imagen-hover-1.png" />
<img alt="" src="ruta/imagen-hover-2.png" />
<img alt="" src="ruta/imagen-hover-3.png" />
<img alt="" src="ruta/imagen-hover-4.png" />
<img alt="" src="ruta/imagen-hover-5.png" />
<img alt="" src="ruta/imagen-hover-6.png" />
etc
</div>
</body> 
sacando el estilo a la hoja de estilo.

Bye
  #7 (permalink)  
Antiguo 09/10/2009, 23:23
Avatar de richicasas  
Fecha de Ingreso: abril-2007
Ubicación: Colombia
Mensajes: 692
Antigüedad: 10 años, 8 meses
Puntos: 13
De acuerdo Respuesta: A veces no carga la imagen para el hover del link , alguna solucion???

Muchas gracias, mejor hice sprite y las uni en una sola para que carguen bien, gracias por la ayuda.
__________________
Juguetes Sexuales
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:00.