Foros del Web » Creando para Internet » CSS »

Vínculo que no se adapta al estilo que hay en la clase definida

Estas en el tema de Vínculo que no se adapta al estilo que hay en la clase definida en el foro de CSS en Foros del Web. Hola muy buenas. Estoy algo desquiciado. Quiero aplicarle un estilo a un vínculo, algo en principio muy simple de hacer. Pero resulta, por no sé ...
  #1 (permalink)  
Antiguo 22/09/2006, 17:08
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.462
Antigüedad: 15 años, 4 meses
Puntos: 2100
Vínculo que no se adapta al estilo que hay en la clase definida

Hola muy buenas.

Estoy algo desquiciado.
Quiero aplicarle un estilo a un vínculo, algo en principio muy simple de hacer. Pero resulta, por no sé que razón, que el vínculo no se queda como yo quiero.

Tengo algo así (después de mil cambios, intento y reaciendo, pues quedó esto ahora mismo):
Código:
.vinculoagenda a:link {font-size:13px;color:#397300;text-decoration:none;}
.vinculoagenda a:visited {font-size:13px;color:#397300;text-decoration:none;}
.vinculoagenda a:active {font-size:13px;color:#397300;text-decoration:none;}
.vinculoagenda a:hover {font-size:13px;color:#A2BD87;text-decoration:none;}
La página está colgada en lanzaroterock.com/x (el vínculo que hay en la agenda, aunque se ve de sobra).
Supongo que será alguna chorrada, pero estoy desentrenado en estos menesteres.

Gracias y un saludo.
  #2 (permalink)  
Antiguo 22/09/2006, 17:13
 
Fecha de Ingreso: diciembre-2003
Mensajes: 1.583
Antigüedad: 14 años
Puntos: 13
Está mal el orden, debe ser LINK, VISITED, HOVER y ACTIVE.
  #3 (permalink)  
Antiguo 22/09/2006, 17:17
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.462
Antigüedad: 15 años, 4 meses
Puntos: 2100
¿Debe de ir en un orden? He probado a cambiarlo, pero sigue igual. De todas formas, añado esta pregunta a la consulta, porque, tengo mas estilos para otros vínculos definidos, y están en "mal" orden.
  #4 (permalink)  
Antiguo 23/09/2006, 04:06
Avatar de pzin
Moderata 😈
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 10.462
Antigüedad: 15 años, 4 meses
Puntos: 2100
Bueno, de momento lo voy a dejar de la única manera que funciona. He dejado el estilo dentro del HTML, en el mismo enlace.
Si alguien supiera que pasaba antes, le agradecería que lo posteara.

Gracias y un saludo.
  #5 (permalink)  
Antiguo 24/09/2006, 15:13
Avatar de KnowDemon  
Fecha de Ingreso: julio-2004
Ubicación: Ciudad de México
Mensajes: 544
Antigüedad: 13 años, 5 meses
Puntos: 2
Hola,

Es probable que se deba a cuestiones de prioridad. Si hay estilos en conflicto, se aplicarán los más específicos. Por decir algo: un selector basado en "id" tiene prioridad sobre uno basado en "class", aún cuando el elemento sea descendiente y el "id" ó "class" no esten aplicados directamente a él, como en un selector contextual. Por ejemplo, con las siguientes reglas en el orden en que son presentadas:

Código:
#algo elemento{
color: red;
}

elemento.miclase{
color: blue;
}
Si las dos aplican para elemento, se aplicara el color rojo y no el azul (hasta donde yo puedo recordar). Tal vez la causa de tu problema vaya por ahí.
__________________
Mi pequeño espacio en la web: VisiónE
"El cosmos es todo lo que es, todo lo que fue, y todo lo que será alguna vez."
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:08.