Foros del Web » Creando para Internet » CSS »

Z-index

Estas en el tema de Z-index en el foro de CSS en Foros del Web. hola a todos, soy nueva en este foro y la razon por la que les escribo es por que necesito resolver un problema con los ...
  #1 (permalink)  
Antiguo 16/08/2007, 14:32
naf
 
Fecha de Ingreso: agosto-2007
Ubicación: Chile
Mensajes: 23
Antigüedad: 10 años, 4 meses
Puntos: 0
Z-index

hola a todos, soy nueva en este foro y la razon por la que les escribo es por que necesito resolver un problema con los z- index. Haber si alguien me puede orientar.

Hice una pagina web en donde necesito colocar una imagen debajo de un fondo de pie de pagina (ambas imagenes son png, por que tienen bordes transparentes).

codigo html

codigo imagen:
<div id="posicionador-foto-inicio"><img src="imagenes/foto-inicio.jpg" class="foto-inicio"/></div>

codigo- pie de pagina:

<div id="pie-de-pagina">
<p>texto</p>
<p>texto</p>
<p class="tex-piepagina" align="center"><a href="/">Inicio</a> | <a href="/contacto/">Cont&aacute;ctenos</a> | <a href="/sitios-amigos/">Sitios Amigos</a></p>

</div>


codigo css:

#pie-de-pagina{
background-image: url(/imagenes/benner2.png)!important;
background-image: none;
filter: progid:DXImageTransform.Microsoft.AlphaImageLoader (src='/imagenes/benner2.png', sizingMethod='scale');
background-repeat: no-repeat;
background-position: right bottom;
position: relative;
z-index: 100;
height: 33px;
margin: 0px;
padding: 0px;
}
img.foto-inicio{
position: absolute;
bottom: -32px;
z-index: 10;
left: 5px;
}
#posicionador-foto-inicio{
background-color: #99CC33;
height: 0px;
clear: both;
position: relative;
}
#posicion{
height: 45px;
background-image: url(../imagenes/bannerinf-bottom.png);
background-repeat: no-repeat;
}

La imagen tiene una clase absolute y el div que lo compone es relative.
El pie de pagina tiene posicion relative y tiene z- index, para quedar sobre la imagen de inicio.
El problema consiste en que los link que estan en el pie de pagina en ie no funcionan (el texto lo muestra, pero no se activan los link) , pero si funciona en firefox.


Espero que alguien me pueda ayudar... gracias.

Última edición por naf; 17/08/2007 a las 10:42
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:04.