Foros del Web » Administración de Sistemas » Apache »

[SOLUCIONADO] Imagenes no funcionan desde IP Pública (Exterior)

Estas en el tema de Imagenes no funcionan desde IP Pública (Exterior) en el foro de Apache en Foros del Web. Hola, estoy haciendo pruebas en localhost, y hasta ahora todo bien, el problema surge cuando quiero acceder a la web a través de la IP ...
  #1 (permalink)  
Antiguo 25/02/2015, 05:41
 
Fecha de Ingreso: junio-2011
Mensajes: 39
Antigüedad: 6 años, 11 meses
Puntos: 2
Imagenes no funcionan desde IP Pública (Exterior)

Hola, estoy haciendo pruebas en localhost, y hasta ahora todo bien, el problema surge cuando quiero acceder a la web a través de la IP pública, he cambiado la configuración de Wordpress, desde administración, ajustes generales, y en vez de poner "localhost"-->"ip_publica".

Solo me pasa con las rutas de las imagenes, el resto funciona perfectamente.

Pues bien tanto en localhost como en la red local(LAN) funciona perfectamente las imagenes, con rutas relativas, son imagenes que están guardadas en las carpetas de la plantilla y que a su vez se usan en páginas a través de Html.

Lo que no entiendo es por que en LAN funciona y en internet no.
¿Puede que tenga que añadir algo en el htaccess para que permita reconocerlo?, no creo que la solución sea cambiar todas las rutas.

Gracias
  #2 (permalink)  
Antiguo 25/02/2015, 06:39
Avatar de zanguanga
Moderadora
 
Fecha de Ingreso: julio-2009
Ubicación: España
Mensajes: 1.681
Antigüedad: 8 años, 10 meses
Puntos: 425
Respuesta: Imagenes no funcionan desde IP Pública (Exterior)

Hola, tu consulta no tiene nada que ver con WordPress, la muevo a otro foro donde espero puedan ayudarte.
__________________
Mi blog personal | Mi G+
  #3 (permalink)  
Antiguo 25/02/2015, 07:12
Avatar de chichote
Colaborador
 
Fecha de Ingreso: diciembre-2004
Ubicación: Santiago - Chile
Mensajes: 1.868
Antigüedad: 13 años, 5 meses
Puntos: 145
Respuesta: Imagenes no funcionan desde IP Pública (Exterior)

zanguanga, si el sitio está desarrollado en wordpress este caso si tiene que ver con wordpress, es un problema de configuración.

sylarlocke, Cuando instalas un sitio en localhost, las rutas quedan seteadas como localhost, y por ende cuando accedes desde una ip publica o dominio no veras las fotos, ya que cada usuario buscará las fotos en su propio localhost.

Para reconfigurar deberás acceder a "Ajustes -> Generales" y modificar los parametros "Dirección de WordPress (URL)" y "Dirección del sitio (URL)" con la dirección pública, ya sea un dominio o ip publica.

En caso de no funcionar, deberás modificar las rutas directamente en la base de datos. Lo que hago yo es que abro el sql con algun editor de texto y le pongo remplazar todo (para no estar uno por uno).

Saludos.
__________________
http://chicho.ninja yiaaaa
  #4 (permalink)  
Antiguo 26/02/2015, 02:05
 
Fecha de Ingreso: junio-2011
Mensajes: 39
Antigüedad: 6 años, 11 meses
Puntos: 2
Respuesta: Imagenes no funcionan desde IP Pública (Exterior)

Hola, en primer lugar gracias por vuestra ayuda.

La consulta iba referida a Wordpress, quizás debería haberlo aclarado en el mensaje.

Chicote hice exactamente lo que comentas, de hecho cuando cambias los parámetros en el Back-end automáticamente se cambia en la BD, yo utilizo un gestor de Mysql, pero por lo visto el fallo venía derivado al acceso a la imagenes, estaba iendo a una ruta distinta, al final pude arreglarlo.

Gracias por la ayuda.

Tema solucionado.
  #5 (permalink)  
Antiguo 26/02/2015, 06:09
Avatar de chichote
Colaborador
 
Fecha de Ingreso: diciembre-2004
Ubicación: Santiago - Chile
Mensajes: 1.868
Antigüedad: 13 años, 5 meses
Puntos: 145
Respuesta: Imagenes no funcionan desde IP Pública (Exterior)

Cita:
Iniciado por sylarlocke Ver Mensaje
Hola, en primer lugar gracias por vuestra ayuda.

La consulta iba referida a Wordpress, quizás debería haberlo aclarado en el mensaje.

Chicote hice exactamente lo que comentas, de hecho cuando cambias los parámetros en el Back-end automáticamente se cambia en la BD, yo utilizo un gestor de Mysql, pero por lo visto el fallo venía derivado al acceso a la imagenes, estaba iendo a una ruta distinta, al final pude arreglarlo.

Gracias por la ayuda.

Tema solucionado.
Claro, wordpress almacena por cada imagen manipulada con su cargador de imagenes las rutas completas en la base de datos, para algunos es una virtud, para mi una estupidez de parte de los desarrolladores de wordpress, pero en fin, que bueno que lo solucionaste.

Saludos.
__________________
http://chicho.ninja yiaaaa

Etiquetas: funcionan, imagenes, ip, página, pública, wordpress
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:19.