Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » Mysql »

Cambiar el character a mysql en wamp server

Estas en el tema de Cambiar el character a mysql en wamp server en el foro de Mysql en Foros del Web. Hola a todos, llevo todo el día peleandome con mysql por que lo he instalado nuevo en windows 10 'wampServer'. Bueno la cuestión es que ...
  #1 (permalink)  
Antiguo 25/04/2016, 11:15
 
Fecha de Ingreso: marzo-2010
Mensajes: 30
Antigüedad: 11 años, 8 meses
Puntos: 0
Cambiar el character a mysql en wamp server

Hola a todos, llevo todo el día peleandome con mysql por que lo he instalado nuevo en windows 10 'wampServer'. Bueno la cuestión es que quiero cambiar los collations y character.

El archivo my.ini lo tengo asi:

[mysqld]
port = 3306
init_connect='SET collation_connection = utf8_general_ci'
init_connect='SET NAMES utf8'
character-set-server=utf8
collation-server=utf8_general_ci

[client]
default-character-set=utf8

Como veis ando buscando utf8 y utf8_general_ci. En Ubuntu lo he configurado en todas las versiones, con el tiempo va cambiando, y la verdad que como siempre mejor.

La cuestion es que obtengo diferente resultado segun hago (show variables like 'character%';show variables like 'collation%';) en la consola mysql o en phpMyAdmin.

Muestro en la consola mysql, lo que yo Esperaba:

mysql> show variables like 'coll%';
+----------------------+-----------------+
| Variable_name | Value |
+----------------------+-----------------+
| collation_connection | utf8_general_ci |
| collation_database | utf8_general_ci |
| collation_server | utf8_general_ci |
+----------------------+-----------------+

+--------------------------+------------------------------------------------+
| Variable_name | Value |
+--------------------------+------------------------------------------------+
| character_set_client | utf8 |
| character_set_connection | utf8 |
| character_set_database | utf8 |
| character_set_filesystem | binary |
| character_set_results | utf8 |
| character_set_server | utf8 |
| character_set_system | utf8 |
| character_sets_dir | C:\wamp64\bin\mysql\mysql5.7.9\share\charsets\ |
+--------------------------+------------------------------------------------+


Muestro phpMyAdmin:

show variables like 'character%'

Variable_name Value
character_set_client utf8mb4
character_set_connection utf8mb4
character_set_database utf8
character_set_filesystem binary
character_set_results utf8mb4

show variables like 'collation%'

Variable_name Value
collation_connection utf8mb4_general_ci
collation_database utf8_general_ci
collation_server utf8_general_ci
character_set_server utf8
character_set_system utf8
character_sets_dir
C:\wamp64\bin\mysql\mysql5.7.9\share\charsets\

Como ves diferentes respuestas, solo os puedo decir la versión mysql que gasto, que es 5.7.9. ¿Alguna idea que puedo estar haciendo mal?

Etiquetas: server, sql, wamp
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:21.