Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » Mysql »

Conector JDBC

Estas en el tema de Conector JDBC en el foro de Mysql en Foros del Web. Hola, Tengo que conectar la base de datos con Pentaho, mediante JDBC, para que pueda configurar el DataSource a mi dwh. Aquí tengo un problema ...
  #1 (permalink)  
Antiguo 12/05/2013, 13:52
mnsyole
Invitado
 
Mensajes: n/a
Puntos:
Pregunta Conector JDBC

Hola,

Tengo que conectar la base de datos con Pentaho, mediante JDBC, para que pueda configurar el DataSource a mi dwh.

Aquí tengo un problema de concepto, porque en las instrucciones de Pentaho me dice que tenga especial cuidado con la versión del MySQl instalada.

Tengo MySQL Server 6.0 y en clliente la v. 5.1.11, ¿Que versión de JDBC debo instalar?

En http://dev.mysql.com/downloads/connector/j/ me he bajado mysql-connector-java-5.1.25-bin.jar y no corresponde a ninguna de las versiones que tengo...

Antes tenía, mysql-connector-java-5.1.17.jar, pero tampoco coincide...

No sé antes de liarla y que no me funcione el tomcat (en /lib) tengo que dejar el JDBC, quiero asegurarme.

Alguien puede ayudarme?

Gracias de antemano
  #2 (permalink)  
Antiguo 12/05/2013, 19:18
Avatar de gnzsoloyo
Moderador criollo
 
Fecha de Ingreso: noviembre-2007
Ubicación: Actualmente en Buenos Aires (el enemigo ancestral)
Mensajes: 23.322
Antigüedad: 12 años, 2 meses
Puntos: 2654
Respuesta: Conector JDBC

Cita:
Tengo MySQL Server 6.0 y en clliente la v. 5.1.11, ¿Que versión de JDBC debo instalar?
Explícame una cosa: ¿Por qué usas la versión 6.0.x, que es una versión alpha fallida, que se descartó hace unos cuantos años (fue un fiasco), y terminó remplazada por la 5.1.x?
¿Leíste que es "alpha"?
¿Sabes qué es un software "alpha"?

Si te fijas en la página oficial, esa versión no está disponible para descargas como GA, por lo que no es una versión productiva (http://dev.mysql.com/downloads/mysql/).
Incluso cuando te fijas en las versiones de archivo, tampoco aparece: http://downloads.mysql.com/archives.php

En síntesis: No instales basura. Pon la misma versión en cliente que en servidor. ¿Cuál? La que quieras en tanto esté disponible como GA.
En cuanto al conector, la misma página donde lo descargas dice claramente cuáles son los requisitos. Lo mismo que cualquier conector para cualquier DBMS, siempre que te tomes el tiempo de leer la documentación oficial, con tranquilidad y paciencia (Sobre todo, con paciencia puedes encontrar la información que buscas: http://dev.mysql.com/doc/refman/5.6/...-versions.html).

En definitiva, es lo que hacemos todos...
__________________
¿A quién le enseñan sus aciertos?, si yo aprendo de mis errores constantemente...
"El problema es la interfase silla-teclado." (Gillermo Luque)

Última edición por gnzsoloyo; 12/05/2013 a las 19:27

Etiquetas: conector, jdbc, sql
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:22.