Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » Mysql »

problemas con myadmin de appserv

Estas en el tema de problemas con myadmin de appserv en el foro de Mysql en Foros del Web. Hola a todos de nuevo, tengo un problema, utilizando el myadmin del appser me sale este error al hacer una consulta, no se de que ...
  #1 (permalink)  
Antiguo 15/04/2007, 20:50
Avatar de isch  
Fecha de Ingreso: febrero-2007
Ubicación: En mi casa
Mensajes: 36
Antigüedad: 12 años, 9 meses
Puntos: 0
problemas con myadmin de appserv

Hola a todos de nuevo, tengo un problema, utilizando el myadmin del appser me sale este error al hacer una consulta, no se de que se trata, espero me puedan ayudar con el.

SALUDOS !!!
Cita:

consulta SQL:

SELECT UsuarioID, User_P, Password_P
FROM Usuarios
WHERE User_P = '$USER'
AND Password_P = '$PASS'
LIMIT 0 , 30
MySQL ha dicho:

#1267 - Illegal mix of collations (latin1_bin,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='
  #2 (permalink)  
Antiguo 16/04/2007, 07:58
Avatar de cala932  
Fecha de Ingreso: septiembre-2006
Ubicación: San Juan-Argentina
Mensajes: 902
Antigüedad: 13 años, 2 meses
Puntos: 9
Re: problemas con myadmin de appserv

hola isch, a la consulta la estas ejecutando directamente del phpmyadmin??
__________________
->Aprender es un proceso que incluye el error..
  #3 (permalink)  
Antiguo 17/04/2007, 08:32
Avatar de isch  
Fecha de Ingreso: febrero-2007
Ubicación: En mi casa
Mensajes: 36
Antigüedad: 12 años, 9 meses
Puntos: 0
Sonrisa Re: problemas con myadmin de appserv

si, asi es, de hecho la consulta es parte de un script en php, pero al ejecutarlo me manda un mensaje de error en los mysql_query y en el mysql_num_rows sobre los parametros, no comprendia por que pues los parametros de la funciones estan bien, luego ejecute la consulta directamente sobre el myadmin y me mandaba el error que puse aqui, no se si tenga algo que ver con el cotejamiento o que, por favor hechenme la mano, se los agardezco.

un dato mas, los parametros, el $user es un varchar y el $pass es un integer, si quito el User_P = '$USER' de la clausula WHERE la consulta se ejecuta sin problemas, entonces la bronca me imagino solo es con el $user, por que ??

SALUDOS !!!
  #4 (permalink)  
Antiguo 17/04/2007, 08:55
Avatar de cala932  
Fecha de Ingreso: septiembre-2006
Ubicación: San Juan-Argentina
Mensajes: 902
Antigüedad: 13 años, 2 meses
Puntos: 9
Re: problemas con myadmin de appserv

Código PHP:
//Por ejemplo:
$conn=mysql_connect("localhost","xxxx","xxxx");
mysql_select_db("tu BD",$conn);
$sql="SELECT UsuarioID, User_P, Password_P
FROM `Usuarios`
WHERE 1 AND  `User_P` = '$USER'
AND `Password_P` = '$PASS'"
;
$rs=mysql_query($sql,$conn);

if(
mysql_affected_rows())
{
while(
$row=mysql_fetch_array($rs))
{
echo 
$row["User_P"];
}
}
else
echo
"No se encontro"
Saludos
__________________
->Aprender es un proceso que incluye el error..
  #5 (permalink)  
Antiguo 17/04/2007, 12:48
Avatar de isch  
Fecha de Ingreso: febrero-2007
Ubicación: En mi casa
Mensajes: 36
Antigüedad: 12 años, 9 meses
Puntos: 0
Re: problemas con myadmin de appserv

gracias, la cuestion era la conexion, la forma en la que la tenia no me reconocel el parametro de conexion, asi que lo modifique y al parecer ya quedo. Pero gracias de todos modos.

SALUDOS !!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:28.