Foros del Web » Programas, Hardware y Redes » Ofimática »

Agrupar datos en excel

Estas en el tema de Agrupar datos en excel en el foro de Ofimática en Foros del Web. Bien ncesito hacer que los datos que tengan el mismo codigo se agrupen para poder sumarlos despues y tener un total estos datos estan distribuidos ...
  #1 (permalink)  
Antiguo 09/10/2009, 11:52
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Agrupar datos en excel

Bien ncesito hacer que los datos que tengan el mismo codigo se agrupen para poder sumarlos despues y tener un total

estos datos estan distribuidos en filas con cada producto

en las columnas estan en este orden

Cod - Cantidad - Codigo base - Monto


Yo necesito es agrupar los que tengan el mismo codigo base para despues sumarlos todos como un unico producto
  #2 (permalink)  
Antiguo 09/10/2009, 12:00
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

Puedes usar sumar.si, o en la pestaña de inicio viene ordenar o agregar filtro. Todo depende del tamaño de tu base de datos. ¿Podrias poner algún ejemplo para aterrizar mas la forma de resolverlo?

Saludos
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009
  #3 (permalink)  
Antiguo 09/10/2009, 12:12
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Agrupar datos en excel

Aca dejo un ejemplo para que lo vean

necesito agrupar lo que esta en rojo (codigo base) y sumar todos los resultasdos de cantidades mensuales donde coincidan el codigo base.

algo asi como la opcion de agrupar en una consulta de acces

ttp://rapidshare.de/files/48493911/ej.rar.html

agregenle al enlace la h
  #4 (permalink)  
Antiguo 09/10/2009, 12:17
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

¡¡¡changos!!! Ando ocupando el rapidshare para descargar un disco. En cuanto termine comienzo a revisar el tuyo

Saludos
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009
  #5 (permalink)  
Antiguo 09/10/2009, 12:19
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Agrupar datos en excel

Aca esta la descarga directa del ejemplo

xtremesystem.com.ar/ej.rar
  #6 (permalink)  
Antiguo 09/10/2009, 12:26
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

Excelente, reviso y reenvio


[Edición]
Aunque viene el ejemplo de uso de filtros, se me hizo mas comodo trabajar con la funcion SUMAR.SI aqui esta el archivo

Saludos
[/Edición]
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009

Última edición por caesar.l; 09/10/2009 a las 12:40 Razón: Subir archivos
  #7 (permalink)  
Antiguo 09/10/2009, 13:11
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Agrupar datos en excel

Che gracias me vinode 10 la ayuda gracias por estar siempre ayudando y aportando es bueno que haya gente como vos en la web
  #8 (permalink)  
Antiguo 09/10/2009, 13:14
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

De nada
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009
  #9 (permalink)  
Antiguo 09/10/2009, 13:24
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Agrupar datos en excel

se puede en el sumar si agregar varias condiciones con la funcion

O
  #10 (permalink)  
Antiguo 09/10/2009, 13:34
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

Te recomendaria el SUMAR.SI.CONJUNTO

Saludos
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009
  #11 (permalink)  
Antiguo 09/10/2009, 13:49
 
Fecha de Ingreso: agosto-2009
Mensajes: 45
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: Agrupar datos en excel

no con sumar si conjunto no me dio es decir cuansolo agrego un criterio funciona pero si quiero agregar mas me devuelve el valor 0 (cero)
  #12 (permalink)  
Antiguo 10/10/2009, 08:56
Avatar de caesar.l  
Fecha de Ingreso: febrero-2007
Ubicación: Aguascalientes, México
Mensajes: 1.436
Antigüedad: 7 años, 6 meses
Puntos: 91
Respuesta: Agrupar datos en excel

Y si usas dos SUMAR.SI, algo como

Código vb:
Ver original
  1. = SUMAR.SI(Cod_Base, Condicion_1, Monto) +  SUMAR.SI(Cod_Base, Condicion_2, Monto)

Saludos
__________________
Descanse en paz
Jacoba Elvira Escamilla Rocha
1939-2009

Última edición por caesar.l; 10/10/2009 a las 08:57 Razón: Mejorar codigo
  #13 (permalink)  
Antiguo 10/10/2009, 14:48
 
Fecha de Ingreso: julio-2006
Ubicación: Madrid
Mensajes: 926
Antigüedad: 8 años, 1 mes
Puntos: 55
Respuesta: Agrupar datos en excel

Hola,
Con más de una condición se puede hacer con sumaproducto. Por ejemplo:

Código:
=SUMAPRODUCTO((C2:C72=51618)*(D2:D72<100000)*D2:D72)
Esta fórmula sumaría de la última de tus columnas, cuando el código base fuera 51618 y la cantidad mensual fuera menor a 100000.

Si alguna de esas dos condiciones no se da, no suma.

Saludos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:43.
SEO by vBSEO 3.3.2