Foros del Web » Programas, Hardware y Redes » Ofimática »

Ayuda en la Funcion SI de Excel

Estas en el tema de Ayuda en la Funcion SI de Excel en el foro de Ofimática en Foros del Web. Tengo una duda Necesito usar una formula como esta =SI(A2=10, "DIEZ",)&SI(A2=9, "NUEVE").... Asi sucesivamente, donde A2 es la celda donde tengo un valor entre el ...
  #1 (permalink)  
Antiguo 10/10/2006, 20:50
Avatar de dynasty3320  
Fecha de Ingreso: octubre-2006
Ubicación: En Helsinki, Finlandia
Mensajes: 10
Antigüedad: 8 años
Puntos: 0
Sonrisa Ayuda en la Funcion SI de Excel

Tengo una duda

Necesito usar una formula como esta

=SI(A2=10, "DIEZ",)&SI(A2=9, "NUEVE")....

Asi sucesivamente, donde A2 es la celda donde tengo un valor entre el 5 y el 10 y la celda A3 que es en la que tengo la formula me da por resultado lo que hay en la celda A2 pero en letra por eso lo de ...A2=10,"Diez",... pero uso el sibolo "&" y no debo usarlo como... necesito que me ayuden o me digan que poner en lugar del & y que la formula funcione normalmente.

gracias...
  #2 (permalink)  
Antiguo 10/10/2006, 21:55
Avatar de BrujoNic
Moderador
 
Fecha de Ingreso: noviembre-2001
Ubicación: Costa Rica/Nicaragua
Mensajes: 15.383
Antigüedad: 12 años, 11 meses
Puntos: 422
Pasar de números a letras en Excel
__________________
La tecnología está para ayudarnos. No comprendo el porqué con esa ayuda, la gente escribe TAN MAL.
NO PERDAMOS NUESTRO LINDO IDIOMA ESPAÑOL
  #3 (permalink)  
Antiguo 11/10/2006, 17:42
Avatar de medinauta  
Fecha de Ingreso: diciembre-2002
Ubicación: Guayaquil
Mensajes: 159
Antigüedad: 11 años, 10 meses
Puntos: 0
Cita:
=SI(A2=10, "DIEZ",)&SI(A2=9, "NUEVE")
Deberia quedar asi:
Código PHP:
=IF(A2=5;"Cinco";IF(A2=6;"Seis";IF(A2=7;"Siete";IF(A2=8;"Ocho";IF(A2=9;"Nueve";IF(A2=10;"Diez";"Valor no esta entre 5 y 10")))))) 
En lugar de "&" debes usar ";" (punto y coma) o "," (coma) dependiendo como tu sistema este configurado para el separador de listas que lo puedes interpretar como "caso contrario".
  #4 (permalink)  
Antiguo 12/10/2006, 08:13
Avatar de juancace  
Fecha de Ingreso: febrero-2006
Ubicación: Zona Norte del Gran Bs As
Mensajes: 89
Antigüedad: 8 años, 8 meses
Puntos: 0
Hola.
Tenés que usar la funcion Si() por algo en particular?.
Porque eso lo podes resolver con un BuscarV(), es otra alternativa.
Si lo necestas, respondeme y te explico.
Saludos!
__________________
JuAnCaCe :arriba:
  #5 (permalink)  
Antiguo 12/10/2006, 11:34
Avatar de medinauta  
Fecha de Ingreso: diciembre-2002
Ubicación: Guayaquil
Mensajes: 159
Antigüedad: 11 años, 10 meses
Puntos: 0
Cita:
Iniciado por medinauta Ver Mensaje
Deberia quedar asi:
Código PHP:
=IF(A2=5;"Cinco";IF(A2=6;"Seis";IF(A2=7;"Siete";IF(A2=8;"Ocho";IF(A2=9;"Nueve";IF(A2=10;"Diez";"Valor no esta entre 5 y 10")))))) 
En lugar de "&" debes usar ";" (punto y coma) o "," (coma) dependiendo como tu sistema este configurado para el separador de listas que lo puedes interpretar como "caso contrario".
Lo siento, en la formula olvide cambiar el "IF" por el "SI", yo utilizo el programa en ingles
  #6 (permalink)  
Antiguo 04/03/2008, 07:28
 
Fecha de Ingreso: marzo-2008
Mensajes: 2
Antigüedad: 6 años, 7 meses
Puntos: 0
Re: Ayuda en la Funcion SI de Excel

Hola a todos, apelo a vuestros conocimientos para encontrar una fórmula en excel.
Tengo una planilla con varios embarques marítimos donde en una de sus columnas indica el lugar de pago de un flete (MVD, BUE, RGD, ASU), y una columna siguiente donde figuran los importe a abonar.
Necesito una fórmula que me permita sumar (agrupar) los importes de los fletes de acuerdo a su lugar de pago ó sea un resumen.
Desde ya agradezco vuestra ayuda y les mando un abrazo
José Luis - Montevideo / Uruguay
  #7 (permalink)  
Antiguo 04/03/2008, 08:03
Avatar de 3pies
Colaborador
 
Fecha de Ingreso: diciembre-2003
Ubicación: Desde una destilería
Mensajes: 2.596
Antigüedad: 10 años, 10 meses
Puntos: 142
Re: Ayuda en la Funcion SI de Excel

Bienvenido al foro JLR60.
Como una imagen vale más que mil palabras...



La función SUMAR.SI es lo que buscas. Si te fijas, antes del primer punto y coma tienes el rango de datos a evaluar (de B2 a B6), luego pones la condición (que sea igual a MVD, entrecomillado), y finalmente, pones el rango a sumar (de A2 a A6) si se cumple esa condición.

Salu2
  #8 (permalink)  
Antiguo 04/03/2008, 08:30
 
Fecha de Ingreso: marzo-2008
Mensajes: 2
Antigüedad: 6 años, 7 meses
Puntos: 0
Re: Ayuda en la Funcion SI de Excel

Cita:
Iniciado por 3pies Ver Mensaje
Bienvenido al foro JLR60.
Como una imagen vale más que mil palabras...



La función SUMAR.SI es lo que buscas. Si te fijas, antes del primer punto y coma tienes el rango de datos a evaluar (de B2 a B6), luego pones la condición (que sea igual a MVD, entrecomillado), y finalmente, pones el rango a sumar (de A2 a A6) si se cumple esa condición.

Salu2
3Pies, un millon de gracias tengo casi solucionado el problema, me funciona con todos los puertos MVD, ASU, RGD pero no funciona con BUE. De todos modos es la fórmula que estaba buscando. Gracias y buena jornada. José Luis
  #9 (permalink)  
Antiguo 04/03/2008, 08:37
Avatar de 3pies
Colaborador
 
Fecha de Ingreso: diciembre-2003
Ubicación: Desde una destilería
Mensajes: 2.596
Antigüedad: 10 años, 10 meses
Puntos: 142
Re: Ayuda en la Funcion SI de Excel

Si no te funciona con BUE, es probablemente porque debe haber algún espacio en blanco antes o después de esa palabra, en la columna donde figura ese lugar de pago.
  #10 (permalink)  
Antiguo 11/10/2008, 10:51
 
Fecha de Ingreso: octubre-2008
Mensajes: 1
Antigüedad: 6 años
Puntos: 0
Respuesta: Ayuda en la Funcion SI de Excel

Hola a todos!, gracias por el foro!, soy nueva y me he quedado flipada!, no sabía que hubiera un foro como este!.
Y después de hacer algo la pelota... ahí va mi duda:
Tengo una función SI, la cual quiero encadenar, pero creo que hay un límite de 7 encadenados... qué hago para mis 9 opciones???, hay alguna solución con la fórmula SI o hay otras alternativas para estos casos???.
Por si no me he explicado bien, tengo dos columnas:
una con número del uno al nueve, y la segunda con un código asociado a ese número. Tengo que crear una fórmula en la que me recoga el valor del código según el número... y como tengo nueve números no me vale la función SI...
Me he explicado bien???.

Gracias a todos!.
  #11 (permalink)  
Antiguo 29/11/2008, 15:14
 
Fecha de Ingreso: noviembre-2008
Mensajes: 1
Antigüedad: 5 años, 11 meses
Puntos: 0
Respuesta: Ayuda en la Funcion SI de Excel

Es la formula que estaba buscando, pero en mi caso tengo que hacer referencia a otra hoja y me da error.
¿Cómo puedo solucionar el problema?
Los datos para realizar la fórmula se encuentran en otra hoja diferente a donde tengo que hacer los cálculos.
GRACIAS.
  #12 (permalink)  
Antiguo 29/11/2008, 22:36
 
Fecha de Ingreso: julio-2008
Mensajes: 99
Antigüedad: 6 años, 3 meses
Puntos: 1
Respuesta: Ayuda en la Funcion SI de Excel

dolphins, yo he tenido el mismo problema, y lo he resuelto con un truquito que me he encontrado de suerte, resulta que el Open Office puede anidar mas condiciones dentro de la funcion si, entonces lo que hago es abrir el archivo creado en excell con Open Office, agrego las condiciones que me hacen falta en la formula guardo, cierro y lo abro nuevamente en excell.

BRUT, no debe presentar ningun error, si quieres deja la formula que estas usando para revisarla con una breve explicacion del resultado que necesitas.

CHAO
  #13 (permalink)  
Antiguo 30/11/2008, 01:46
 
Fecha de Ingreso: julio-2006
Ubicación: Madrid
Mensajes: 927
Antigüedad: 8 años, 3 meses
Puntos: 55
Respuesta: Ayuda en la Funcion SI de Excel

Hola,
Para solucionar la limitación del SI, excel usa la función BuscarV.

Un saludo
  #14 (permalink)  
Antiguo 01/12/2008, 04:29
Avatar de ceSharp  
Fecha de Ingreso: octubre-2008
Ubicación: Madrid
Mensajes: 495
Antigüedad: 6 años
Puntos: 64
Respuesta: Ayuda en la Funcion SI de Excel

Hola a todos los de la duda de la 'séptima condición'. Hay una solución un poco mas clara (al menos a mi parecer) a todo esto. Pongamos un ejemplo que así se ve todo mejor:
- Necesitamos saber el número de mes que pone en la celda A1. -
- En la celda C1 exponemos la fórmula =SI(A1=1;"ene";SI(A1=2;"feb"...
- La séptima condición sería hacer referencia a otra celda. Esta sería la fórmula completa de C1:
=SI(A1=1;"ene";SI(A1=2;"feb";SI(A1=3;"mar";SI(A1=4 ;"abr";SI(A1=5;"may";SI(A1=6;"jun";SI(A1=7;"jul";C 2)))))))
- Y en la celda C2 seguir con la fórmula:
=SI(A1=8;"ago";SI(A1=9;"sep";SI(A1=10;"oct";SI(A1= 11;"nov";SI(A1=12;"dic")))))

afortunadamente esto no ocurre ya en office 2007 (al menos 12 condiciones permite... no he probado mas)
Espero que os sirva.

Salu2
  #15 (permalink)  
Antiguo 01/12/2008, 19:19
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 7 meses
Puntos: 85
Respuesta: Ayuda en la Funcion SI de Excel

Hola!. Una alternativa a lo anterior pero con una sola fórmula sería:

Excel en español:
= ELEGIR(A1; "Ene"; "Feb"; "Mar"; "Abr"; "May"; "Jun"; "Jul"; "Ago"; "Set"; "Oct"; "Nov"; "Dic")

Excel en inglés:
= CHOOSE(A1, "Ene", "Feb", "Mar", "Abr", "May", "Jun", "Jul", "Ago", "Set", "Oct", "Nov", "Dic")


Saludos, Cacho.
  #16 (permalink)  
Antiguo 01/12/2008, 19:27
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 7 meses
Puntos: 85
Respuesta: Ayuda en la Funcion SI de Excel

Hola!. Y, ya que estamos, otra alternativa más sencilla aún sería:

Excel en español:
= FECHA(2009; A1; 1)

Excel en inglés:
= DATE(2009, A1, 1)

Naturalmente, la celda en la que se coloca esta fórmula debe tener un formato personalizado de fecha como:

mmm
ó
mmmm

por ejemplo.
Saludos, Cacho.
  #17 (permalink)  
Antiguo 08/04/2009, 06:24
 
Fecha de Ingreso: abril-2009
Mensajes: 1
Antigüedad: 5 años, 6 meses
Puntos: 0
Respuesta: Ayuda en la Funcion SI de Excel

Tengo algo todavía más complicado que necesito la función SI, pues es la única que sé usar la de Buscar no me aclaro con las indicciones de excel. Trabajo con ecel 2003. Necesito anidar 64 condiciones que parten de otras 3, cuando hago las 7 primeras, no hay problema... He visto soluciones que no termino de comprender, expongo lo que necesito

Pax Duración Diseño PVP
1 1 1 11.000
1 1 2 12.900
1 1 3 13.000
1 1 4 14.000
1 2 1 18.000
1 2 2 25.000

Que en una únca celda, si se da la condición completa de la primera fila, 1;1;1, me dé el valor de 11.000, pero si se cambia esta cndición a 1;2;1, me dé el valor de 18.000, así tengo hasta 70 condiciones diferentes. La fórmula para 7 condiciones es: =SI(Y(C14="1";D14="1";E14="1");G18;SI(Y(C14="1";D1 4="1";E14="2");G19;SI(Y(C14="1";D14="1";E14="3");G 20;SI(Y(C14="1";D14="1";E14="4");G21;SI(Y(C14="1"; D14="2";E14="1");G22;SI(Y(C14="1";D14="2";E14="2") ;G23;SI(Y(C14="1";D14="2";E14="3");G24))))))) y funciona (he copiado mi fórmula que no coincide con a1 etc., ¿Qué hago con el resto de condiciones?

Lo necesito de forma urgente, estoy bloqueda! mil gracias!

Última edición por calmagro; 08/04/2009 a las 06:25 Razón: me he confundido con la versión de excel
  #18 (permalink)  
Antiguo 19/06/2009, 02:07
 
Fecha de Ingreso: junio-2009
Mensajes: 1
Antigüedad: 5 años, 4 meses
Puntos: 0
Información Respuesta: Ayuda en la Funcion SI de Excel

hola amigos que tal soy nuevo en este foro y quisiera ver si me podian ayudar con un problema el tema es el siguiente tengo una planilla donde me piden calcular la pension del alumno segun el turno y el ciclo que este, estuve tratando de usar la funcion si pero no me sale

TURNO CICLO PENSION
M I
M III
M V
T IV
N III
T I
N VI
M V

este es la referencia que nos dan si el alumno se encuentra en alguno de estos rangos se le debe de descontar el monto que se indica en pension

TABLA

TURNO CICLO PENSION

M I,II,III 150
IV,V,VI 200


T I,II 120
III,IV 150
V,VI 180

N I,II,III 200
IV,V,VI 220

le agradeceria si me pudieran ayudar

Última edición por CASAGU; 19/06/2009 a las 02:15 Razón: el cuadro no me salio centrado
  #19 (permalink)  
Antiguo 19/06/2009, 10:32
Avatar de jlsoutoz  
Fecha de Ingreso: junio-2009
Ubicación: Buenos Aires
Mensajes: 67
Antigüedad: 5 años, 4 meses
Puntos: 2
Respuesta: Ayuda en la Funcion SI de Excel

Cita:
Iniciado por calmagro Ver Mensaje
Tengo algo todavía más complicado que necesito la función SI, pues es la única que sé usar la de Buscar no me aclaro con las indicciones de excel. Trabajo con ecel 2003. Necesito anidar 64 condiciones que parten de otras 3, cuando hago las 7 primeras, no hay problema... He visto soluciones que no termino de comprender, expongo lo que necesito

Pax Duración Diseño PVP
1 1 1 11.000
1 1 2 12.900
1 1 3 13.000
1 1 4 14.000
1 2 1 18.000
1 2 2 25.000

Que en una únca celda, si se da la condición completa de la primera fila, 1;1;1, me dé el valor de 11.000, pero si se cambia esta cndición a 1;2;1, me dé el valor de 18.000, así tengo hasta 70 condiciones diferentes. La fórmula para 7 condiciones es: =SI(Y(C14="1";D14="1";E14="1");G18;SI(Y(C14="1";D1 4="1";E14="2");G19;SI(Y(C14="1";D14="1";E14="3");G 20;SI(Y(C14="1";D14="1";E14="4");G21;SI(Y(C14="1"; D14="2";E14="1");G22;SI(Y(C14="1";D14="2";E14="2") ;G23;SI(Y(C14="1";D14="2";E14="3");G24))))))) y funciona (he copiado mi fórmula que no coincide con a1 etc., ¿Qué hago con el resto de condiciones?

Lo necesito de forma urgente, estoy bloqueda! mil gracias!
esto ya estaba respondido mas arriba, pero tal vez pueda ser mas claro explicandolo una vez mas.

supongamos que tu formula esta en la celda a1, pero con una salvedad, en ves de tener puesta la septima condicion tal cual esta, reemplazalo por A2

quedaria asi:

=SI(Y(C14="1";D14="1";E14="1");G18;SI(Y(C14="1";D1 4="1";E14="2");G19;SI(Y(C14="1";D14="1";E14="3");G 20;SI(Y(C14="1";D14="1";E14="4");G21;SI(Y(C14="1"; D14="2";E14="1");G22;SI(Y(C14="1";D14="2";E14="2") ;G23;A2)))))))

donde quedarian 6 condiciones mas las condiciones de a2

en la celda A2 poner las condiciones desde la septima, hasta la doce, es decir 6 mas y la septima haciendola vincular con a3 (donde tendras de la condicion 13 hasta la 18 mas a4, y asi sucesivamente hasta completar las 70 y algo que tengas.

espero haber sido claro

saludos

PD: cualquier cosa me avisas y te ayudo por MP
  #20 (permalink)  
Antiguo 20/07/2009, 12:56
 
Fecha de Ingreso: junio-2008
Mensajes: 1
Antigüedad: 6 años, 4 meses
Puntos: 0
Respuesta: Ayuda en la Funcion SI de Excel

Salu2 a to2.

Pregunta:
¿Cuantas funciones SI encadenados podemos tener?
Tengo una funcion que determina el un valor estandar para cierto rango de anchos de banda, pero he tenido que separarlo en 2 dado que me da un error.
G4 es el BW ingresado, k13 es el máximo.

=SI(G4>K13;"SUPERA EL BW MAXIMO";SI(G4>9540;10000;SI(G4>8640;9000;SI(G4>756 0;8000;SI(G4>6600;7000;SI(G4>5500;6000;SI(G4>4600; 5000;SI(G4>3600;4000;H5))))))))

Donde la celda H5 =

=SI(G4>2400;3000;SI(G4>1150;2000;SI(G4>44;1000;0)) )

No he logrado que esto funcione completo, es decir:
=SI(G4>K13;"SUPERA EL BW MAXIMO";SI(G4>9540;10000;SI(G4>8640;9000;SI(G4>756 0;8000;SI(G4>6600;7000;SI(G4>5500;6000;SI(G4>4600; 5000;SI(G4>3600;4000;SI(G4>2400;3000;SI(G4>1150;20 00;SI(G4>44;1000;0)))))))))))

¿Es limitacion de excel o es un error de escritura?
  #21 (permalink)  
Antiguo 20/07/2009, 15:40
Colaborador
 
Fecha de Ingreso: agosto-2004
Mensajes: 1.556
Antigüedad: 10 años, 2 meses
Puntos: 39
Respuesta: Ayuda en la Funcion SI de Excel

Bienvenid@ raptime:
Excel sólo te permite 7 anidaciones...
Abre los parámetros del BW..
Saludos...
  #22 (permalink)  
Antiguo 24/08/2009, 09:43
Avatar de korybante  
Fecha de Ingreso: agosto-2009
Mensajes: 1
Antigüedad: 5 años, 2 meses
Puntos: 0
Respuesta: Ayuda en la Funcion SI de Excel

Que es eso de abrir parametro
  #23 (permalink)  
Antiguo 28/10/2009, 15:36
 
Fecha de Ingreso: mayo-2009
Mensajes: 2
Antigüedad: 5 años, 5 meses
Puntos: 0
consulta

Estoy trabajando en una tabla estadistica , mi principal dificultad es que no se que fòrmula emplear para que los valores de los intervalos lo reconozca el excel, es decir que al hallar la freceuncia el programa considera por ejemplo al valor 26 se considera en el primer intervalo, pero el intervalo diec que debe pertenecer al intervalo 2

Ii fi
[20;26> 3
[26;32> 1
[32;38> 7

Última edición por ciberteacher; 28/10/2009 a las 15:49
  #24 (permalink)  
Antiguo 29/10/2009, 09:16
Avatar de ceSharp  
Fecha de Ingreso: octubre-2008
Ubicación: Madrid
Mensajes: 495
Antigüedad: 6 años
Puntos: 64
Respuesta: Ayuda en la Funcion SI de Excel

Hola chicos,

Por un lado ciberteacher,
no entiendo bien tu duda. podrías ser más explicito o poner un ejemplo claro de lo que quieres?

por otro lado korybante,
la pregunta es de agosto. pero bueno, acabo de leerla y no puedo evitar responder.

en excel podemos usar más de 7 condiciones. el único 'pero' es que tenemos que apuntar a otra celda para continuar con las condicionales:

=SI(A1=1;"UNO";SI(A1=2;"DOS";SI(A1=3;"TRES";SI(A1= 4;"CUATRO";SI(A1=5;"CINCO";SI(A1=6;"SEIS";B1)))) )) --> (no sé ni cuantos paréntesis he puesto... jejejeje)

la cosa es que la séptima condición apunta a B1. y en B1 podemos seguir:

=SI(A1=7;"SIETE"......... y así hasta el infinito.

salu2
  #25 (permalink)  
Antiguo 29/10/2009, 09:35
 
Fecha de Ingreso: julio-2006
Ubicación: Madrid
Mensajes: 927
Antigüedad: 8 años, 3 meses
Puntos: 55
Respuesta: Ayuda en la Funcion SI de Excel

Hola,
No es por repetirme, pero en este mismo post, de noviembre de 2008 por cierto, comentaba que para el uso de más de 7 condiciones, microsoft excel recomienda el uso de buscarv o buscarh.
Con el uso de estas funciones no hace falta apuntar a ninguna otra celda, y la fórmula es mucho más corta y sencilla de leer.
Sólo hace falta un rango de celdas alternativo, en esa hoja o en otra, donde se especifiquen los intervalos de valores para las condiciones.


Saludos
  #26 (permalink)  
Antiguo 29/10/2009, 10:08
Avatar de ceSharp  
Fecha de Ingreso: octubre-2008
Ubicación: Madrid
Mensajes: 495
Antigüedad: 6 años
Puntos: 64
Respuesta: Ayuda en la Funcion SI de Excel

Totalmente de acuerdo contigo jchuk,

PERO (jejeje, siempre hay un pero...) por un lado, sobre todo para los principiantes, usar BUSCARV y BUSCARH es un poco complejo el plantearse cuando hay que utilizarlo, mientras que SI es bastante sencillo de formular y usando la 'lógica mental' es más sencillo de aplicar.

Por otro lado he respondido porque 'categoricamente' decían que NO se pueden poner más de 7 condiciones con SI, y realmente dentro de una celda no se puede, pero si se pueden concatenar unas detrás de otras.

Aún así insisto en que llevas razón; es recomendable usar las funciones BUSCARV y BUSCARH.

salu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Tema Cerrado

SíEste tema le ha gustado a 8 personas (incluyéndote)




La zona horaria es GMT -6. Ahora son las 22:38.
SEO by vBSEO 3.3.2