Foros del Web » Soporte técnico » Ofimática »

[SOLUCIONADO] buscarv con rango de valores

Estas en el tema de buscarv con rango de valores en el foro de Ofimática en Foros del Web. hola a [email protected], a ver si me pueden ayudar Me gustaría saber como poner en una columna un valor dependiendo de un rango que hay ...
  #1 (permalink)  
Antiguo 24/09/2014, 01:41
 
Fecha de Ingreso: abril-2011
Mensajes: 39
Antigüedad: 8 años, 7 meses
Puntos: 1
buscarv con rango de valores

hola a [email protected],

a ver si me pueden ayudar

Me gustaría saber como poner en una columna un valor dependiendo de un rango que hay predeterminado en otra celda, es decir,

A B C
1000 2000 10
2001 3000 20
3001 4000 30


Si yo pongo en la casilla F8 un valor de 1500 en la F9 tendría que aparecer 10 que es el valor que hay entre A y B
Y si pongo en F8 el valor 3100, en la F9 me tendría que aparecer 30 que es el valor que hay entre A y B de la fila 4

Espero haberme explicado,

Muchas gracias
  #2 (permalink)  
Antiguo 24/09/2014, 12:35
Avatar de Omura
Colaborador
 
Fecha de Ingreso: julio-2006
Ubicación: Peru
Mensajes: 3.491
Antigüedad: 13 años, 4 meses
Puntos: 185
Respuesta: buscarv con rango de valores

si necesitas que tome el valor de las celdas, puedes usar algo como esto...

=SI(Y(F8>=A1,F8<=B1),C1,SI(Y(F8>=A2,F8<=B2),C2,SI( Y(F8>=A3,F8<=B3),C3,"fuera de rango")))

ahora si los valores van a ser fijos puedes considerarlos directo en la formula...

=SI(Y(F1>=1000,F1<=2000),10,SI(Y(F1>=2001,F1<=3000 ),20,SI(Y(F1>=3001,F1<=4000),30,"fuera de rango")))
__________________
Mi error era de código... pero de código genético.
  #3 (permalink)  
Antiguo 25/09/2014, 02:20
 
Fecha de Ingreso: julio-2006
Ubicación: Madrid
Mensajes: 943
Antigüedad: 13 años, 3 meses
Puntos: 56
Respuesta: buscarv con rango de valores

Hola,

La opción de Omura es buena.

Planteo otra por si es viable, en el caso de que la tabla sea muy extensa, en cuyo caso la función SI sugerida por Omura se haría muy larga, difícil de leer, interpretar y mantener.

Para que funcione la tabla debería estar ordenada al contrario que se indica en el ejemplo, es decir, primero el valor de 3001 a 4000, en la fila de debajo el de valor 2001 a 3000 y en la última fila el de 1000 a 2000.

Suponiendo que esta tabla esté en el rango A1:B3 y el valor a buscar esté, por ejemplo, en la celda E1, en la celda E2 pondría esta fórmula:

=INDICE($A$1:$C$3;COINCIDIR(F1;$B$1:$B$3;-1);3)

Esta fórmula es mucho más corta y más fácil de mantener si la tabla en lugar de 3 filas tiene un tamaño mucho mayor, ya que la fórmula no crecería, sólo vararían los rangos en ella indicada.

Saludos!!
  #4 (permalink)  
Antiguo 25/09/2014, 07:22
 
Fecha de Ingreso: abril-2011
Mensajes: 39
Antigüedad: 8 años, 7 meses
Puntos: 1
Respuesta: buscarv con rango de valores

Muchas gracias a los dos por la pronta respuesta

Lo probaré y os cuento cual es la que mejor se adapta a mi necesidad.

Lo dicho, muchas gracias
  #5 (permalink)  
Antiguo 29/09/2014, 05:59
 
Fecha de Ingreso: abril-2011
Mensajes: 39
Antigüedad: 8 años, 7 meses
Puntos: 1
Respuesta: buscarv con rango de valores

Muchas gracias a los dos por la pronta respuesta

Me funcionó la segunda respuesta, la de jchuk, asi que con eso me vale


Gracias

Etiquetas: excel
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 17:17.