Foros del Web » Soporte técnico » Ofimática »

Duda con macro en excel

Estas en el tema de Duda con macro en excel en el foro de Ofimática en Foros del Web. Buenas tardes a todos, tengo un problema con excel y quiero ver si alguien puede ayudarme: en un libro de excel tengo un reporte larguisimo ...
  #1 (permalink)  
Antiguo 23/07/2010, 19:42
 
Fecha de Ingreso: octubre-2004
Mensajes: 26
Antigüedad: 18 años, 1 mes
Puntos: 0
Duda con macro en excel

Buenas tardes a todos, tengo un problema con excel y quiero ver si alguien puede ayudarme: en un libro de excel tengo un reporte larguisimo de productos enlistados de la sig. manera:
A B C D E F
1 tipo fecha descripcion entrada salida saldo
2
3 Inv. inicial 01/01/09 corbata gris 5
4 compras 02/02/09 corbata gris 10
5 ventas 05/05/09 corbata gris 1
6 ventas 10/06/09 corbata gris 1
7 ventas 12/09/09 corbata gris 1
8 ventas 15/10/09 corbata gris 1
9 ventas 20/12/09 corbata gris 1
10 saldo final 31/12/09 corbata gris 5
en si lo que necesito es una macro que por ejemplo le pueda dar estos datos:
1)identifique fila en que empieza "corbata gris" en este caso empieza en la fila C3
2)identifique fila en que termina "corbata gris" en este caso termina en la fila C10
3)realizar sig operacion:
a) =SUMA(D3:D10)+F3, y restar la =SUMA(E3:E10). si el resultado es igual a F10, entonces fin.
b) si el resultado es menor que F10, entonces insertar el numero de filas de la dif en la fila 9 (por ejemplo, en este caso la sumatoria es 15 - 5 = el resultado deberia ser 10, mas sin embargo el en F10 hay 5., por lo que por ser 5 de diferencia, en A9 se deben de insertar 5 filas.
en realidad no se si fui claro o si se pueda hacer.. les agradezco de antemano toda la ayuda que me puedan brindar..

Etiquetas: excel, macro
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:22.