Foros del Web » Soporte técnico » Ofimática »

[SOLUCIONADO] Excel. Seleccionar suma varias celdas teniendo el total

Estas en el tema de Excel. Seleccionar suma varias celdas teniendo el total en el foro de Ofimática en Foros del Web. Buenos días a todos. A ver si me explico... En la columna 'A' tengo una serie de cantidades aleatorias, unas 150 celdas. Y en la ...
  #1 (permalink)  
Antiguo 01/06/2017, 01:55
 
Fecha de Ingreso: julio-2013
Mensajes: 8
Antigüedad: 4 años, 3 meses
Puntos: 0
Excel. Seleccionar suma varias celdas teniendo el total

Buenos días a todos. A ver si me explico...

En la columna 'A' tengo una serie de cantidades aleatorias, unas 150 celdas.

Y en la celda 'B1' tengo una cantidad, que es la suma de 3 celdas de la columna 'A', pero no se que celdas son.

¿Hay alguna forma de hallar estas 3 celdas?, puede que haya más de 1 posibilidad, es decir, puede que haya más de 1 grupo de 3 celdas que sumen esa cantidad.

Muchas gracias
Un saludo
  #2 (permalink)  
Antiguo 21/07/2017, 12:38
Avatar de flashmax  
Fecha de Ingreso: julio-2012
Ubicación: Bs.As. Argentina
Mensajes: 506
Antigüedad: 5 años, 2 meses
Puntos: 86
Respuesta: Excel. Seleccionar suma varias celdas teniendo el total

Lo tienes que hacer con el complemento solver
ve a obsiones ---> complementos ---> activa solver
ejemplo:
Código:
ingresa los valores en el rango A1:A20
en el rango B1:B20 todas las celdas con el valo 1
en la celda B21 =SUMAPRODUCTO(A1:A20;B1:B20)
posicionado sobre la celda B21 abres solver de la barra de herramientas.
en la ventana ingresa:
objetivo $B$21
valor de : pones tu total
cambiando celdas de variable: $B$1:$B$20
sujeto a restricciones...agregar nuevo.....referencia de celda $B$1:$B$20=binario
aceptar y resolver.
en el rango B1:B20 las celdas que queden en 1 son las celdas que suman tu valor.
__________________
Saludos!
----------------------------------------------------------
  #3 (permalink)  
Antiguo 29/08/2017, 01:52
 
Fecha de Ingreso: julio-2013
Mensajes: 8
Antigüedad: 4 años, 3 meses
Puntos: 0
Respuesta: Excel. Seleccionar suma varias celdas teniendo el total

Cita:
Iniciado por flashmax Ver Mensaje
Lo tienes que hacer con el complemento solver
ve a obsiones ---> complementos ---> activa solver
ejemplo:
Código:
ingresa los valores en el rango A1:A20
en el rango B1:B20 todas las celdas con el valo 1
en la celda B21 =SUMAPRODUCTO(A1:A20;B1:B20)
posicionado sobre la celda B21 abres solver de la barra de herramientas.
en la ventana ingresa:
objetivo $B$21
valor de : pones tu total
cambiando celdas de variable: $B$1:$B$20
sujeto a restricciones...agregar nuevo.....referencia de celda $B$1:$B$20=binario
aceptar y resolver.
en el rango B1:B20 las celdas que queden en 1 son las celdas que suman tu valor.
Hola, muchas gracias por la respuesta.
En parte me funciona, digo en parte porque si hay más de una solución no se como hacer para que me muestre más posibilidades.

Un saludo



La zona horaria es GMT -6. Ahora son las 15:07.