Foros del Web » Programas, Hardware y Redes » Ofimática »

extraer mes y año

Estas en el tema de extraer mes y año en el foro de Ofimática en Foros del Web. escribo una fecha 01/08/2008 quiero extraer en excel el mes y el año quiero sacar esto asi 0808 ¿Alguien sabe como puedo hacer eso en ...
  #1 (permalink)  
Antiguo 03/02/2010, 08:15
 
Fecha de Ingreso: mayo-2008
Mensajes: 181
Antigüedad: 6 años, 4 meses
Puntos: 0
Pregunta extraer mes y año

escribo una fecha 01/08/2008
quiero extraer en excel el mes y el año
quiero sacar esto asi
0808

¿Alguien sabe como puedo hacer eso en excel?Es que con extraer me pide que sea formato texto...

Gracias
  #2 (permalink)  
Antiguo 03/02/2010, 08:21
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.703
Antigüedad: 9 años, 6 meses
Puntos: 823
Respuesta: extraer mes y año

Puedes asignar a la celda un formato personalizado (MMYY), o si realmente quieres extraer el mes y el año tienes las funciones MES() y AÑO()
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 03/02/2010, 08:23
Avatar de abimaelrc
Colaborador
 
Fecha de Ingreso: mayo-2009
Ubicación: En el planeta de Puerto Rico
Mensajes: 14.701
Antigüedad: 5 años, 5 meses
Puntos: 1494
Respuesta: extraer mes y año

Si ya tienes un campo que tiene declarado unas fechas especificamente, puedes usar la función MID.
__________________
Verifica antes de preguntar.
Los verdaderos amigos se hieren con la verdad, para no perderlos con la mentira. - Eugenio Maria de Hostos
  #4 (permalink)  
Antiguo 04/02/2010, 05:03
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 6 meses
Puntos: 85
Respuesta: extraer mes y año

Intenta:

= TEXTO( A1; "mmaa")

Saludos, Cacho.
  #5 (permalink)  
Antiguo 04/02/2010, 09:34
 
Fecha de Ingreso: agosto-2007
Mensajes: 1.827
Antigüedad: 7 años, 2 meses
Puntos: 36
Respuesta: extraer mes y año

Cita:
Iniciado por mrocf Ver Mensaje
Intenta:

= TEXTO( A1; "mmaa")

Saludos, Cacho.
Será? = TEXTO( A1; "mmyy")
__________________
Las contraseñas son como la ropa interior: Nunca tienes que dejarlas donde la gente pueda verlas, tienes que cambiarlas regularmente y no tienes que dejárselas a extraños
  #6 (permalink)  
Antiguo 04/02/2010, 11:13
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 6 meses
Puntos: 85
De acuerdo Extraer mes y año

Hola! JoaoM.
No estaba entendiendo la razón de ser tu comentario hasta que advertí el concepto que -pareces- desconocer.

En efecto, estamos hablando de la Configuración Regional de la PC.
Mira en el siguiente enlace una página de MS traducida -simultáneamente- al español y al inglés: Información acerca de la configuración en el cuadro de diálogo "Formato de celdas" en Excel 2007.

¿Notaste que en la versión en español se referencia al año con "a" mientras que en la versión en inglés se lo hace con "y"?
Pues esa alternativa se maneja a través del "Idioma" de la Configuración Regional.

Por ello te hablaba inicialmente de lo que desconocías. Así, tu comentario debió haber sido más o menos así:

- "Si el idioma de la Configuración Regional de tu PC está en inglés, entonces la fórmula a utilizar es:

= TEXTO( A1; "mmyy")

Claro que si aclarabas ésto también tendrías que haber aclarado:

- "Y si tienes la versión de Excel en inglés, tu fórmula podría ser:

= TEXT(A1, "mmyy")

En resumen: no compliquemos una respuesta sencilla.

Saludos, Cacho.


Cita:
Iniciado por JoaoM Ver Mensaje
Será? = TEXTO( A1; "mmyy")
  #7 (permalink)  
Antiguo 05/02/2010, 15:48
 
Fecha de Ingreso: agosto-2007
Mensajes: 1.827
Antigüedad: 7 años, 2 meses
Puntos: 36
Respuesta: Extraer mes y año

Cita:
Iniciado por mrocf Ver Mensaje
[FONT="Comic Sans MS"][SIZE="3"]
Cierto y no soy yo que me pondre adelante, pues mis conocimientos son minimos o casi nulos pero esque;

Mi SO Es Español, mi Excel es Español (OFFICE2007)totalmente ESPAÑOL y no me dá el resultado de mmaa y si mmyy, ¿porque? no lo se yo y,

Por esta razon fue que dije (sin conocimiento de lo expuesto por ti) lo anterior

Gracias por aclararme
__________________
Las contraseñas son como la ropa interior: Nunca tienes que dejarlas donde la gente pueda verlas, tienes que cambiarlas regularmente y no tienes que dejárselas a extraños
  #8 (permalink)  
Antiguo 05/02/2010, 16:48
 
Fecha de Ingreso: julio-2006
Ubicación: Madrid
Mensajes: 927
Antigüedad: 8 años, 2 meses
Puntos: 55
Respuesta: extraer mes y año

Cita:
- "Si el idioma de la Configuración Regional de tu PC está en inglés, entonces la fórmula a utilizar es:

= TEXTO( A1; "mmyy")
  #9 (permalink)  
Antiguo 06/02/2010, 09:41
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 6 meses
Puntos: 85
De acuerdo Configuración Regional de la PC

Hola! amigo JoaoM. Te sugiero que veas lo siguiente:



Observa que en la celda [B1] he colocado el número "40390".
En la celda [B2] he puesto la fórmula = TEXTO($B$1; "dd-mmm-aaaa")
Y en la celda [B3] he puesto la fórmula = TEXTO($B$1; "dd-mmm-yyyy")

Pero, lo más importante a estos efectos: mira que en la configuración regional tengo Español (España).
Esta configuración hace que la primera fórmula sea interpretada correctamente (por el "aaaa") mientras que la segunda fórmula no es interpretada correctamente (por el "yyyy").

Ahora procedemos a modificar la configuración regional del siguiente modo: Inglés (Estados Unidos)



¿Adviertes lo que pasó en el Excel...???
En efecto: la fórmula que antes andaba bien... ¡ahora no!. Mientras que la segunda fórmula pasó a desempeñarse según lo esperado.

Advierte otros detalles "menores": en la primera configuración la "j" de julio está en minúscula mientras que en la segunda configuración la "j" está en mayúscula.

También puedes ver aquello de intercambiarse las "comas" por los "punto y comas". Aunque -asumo que lo sabes- uno puede modificar estos formatos estándares fácilmente.

En fin, como verás: existen diversas posibilidades...

Espero te haya sido de utilidad.
Saludos, Cacho.
  #10 (permalink)  
Antiguo 06/02/2010, 13:45
 
Fecha de Ingreso: agosto-2007
Mensajes: 1.827
Antigüedad: 7 años, 2 meses
Puntos: 36
Respuesta: extraer mes y año

Hye amigo, no quiero que te molestes conmigo por esto, no es mi intencion molestar a nadie.
Se que no estas molesto, al menos asi lo persibo pero, solo expresarte mi intencion.

Pues te dejo esto para que veas que tengo el 2010 en español, lo tenia Español Venezuela pero lo cambie para hacer la prueba y el resultado es el mismo
con las 4 aaaa pero solo dos aa queda 31-jul-aa
Dime si los de arriba estan en su orden o algo está mal.
¿Cualquier de los dos, algo fallido? si coloco en A2 o cualquiera = TEXTO($B$1; "dd-mmm-aaaa") y en B1 40215 me dá 06-feb-sábado, es correcto, hoy sábado 6 feb
¿es correcto
__________________
Las contraseñas son como la ropa interior: Nunca tienes que dejarlas donde la gente pueda verlas, tienes que cambiarlas regularmente y no tienes que dejárselas a extraños

Última edición por JoaoM; 06/02/2010 a las 13:53
  #11 (permalink)  
Antiguo 06/02/2010, 14:45
Avatar de mrocf  
Fecha de Ingreso: marzo-2007
Ubicación: Bs.As.
Mensajes: 1.084
Antigüedad: 7 años, 6 meses
Puntos: 85
Respuesta: extraer mes y año

Pero JoaoM:
Aquí de lo que siempre se ha tratado es de que entendieses (porque creo que ya lo has entendido) que tanto la "a" como la "y" son símbolos válidos para representar un dígito del año... según el contexto.

Ahora tenemos que dar el paso siguiente: ¿Cómo está seteada tu PC?
¿Estamos de acuerdo?

P.D.
¿Notaste que el lenguaje de tu ventana informativa está en portugués?
¿No te parece que eso hace una gran diferencia?

Etiquetas: año, extraer
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:41.
SEO by vBSEO 3.3.2